Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-14-2009, 03:56 PM   #1
New Member




Join Date: Mar 2009
Location: Australia
Posts: 5
FA 80-320 repair

Hi folks, long time reader first time poster. Just thought I'd share my tips for repairing this lens if you come across one with this specific fault. It seems to be common for them to not work on the A setting. I got one from fleabay that was said to be in good working order but ended up having this fault. I liked the lens so settled on a partial refund with the seller, getting it for $120AUD in the end. The optics are perfect.

The repair involves bending the aperture ring A contact wiper slightly. The base of the lens must be carefully removed first. I'm assuming this would only be attempted by someone with some technical skills, it's not for the faint of heart! What happens is that the spring loaded A contact on the lens mount actually pushes the contact for the A wiper contact away as it is mounted on the camera. Hard to explain, but once in there it's pretty obvious. The A wiper that's attached to the aperture ring needs to be removed(small black screw) and the down facing end of it needs to be angled down further. Be careful or it will snap, very easily.

If it does snap, all that needs to happen to make the A setting work is that A setting pin needs to be shorted to the metal of the lens mount.

Hope this is helpful for someone with this lens.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, contact, fault, k-mount, lens, pentax lens, repair, slr lens, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Faulty FA 80-320 EsBee Pentax SLR Lens Discussion 10 08-28-2009 06:49 PM
Trouble with my FA 80 - 320 4.5/5.6..... UpNorth Pentax SLR Lens Discussion 5 01-11-2009 10:59 AM
Fa 80-320 Bife Pentax SLR Lens Discussion 7 01-08-2008 04:32 PM
Annoyed at my 80-320 Arpe Pentax SLR Lens Discussion 25 10-08-2007 09:32 AM



All times are GMT -7. The time now is 04:11 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top