Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-01-2009, 12:21 AM   #1
Site Supporter




Join Date: Mar 2007
Location: Honolulu, Hawaii
Photos: Gallery
Posts: 92
Need Some Help

My DA*300mm lens will not focus using SDM on my K20D. This is my second copy as I sent the first to Pentax for the same problem and they replaced it with what looks to be a returned lens. Before I send this one back I would like to test it on another body capable of using the SDM motor.


If anybody on the Island of Oahu is willing to help it would be appreciated. I could bring a few of the lens listed in my profile to play with while I test the lens.

PM if available.

Terry

05-03-2009, 03:31 PM   #2
Site Supporter




Join Date: Mar 2007
Location: Honolulu, Hawaii
Photos: Gallery
Posts: 92
Original Poster
Bump

10 char
05-03-2009, 03:37 PM   #3
Loyal Site Supporter
Canada_Rockies's Avatar

Join Date: Nov 2007
Location: Sparwood, BC, Canada
Photos: Gallery | Albums
Posts: 9,134
Terry, polish up your contacts on both the camera and the lens. Sometimes this helps a lot. I used micro fibre cloth and alcohol on my 50-135 and it is much better so far.
05-03-2009, 04:19 PM   #4
Site Supporter




Join Date: Mar 2007
Location: Honolulu, Hawaii
Photos: Gallery
Posts: 92
Original Poster
I just tried it but no joy. It's still exhibiting the same symptoms. It will attempt to focus by moving but will never acheive focul lock. Even if I manually focus on a spot and then try to AF it will move out of focus. The other DA 300 axted the same.

My DA 16-50 and 50-135 work just fine. If I'm not able to test the lens on another body I'll send it back next week. Thank you for the advice.

Terry

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-mount, lens, pentax lens, sdm, slr lens, test
Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -7. The time now is 07:05 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top