Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-22-2009, 08:21 PM   #1
Senior Member
fishy's Avatar

Join Date: Aug 2007
Location: Brussels
Photos: Gallery
Posts: 199
Sigma 70-300 giving F-- problem

Hi all,

I know this has been posted before, but I have not been able to solve this issue; hopefully you can help me out..

What happens is that sometimes, and intermittently, when I have my Sigma 70-300 mounted, my K10D seems to lose the aperture control over the lens; it shows an aperture "F--" (like on M lenses). If I fiddle with the lens a bit it comes back..

I have cleaned the contacts, on both lens and camera, and checked the mountscrews.. Nothing there. I hope this is not the end of my Sigma, I really like this lens! Any help appreciated.

Thanks!

05-22-2009, 09:07 PM   #2
Inactive Account




Join Date: May 2009
Location: singapore
Posts: 8
Sigma 70-300 giving F-- problem

make sure your aperture on the lens is set to "A".
Or it could be a loose contact on the lens itself.

good luck
05-22-2009, 11:03 PM   #3
Senior Member
fishy's Avatar

Join Date: Aug 2007
Location: Brussels
Photos: Gallery
Posts: 199
Original Poster
Yeah, aperture ring is set to A allright... If it were a loose contact, I wonder if that would be user serviceable, since I am quite a bit away from any service-center... Has anyone had success fixing this?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, help, k-mount, lens, pentax lens, sigma, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Equipment problem - Pentax K-x, Sigma 100-300 f/4 and AF-C mode WoRaS Pentax DSLR Discussion 9 09-04-2012 03:40 PM
TESTED: Pentax 55-300 vs. Sigma 70-300 vs. Tamron 70-300 falconeye Pentax SLR Lens Discussion 22 05-14-2009 04:01 PM
For Sale - Sold: Quantary 70-300 f4-5.6 LDO Macro (AKA Sigma 70-300 APO) K10Perry Sold Items 6 02-25-2008 09:39 PM
Giving Sigma ''props'' jgredline Pentax SLR Lens Discussion 6 02-12-2008 06:30 PM
Problem with Sigma 70-300 DL Macro VF-19 Pentax SLR Lens Discussion 1 09-02-2007 12:59 PM



All times are GMT -7. The time now is 11:46 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top