Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-18-2009, 10:55 PM   #1
Veteran Member
pbo's Avatar

Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 891
Anyone had experience with Fujinon m42 lenses?

I'm asking because I just got one (Fujinon 55/1.8) - and it's got problems. First of all, its aperture ring, when mounted on a K10D, is pushed right against the body (unlike other lenses, where between the ring and actual mount, there is some distance - and ring turns freely) and just doesn't nudge when mounted. You can sort of see from the picture attached that the rim of aperture ring is on same "level" as the rest of the mount.
Also, there's no auto-manual switch, but that's gonna matter only after I solve the first issue.

Any suggestions what to do? I don't have dremels, drills, etc etc, so it'd be cool if there was a relatively easy solution...

Bo.

Attached Images
View Picture EXIF
PENTAX K10D  Photo 
06-19-2009, 06:06 AM   #2
Veteran Member
georgweb's Avatar

Join Date: Apr 2008
Location: Berlin, Germany
Photos: Gallery
Posts: 1,381
Hi Bo,
not knowing this lens 'in person', I suggest you try the following:

I hope it has got screws at the back which you can unscrew.

Lift off the mount carefully straight up (lens sits on the table like on your pic). Be careful with the pin and other stuff that might be engaged with that ring.

The aperture ring should be ready to lift now. Be carefull, there will be a ball and a spring popping out (might put the whole thing in a plastic box or something before).

If you have managed to hold the aperture ring in your hand as a separate part, put some sandpaper on a flat surface and sand down the ring in circular, even pressurized motions. Be careful with the dust.

Put a little bit of a cotton swab plastic shaft onto the aperture pin when re-assembling, so that it will be pushed in permanently in the right amount.

Hope some of this is applicable to your lens :-)

Best of success, Georg (the other)
06-19-2009, 06:24 AM   #3
Inactive Account




Join Date: Dec 2008
Location: Ames, Iowa, USA
Photos: Albums
Posts: 2,965
Something that has worked for me is to put a spacer between the lens and adapter:

I've used a ring made of wire bent to the appropriate radius. You can estimate how thick a spacer you need by unscrewing the lens while it is mounted.

Iowa Dave

PS ignore the superfluous stuff in the image.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, fujinon, k-mount, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: EBC Fujinon SW 28mm/3.5 SET, M42 mount (Worldwide) philipxzy Sold Items 1 03-14-2010 05:51 PM
For Sale - Sold: M42 Lenses. Pentax Taks 35mm, 135mm, 55mm, Fujinon 55mm Peter Zack Sold Items 5 03-04-2010 05:24 PM
Any K-x user experience with M42 lens (Gus, please help) hinman Pentax DSLR Discussion 18 02-04-2010 02:38 PM



All times are GMT -7. The time now is 02:45 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top