Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-09-2009, 06:24 PM   #1
Veteran Member
pbo's Avatar

Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 891
Help needed with aperture mechanism

So, here's the thing - I got a camera off craigslist with a Sigma 16/2.8 fisheye (primary reason for buying the package) only to find the aperture was oily and did not close!
I took apart the lens, as well as the aperture mechanism, cleaned the blades and put them back. Now I have a problem - the aperture behaves as it should when lens mount is not screwed in, but when the lens mount is in, the aperture is not "closed" enough. Let me show it in pictures.

This is when lens mount is not screwed in yet:


Lever 1 controls the aperture - when pushed clockwise, aperture opens, when released, the spring pulls the lever back and aperture closes. The lever from lens mount goes into place marked with cross - and pushes lever 1. The opening is about as small as it should be for 16mm@f22.

Now, here is the lens with lens mount in place:


This is the lens with aperture set at f22. The opening is too big for that aperture - I'm sure of it. Also, the lens does not close until f/8 - so when rotating aperture ring starting with 2.8, it stays wide open up until f8. Only then will it start closing.

I'm pretty sure this has some easy enough solution - but I really can't figure out what's the problem!
Also, if you look carefully, the opening is not perfectly hexagonal - that's not my fault, it was like it when I got it

Any help is appreciated,
Bo.

07-09-2009, 07:47 PM   #2
Veteran Member
JonPB's Avatar

Join Date: Sep 2008
Location: Portland, OR, USA
Photos: Gallery | Albums
Posts: 430
Two things come to mind.

1. Does the aperture stop down regularly from f/8 to f/22? Put another way, is the only operational problem that the aperture doesn't stop down to the correct diameter? If this is the case, the mechanism might be bolted in to the wrong anchors, so that the external f-stop ring doesn't engage the intenal f-stop lever until the ring is set past f/8.

2. Does the aperture sometimes work, sometimes not? I once tried reparing a lens that someone else had worked on--which appears to be the case with your lens. One of the aperture leaves was slightly bent, slightly enough that I didn't notice until I looked for it. The aperture would close when the lens pointed downward, but not if pointed upward; gravity pushed the leaves together enough to prevent them from sliding over each other. I wasn't able to fix this.

Hope this helps.
07-09-2009, 10:03 PM   #3
Pentaxian
Just1MoreDave's Avatar

Join Date: Feb 2007
Location: Aurora, CO
Photos: Gallery | Albums
Posts: 4,814
I cheated and took apart my copy. On the mount part, right next to the lever that moves the aperture blades is a silver-colored stamped steel part with an arc in it. That part has a metal tab in it that fits in a slot in the aperture ring. If the slot isn't lined up right when you put the mount back on, the tab won't match up with it. I think that will cause your symptoms.

You can also get replacement bearings from here: https://www.micro-tools.com/store/SearchByKeyword.aspx?word=bearings

I didn't get a cap with mine so I use three plastic 67mm filters screwed together, slide them on the front and cap them with a 67mm cap. It works as a hood on APS-C but must be removed on film.
07-10-2009, 12:24 AM   #4
pbo
Veteran Member
pbo's Avatar

Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 891
Original Poster
FINALLY I got the lens to work as it should. Jon, you are partially right - although the anchors were fine, the holes on the plate that screws go into do not restrict the plate to only one position - after loosening the screws and fiddling with this plate a bit, I seem to have found the right spot - with taking wide open as a reference. Yet, after doing so, the lens did not start stopping down till f/5.6! It so turns out, the person who messed with this lens before me didn't even care to tighten the screws! - I found that out by digging out the whole aperture construction, along with two optical groups with it, - and aperture mechanism was not even tightened to the rest of the piece... I wonder why would he do that...
Anyways, tightening screws proved sufficient for that part. Of course, things don't go easy on me - the lens still did not stop down properly after that - aperture did work correctly, though. At first, I though I messed up the electronics that were responsible for "A" mode - but it just turned out the grease on the base of the lever dried out and it just didn't move as freely as it should. Stealing some grease from the focus mechanism (hehe ) was enough to get the lens to work.
Dave, thanks for the link to bearings I lost two already, one from this lens, one from a lens I used as replacement I knew about the arc and the tab/slot thingy - that was not what was causing the problems. I do have the original ring that goes onto lens to support the lens cap - and I think it'd be great to use it as a hood on dslr - as opposed to zenitar that has a proprietary cap.

Phew, I don't even know why I wrote so much stuff - the lens is so rare nobody would probably even need it... Oh well, hope it proves helpful to someone

Bo.

07-10-2009, 12:25 AM   #5
pbo
Veteran Member
pbo's Avatar

Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 891
Original Poster
Oh, and I remember someone asking about exposure - I tried the lens on Av mode at all apertures - results are all equally underexposed so I'm satisfied
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, help, k-mount, lens, lever, mechanism, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
What mechanism causes aperture ring clicks/snaps? mrcrontab Pentax SLR Lens Discussion 8 02-19-2010 09:22 AM
Help Needed: Tamron Adaptall Aperture Mechanism ballgofar Pentax SLR Lens Discussion 3 07-02-2009 10:10 AM
K-7 probably has the most quit shutter mechanism of all DSLR's Frakkas Pentax News and Rumors 44 06-05-2009 06:19 AM
Help, I think there's something wrong with the focus mechanism on my new fa100mm! aweir Pentax SLR Lens Discussion 3 04-09-2009 12:11 PM
Repairing SF1 winding mechanism mikey55 Pentax Film SLR Discussion 2 08-30-2008 08:21 PM



All times are GMT -7. The time now is 03:52 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top