Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-21-2009, 03:41 AM   #1
New Member




Join Date: Jul 2009
Location: new york
Posts: 4
K-135MM f/3.5 aperture not responsive

I'm a newbie and hope someone can help here.

I purchased a K135 f/3.5 off of ebay and got hosed. The aperture dial doesn't do anything - the blades do not move. The aperture lever cause a very small wiggle in the blades.

The blades are stuck in a stopped down position (smallest opening). Any ideas of how to fix the problem? Or do I need to shoot outside in full light only?

07-21-2009, 03:43 AM   #2
New Member




Join Date: Jul 2009
Location: new york
Posts: 4
Original Poster
Also, will this ruin my K100d if I use it in "Manual" mode with a stuck aperture?
07-21-2009, 03:49 AM   #3
New Member




Join Date: Jul 2009
Location: new york
Posts: 4
Original Poster
Also, the aperture dial has free movement and seems fine. It rotates a good ways and then stops and rotates the other way. No stickiness at all.
07-21-2009, 07:22 AM   #4
Senior Member
wavecurrent's Avatar

Join Date: Jul 2007
Location: Kiruna, Sweden
Posts: 147
I think this is posted in the wrong group, it should be in the "Pentax SLR Lens Discussion" group!!

How does the blade looks, are there any grease or oil on them? That can be one cause for them to stick. What happens if you try to move the aperture level gently at the rear of the lens, can you see the blades move?

In the link below you have some info on these matters!?
https://www.pentaxforums.com/forums/pentax-slr-lens-discussion/44776-disassem...ce-needed.html

Mike

07-21-2009, 10:43 AM   #5
New Member




Join Date: Jul 2009
Location: new york
Posts: 4
Original Poster
The lens look astoundingly clean for a K version lens. I don't know how to tell if there's grease or oil, but I shined a light and noticed slight discoloration in the tips of the blades. Not sure if that was the reflection of my flashlight or not.

The blades get a tiny bit larger if I move the aperture lever - looking at the rear of the lens.
However, the aperture dial does NOTHING.

Is this common for older manual lens? Surprising since it looks so well-kept and newish.
07-21-2009, 01:23 PM   #6
Inactive Account




Join Date: Dec 2008
Location: Ames, Iowa, USA
Photos: Albums
Posts: 2,965
QuoteOriginally posted by joeschmo Quote
The lens look astoundingly clean for a K version lens. I don't know how to tell if there's grease or oil, but I shined a light and noticed slight discoloration in the tips of the blades. Not sure if that was the reflection of my flashlight or not.

The blades get a tiny bit larger if I move the aperture lever - looking at the rear of the lens.
However, the aperture dial does NOTHING.

Is this common for older manual lens? Surprising since it looks so well-kept and newish.
It sounds like you should ask for a refund & return the lens if the seller said it was ok. It is not functioning correctly and is a non-trivial problem to fix most likely.

Ebay should support you on this one.

Dave
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, blades, f/3.5, k-mount, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
135mm 3.5 with no aperture control tortoise Pentax SLR Lens Discussion 3 02-03-2010 05:11 PM
Sears 135mm: Av stop-down does not match aperture ring aerodave Pentax SLR Lens Discussion 2 11-01-2009 02:24 PM
Use of Aperture-Ring 43mm/1.9 -> no aperture data Deimo Pentax SLR Lens Discussion 7 06-24-2009 03:25 PM
For Sale - Sold: Soviet Tair-11A 135mm/2.8 Screw Mount M42 ( 20 Aperture Blades! ) arpaagent Sold Items 6 03-26-2009 05:23 AM
Sears 135mm f2.8 K-mount -- using aperture ring? bikerboy_ro Pentax SLR Lens Discussion 5 11-27-2008 02:20 PM



All times are GMT -7. The time now is 11:25 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top