Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-19-2009, 12:52 AM   #1
Veteran Member




Join Date: Mar 2007
Location: Nove Zamky, Slovakia
Photos: Gallery | Albums
Posts: 7,181
DA*50-135 + GX20 = no SDM :(

Hi everybody,
Mywife has just bought GX20. At the airport from propper retailer, with warranty and all. Today I upgraded the firmware to v1.03 but to my annoyance my DA*50-135 still works with screwdrive only!!! It's not the lens, as I've tried it on my K10D v1.3 and SDM works.
Any ideas?
I know this might be the wrong forum for this but I thought it may get more hits here.

BR
Peter

08-19-2009, 01:10 AM   #2
Junior Member
kestrel's Avatar

Join Date: Jul 2008
Location: Chisinau (Moldova)
Photos: Albums
Posts: 27
I had the same problem on my K10D.
The camera need to be repaired.
08-19-2009, 01:12 AM   #3
axl
Veteran Member




Join Date: Mar 2007
Location: Nove Zamky, Slovakia
Photos: Gallery | Albums
Posts: 7,181
Original Poster
QuoteOriginally posted by kestrel Quote
I had the same problem on my K10D.
The camera need to be repaired.
Don't even say that...
08-19-2009, 01:20 AM   #4
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,679
Peter, could you possibly go back to the person who sold it to you and ask for a test in store?
They should be responsible for camera malfunctions occurring within the guarantee period.

08-19-2009, 02:35 AM   #5
Senior Member




Join Date: Mar 2009
Location: Copenhagen
Posts: 258
SDM works without a hitch on my GX20, so either the camera or lens...
08-19-2009, 03:19 AM   #6
axl
Veteran Member




Join Date: Mar 2007
Location: Nove Zamky, Slovakia
Photos: Gallery | Albums
Posts: 7,181
Original Poster
QuoteOriginally posted by Ash Quote
Peter, could you possibly go back to the person who sold it to you and ask for a test in store?
They should be responsible for camera malfunctions occurring within the guarantee period.
There is slight problem in what you suggested.
The shop is at the airport after check in. I will not use the same airport before late September (if even then). So I don't know.
I was thinking contacting their sister company which has branches in London. I'll see.

BR
Peter
08-19-2009, 03:22 AM   #7
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,679
Sorry to hear this Peter.
You've paid good money for the camera, and you should get a fully-working copy, so however it can be arranged, the vendor should be obliged to get this problem rectified.
Let us know how it goes, mate.
08-19-2009, 06:22 AM   #8
axl
Veteran Member




Join Date: Mar 2007
Location: Nove Zamky, Slovakia
Photos: Gallery | Albums
Posts: 7,181
Original Poster
QuoteOriginally posted by Ash Quote
Sorry to hear this Peter.
You've paid good money for the camera, and you should get a fully-working copy, so however it can be arranged, the vendor should be obliged to get this problem rectified.
Let us know how it goes, mate.
Those are the lines I'm thinking along. I'll have to check it online, to see how to contact the vendor. How about sending it to Samsung UK for warranty repair? Would that work? That should be for free, right?

BR
Peter

In any case the camera is going to Egypt with us, for second leg of our holiday. I think with Sigma 10-20 on it, it's going to be just fine, while 50-135 will be on K10D, and now I'm seriously thinking of taking K100D with 31ltd. That way 2 things would be sure:
a) I don't have to change a single lens and have all main ranges I use covered
b) my wife would most definitely kill me if I'd be lugging 3 cameras around
BR
Peter

08-19-2009, 06:40 AM   #9
Inactive Account




Join Date: Nov 2007
Location: Canada eh!
Photos: Gallery
Posts: 674
QuoteOriginally posted by axl Quote
Hi everybody,
Mywife has just bought GX20. At the airport from propper retailer, with warranty and all. Today I upgraded the firmware to v1.03 but to my annoyance my DA*50-135 still works with screwdrive only!!! It's not the lens, as I've tried it on my K10D v1.3 and SDM works.
Any ideas?
I know this might be the wrong forum for this but I thought it may get more hits here.

BR
Peter
I'm not sure if it's different with the GX20, but did you mean to say that you upgraded the GX20 to V1.3 or "1.03", because 1.03 may not be able to control the SDM. Like I said, I'm not familiar with the GX20 so I'm not sure if my understanding of the firmware versions is accurate.
08-19-2009, 09:42 AM   #10
Pentaxian
Mike.P's Avatar

Join Date: Mar 2008
Location: South Coast .. UK
Photos: Gallery
Posts: 1,734
QuoteOriginally posted by Leaf Fan Quote
I'm not sure if it's different with the GX20, but did you mean to say that you upgraded the GX20 to V1.3 or "1.03", because 1.03 may not be able to control the SDM. Like I said, I'm not familiar with the GX20 so I'm not sure if my understanding of the firmware versions is accurate.

I would have thought the GX20 was capable of using SDM lenses straight out of the box (like a K20D), it was the K10D that needed the firmware upgrade.
08-19-2009, 09:58 AM   #11
Veteran Member
GLXLR's Avatar

Join Date: Feb 2009
Location: Sugar Land, TX
Photos: Gallery
Posts: 686
You should clean the contacts on the lens and mount, then update the firmware from Samsung's website just in case.
08-19-2009, 11:29 AM   #12
axl
Veteran Member




Join Date: Mar 2007
Location: Nove Zamky, Slovakia
Photos: Gallery | Albums
Posts: 7,181
Original Poster
QuoteOriginally posted by GLXLR Quote
You should clean the contacts on the lens and mount, then update the firmware from Samsung's website just in case.
I will try to clean the contacts. I hope it'll work. Other than that the camera works like a charm, and even with the DA* the AF is spot on, just noisy...
we'll see

BR
Peter
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
da*50-135, gx20, k-mount, pentax lens, sdm, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
50-135 sdm Kini62 Pentax SLR Lens Discussion 4 10-19-2010 05:22 PM
Does GX20 support SDM lens? shutterbob Pentax DSLR Discussion 3 12-01-2009 09:58 AM
50-135 noisy SDM thomasjmpark Pentax SLR Lens Discussion 5 04-18-2008 04:25 PM
Lens offer from Amazon: DA* 50-135 SDM & DA* 16-50 SDM f8 Pentax SLR Lens Discussion 4 03-25-2008 04:45 AM
smcP-DA* 50-135 f/2.8 ED(IF)SDM ? magnum1 Pentax Film SLR Discussion 6 01-16-2008 10:06 AM



All times are GMT -7. The time now is 11:16 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top