Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-28-2009, 10:01 AM   #1
Forum Member




Join Date: Jan 2008
Posts: 50
GRRRRRRRRRRRRRRRRRRRRRRR. 55-300mm back from "repair"

i got my 55-300mm back from repair from pentax. Now it makes a weird sound when using the telephoto and images are still blurry. I have tried everything, and from 100-300mm on the lens, sharpness sucks. I have tried any combination of SR on and off, manual and auto focus, filters on and off, and a shutter of at least 1/1000, tripod or hand held. I cannot get NON-blurry results. my 18-55 works great, and is way sharper than my 55-300. Pentax said the cleaned the glass, replaced some elements, and adjusted autofocus, but its still a piece of crap. Its decent at 55mm, about the same as the kit lens, but no better. I'm am going to shoot pentax. i think i i just need to vent. What should i do though? i have never had problems with any other lens like this. even my old 50-200mm got better results than this.

08-28-2009, 10:05 AM   #2
Senior Member
jacksonpritt's Avatar

Join Date: Jul 2008
Location: Berkeley, CA
Posts: 124
I would suggest putting it on a tripod, taking a couple shots that show good examples of what you are talking about, and then sending those shots to Pentax's customer service to show them exactly what you're talking about.

I'm sorry you're stuck dealing with this!
Broken lenses are no fun at all, but Pentax's repair service is usually very good.
08-28-2009, 10:31 AM   #3
Forum Member




Join Date: Jun 2009
Location: The Villages, FL
Posts: 70
Communication is a very good thing. Why not phone customer service and have a chat. Tell them it's been worked on by them once and still bad and ask them the best way for you to demonstrate this to them. Ask if they will send you a new one in exchange for your malfunctioning one.
08-28-2009, 10:43 AM   #4
Veteran Member




Join Date: Jul 2008
Location: Colorado USA
Posts: 1,337
Here's a current thread on contacting pentax usa

Here's a current thread on contacting pentax usa:


https://www.pentaxforums.com/forums/pentax-news-rumors/70736-contacting-pentax-usa.html

08-28-2009, 01:00 PM   #5
Forum Member




Join Date: Jan 2008
Posts: 50
Original Poster
yeah, they want me to mail it back to them again, so they can take another month and not fix anything. I'm getting pissed. pentax service blows. I asked and they will not give me an advanced RMA. I am moving, and am shooting a wedding, and they are bullshitting me. I don't think i will be in the pentax market for my next cam, not if they don't take care of their customers, and suck ass at repairs. I CAN STILL SEE DUST IN THE LENS! holy crap. Bummer, i liked my K20D too.
08-28-2009, 01:21 PM   #6
Site Supporter
Site Supporter




Join Date: Jan 2009
Location: Victoria, BC
Photos: Gallery | Albums
Posts: 310
QuoteOriginally posted by bobloadmire Quote
i got my 55-300mm back from repair from pentax. Now it makes a weird sound when using the telephoto and images are still blurry. I have tried everything, and from 100-300mm on the lens, sharpness sucks. I have tried any combination of SR on and off, manual and auto focus, filters on and off, and a shutter of at least 1/1000, tripod or hand held. I cannot get NON-blurry results. my 18-55 works great, and is way sharper than my 55-300. Pentax said the cleaned the glass, replaced some elements, and adjusted autofocus, but its still a piece of crap. Its decent at 55mm, about the same as the kit lens, but no better. I'm am going to shoot pentax. i think i i just need to vent. What should i do though? i have never had problems with any other lens like this. even my old 50-200mm got better results than this.
Have you considered an improper body calibration as the possible cause? Is it Back or Front focussing or is the image un-sharp even if not BF/FF'd ? i.e. is the problem focusing or the optical qualities ?
08-28-2009, 06:02 PM   #7
Forum Member




Join Date: Jan 2008
Posts: 50
Original Poster
yes i have. i have tried all the adjustments, and i have used 4 other lenses that work great. Its not a out of focus blur, its something else. it just looks diffracted.
08-28-2009, 06:10 PM   #8
Damn Brit
Guest




Moved to lens forum.

08-28-2009, 06:34 PM   #9
Veteran Member




Join Date: Sep 2006
Photos: Gallery
Posts: 5,713
QuoteOriginally posted by regor Quote
Have you considered an improper body calibration as the possible cause? Is it Back or Front focussing or is the image un-sharp even if not BF/FF'd ? i.e. is the problem focusing or the optical qualities ?
improper body calibration would never explain a weird sound
Good sugestion though.

Lots of luck with it Bob
08-29-2009, 02:12 AM   #10
Dom
Guest




I'm with the OP I hate my 55-300 and I'm going to get it out of my life.
08-29-2009, 04:11 PM   #11
Site Supporter
Site Supporter
ChipB's Avatar

Join Date: Nov 2007
Location: Austin, TX area
Photos: Gallery | Albums
Posts: 1,664
Bummer - I've been using my Pentax DA 55-300 for 6-8 months now - love it - great color rendition and sharpness. No complaints.

Keep trying - it REALLY is a good lens!!
08-31-2009, 05:11 PM   #12
Forum Member




Join Date: Jan 2008
Posts: 50
Original Poster
call pentax today about my shatty lens. Hopefully they will give me an advanced RMA.
09-01-2009, 07:39 AM   #13
Site Supporter
Site Supporter
cdurfor's Avatar

Join Date: Apr 2009
Location: Washington, DC
Photos: Gallery
Posts: 534
Of note, the Pentax repair time can be dropped to a week or less if you place a $25 check in the package and mark it RUSH! This may seem like a small charge to expedite the repair by 3 weeks.
09-01-2009, 08:34 AM   #14
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,696
Hope it works out.
It really ain't all that bad a lens.
Either carry this little gem around, or lug around a 70-200 with TC for the same range and better IQ...
I have both and still think I should keep my 55-300...
09-10-2009, 01:12 PM   #15
Forum Member




Join Date: Jan 2008
Posts: 50
Original Poster
UPDATES!!!

so after some stern talking, which i felt was deserved after a month RMA. (I was stern, not a dick) i got them to ship me out a new one in placement of the old one. HOLY CRAP! WHAT A HUGE DIFFERENCE! SOO ****ING SHARP! its turned my world upside down. Anywho, i also have some sunpak filters for it that also suck. I show you guys some before and after shots with the old lens, the new lens, and sunpak filters. my 52mm sunpaks are great. my 58mm sunpacks are terrible! don't know whats up. anywho, i'll be back later tonight.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
55-300mm, k-mount, lens, pentax, pentax lens, results, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
the "back to the basics" poll nanok Pentax DSLR Discussion 32 07-26-2010 09:18 PM
Sports "Highside Exit" took 1st Place in DPReview "Missed It by THAT much, Part 1" Challenge MRRiley Post Your Photos! 27 02-21-2010 08:26 PM
K20d-Frame Count on panals..works w/"M" & "P" mode only? arbib Pentax DSLR Discussion 1 08-28-2009 05:47 PM
"Hunger for a DA*50-135?" or "The DA*50-135 as a bird lens!" or "Iron age birds?" Douglas_of_Sweden Post Your Photos! 4 08-13-2008 06:09 AM
img from DA*16-50/2.8, is it "okay"? Or, return for repair? volosong Pentax SLR Lens Discussion 10 04-24-2008 11:30 AM



All times are GMT -7. The time now is 04:23 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top