Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-31-2009, 09:51 AM   #16
Senior Member




Join Date: Jul 2009
Location: BC, Canada
Photos: Gallery
Posts: 174
If you want the aperture clicks back, you have to put the small ball bearing back into the lens. Take a look at the pictures in the previous links. Put a very small amount of vaseline with a toothpick onto the top of the small spring/hole. Put the small ball bearing on top of the spring/hole. The vaseline should hold the small bearing in place while you attempt to put the aperture ring back on. Then carefully put the aperture ring and lens mount back on. You may to have try it a few times to get it back on. Have patience and take your time. (This is a basic requirement for repairing any lens. Do not attempt any lens repair unless you are willing do meet this minimum requirement. It also helps a lot if you have good eyesight and are good at solving puzzles. Taking apart and putting a lens back together the first time is like puzzle solving to me.)

I find the aperture ring on the A50/1.7 is not as nice as the one on the M50/1.7. It does not move and click as smoothly as the one on the M50/1.7. Normally this is not a real problem as one would have it at the A position and have no need to turn it - except in your case.

The only consolation is that the optics of your lens has not changed one bit with the missing parts. It can still take fine pictures just as before. The A50/1.7 has fine optics. Since the spring was missing to begin with, you did not make it any worst by losing the pin. You would not have been able to get the A setting mechanism working without the spring that normally sits right underneath the pin. It is this spring that pops up the pin when the aperture ring is on the "A" position.

I think my suspicion was correct- a previous owner had tried to fix it and lost the spring in the process.

If the issue was not disclosed to you, maybe you should make a complaint to the place you bought the lens from and see if you can get some money back.


Last edited by ma318; 09-01-2009 at 09:59 AM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, camera, k-mount, pentax lens, pentax-a, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax A 50mm f1.2 lazy aperture problem ilya80 Pentax SLR Lens Discussion 3 10-10-2010 09:17 AM
mz-s aperture reading problem? kxlxmx Pentax Film SLR Discussion 3 06-07-2010 12:05 AM
aperture problem with 50 1.7 kent Pentax SLR Lens Discussion 9 11-01-2009 05:11 AM
Problem with stuck aperture ring on Pentax KA 50mm f/1.7 jhaji Pentax SLR Lens Discussion 8 08-15-2009 04:10 PM
FA 24-90 aperture problem penpig Pentax SLR Lens Discussion 1 01-26-2009 10:08 AM



All times are GMT -7. The time now is 09:27 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top