Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-05-2009, 03:14 AM   #1
Veteran Member




Join Date: Jul 2009
Location: Russia
Posts: 341
Trouble with SMC F 50mm 1.7, request to F and FA owners

I have SMC F 50mm 1.7 (auto-focus) with sticky aperture.
Problem is not aperture but that lens is not recognized as auto-focus or even auto :-) Looks like M lens. It may happen due to disassemble.
I have all contacts in place.
But it looks like small spring that provides ground contact is missing, but I am not sure.
Could you remove back of the bayonet and make photo?
Do it carefully and have paper under lens, please.

09-06-2009, 12:51 AM   #2
Veteran Member
glasbak's Avatar

Join Date: Apr 2009
Location: Netherlands
Posts: 343
QuoteOriginally posted by tr13 Quote
But it looks like small spring that provides ground contact is missing, but I am not sure.
Every contact must have a spring.
The A contact must short to the bayonet when in the A position, check this with a multimeter.
Then there is someting else I noticed, see here for the text.
The images are not displayed anymore, but here are they :





George

(If was 25 years younger, I would have time and energy to help with your hack project, but now I only follow your progress)
09-06-2009, 02:43 AM   #3
Veteran Member




Join Date: Jul 2009
Location: Russia
Posts: 341
Original Poster
Yeah, I noticed it.
But in my case it don't help. As I had such photos of my lens, so correct contact are placed in their places.
I thing that one spring is not visible(and lost in my case) and it provides ground contact between chip and bayonet mount. Look - one extra hole is present in photos below.
Interesting thing is that I got F-- displayed with underline (underline goes away in not A position). Lens work in all modes, not M only. You can change aperture and exposure changes accordingly (but F-- still). In photos I see correct aperture numbers.
If I turn lens slightly it start to show correct aperture :-(
AF don't work anyway and body request focal length for OS each time.

Here is my images:
Attached Images
     
09-06-2009, 03:04 AM   #4
Veteran Member
glasbak's Avatar

Join Date: Apr 2009
Location: Netherlands
Posts: 343
You then have to find or make a replacement spring.
Furthermore, the pins which should stick out a little more are (from left to right in your picture)
the first and the fourth. In your picture it looks like the fifth sticks out more.

09-06-2009, 07:09 AM   #5
Veteran Member




Join Date: Jul 2009
Location: Russia
Posts: 341
Original Poster
You are correct, this is photo after one experiment :-)
They are in correct positions now.
I think to look in watches for similar spring.
I still hope that someone could be able to provide me photos (similar to mine).
So, I'll be confident that it is missed spring and not bad contact somethere.
In fact, it must took 2 minutes to remove bayonet mount and place it back.

P.S. I am now expert of removing and placing back this bayonet mount :-)
And I still need to disassemble this thing to cure stuck aperture :-)
09-08-2009, 11:53 PM   #6
Veteran Member




Join Date: Jul 2009
Location: Russia
Posts: 341
Original Poster
Yeah, I was right.
You need to insert spring to empty place.
All started working :-)
Bad thing is that I still didn't find original spring, so poor Quantaray lens now don't have one :-)
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, aperture, auto-focus, k-mount, lens, pentax lens, slr lens, smc, smc f 50mm
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
DA 17-70mm having trouble focusing above 50mm dgaies Pentax SLR Lens Discussion 17 02-24-2012 04:05 PM
Request for K-5 owners: User Manual Edvinas Pentax K-5 10 11-07-2010 08:03 AM
Trouble setting f stop on K7 with SMC FA 50mm 1.4 boy_and_wolf Pentax DSLR Discussion 2 11-29-2009 04:22 PM
Trouble with my Pentax A 50mm 1.7! Tuner571 Pentax SLR Lens Discussion 23 09-21-2009 02:09 PM
Request for limited owners and K7 owners Psynema Pentax SLR Lens Discussion 0 07-09-2009 07:11 PM



All times are GMT -7. The time now is 06:36 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top