Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-03-2009, 11:45 PM   #1
Forum Member




Join Date: Jan 2009
Location: Bay Area
Posts: 60
Help!! Vivitar teleconverter stuck on my camera :-(

Hi all,

I just received my vivitar 2x teleconverter (macro) from an ebay auction. Unfortunately, there is a black/brown spot on every pic. I took. The more serious problem is that the teleconverter is stuck on my camera (k10D) and I can' t get it out!

Has anyone have problem with that? What should I do? (My camera was bought refurbished. Forgot if it came with warranty...)

Thanks,
Donna


Last edited by annod; 10-04-2009 at 12:03 AM.
10-04-2009, 03:56 PM   #3
Forum Member




Join Date: Jan 2009
Location: Bay Area
Posts: 60
Original Poster
Got it unstuck!

Thanks for the info. I finally got it unstuck with the help of a metal tape measure and some force. However, I am confused as I thought only the p/k/a/... would have the extra pin problem. Mine said it is P/K. I couldn't figure out why it was stuck. i don't want to put the lens back on until I have this figured out.

Any ideas?

Thanks,
Donna
10-04-2009, 07:14 PM   #4
Veteran Member




Join Date: Aug 2007
Location: Ottawa
Posts: 365
What some lens makers did was they made their lenses compatiable with both the Richoh A system, as well as the Pentax A system. If you take a FA lens (or a third party FA class lens), and take this Vivitar lens, line up the pins to each other, you'll see an extra pin that sits where the autofocus drive screw is on the FA lens. It's this pin that will cause problems, and thus, either needs to be filed down, or removed.

10-04-2009, 07:20 PM   #5
pbo
Veteran Member
pbo's Avatar

Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 891
Can you show us a picture of the rear of the teleconverter? I had a Vivitar TC get stuck on my K10D - and I needed quite a bit of force to get it off. I later noticed how my SDM contacts got all screwed up - because there was a superfluous (never seen before on any K-mount lens) small tab/pole sort of thing scticking out of the rear of the TC.
10-04-2009, 10:33 PM   #6
Forum Member




Join Date: Jan 2009
Location: Bay Area
Posts: 60
Original Poster
I think I know the reason now.... The TC is the PK version, so there wasn't any pin sticking out, so this isn't the infamous ricoh pin problem.

I just tried putting it on my K10D again. This time, I put the MF/AF-C/AF-S lever in the K10D to MF first, before screwing the TC on, and it doesn't get stuck anymore.

Whew! what a scare.

Thanks,
Donna
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k-mount, pentax lens, slr lens, teleconverter, vivitar
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stuck Teleconverter... DanielT74 Pentax DSLR Discussion 2 06-19-2010 03:23 AM
Stuck Vivitar Matched TC - Help!! pbo Pentax SLR Lens Discussion 4 05-26-2009 07:13 PM
Vivitar interchangeable mount stuck? mmcneil Pentax SLR Lens Discussion 3 05-17-2009 11:02 PM
lens stuck on camera dalechuk Pentax SLR Lens Discussion 4 05-05-2008 05:42 AM
Lens stuck on camera - Help! Finn Pentax SLR Lens Discussion 2 06-07-2007 11:01 AM



All times are GMT -7. The time now is 11:30 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top