Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-01-2009, 03:53 AM   #1
Veteran Member
kent's Avatar

Join Date: May 2009
Location: Lithuania
Photos: Gallery
Posts: 344
aperture problem with 50 1.7

Hi,
I've just received old pentax 50mm 1.7 lens. It's tiny , it's great, it's not automatic.
However I have two problems with it:
1. k200d won't read aperture value (shows F---)
2.Even though aperture closes when i push shutter button there is no difference between f1.7 anf f22. I mean, shutter speed is always the same. I saw that aperture really closes when I push shutter button, but still it seems that all the time I am taking pictures at 1.7. DOF remains the same at 1.7 or at 8 or at 22.
Idea?

11-01-2009, 04:02 AM   #2
Veteran Member
xjjohnno's Avatar

Join Date: Jan 2009
Location: Melbourne Australia
Photos: Gallery
Posts: 2,115
Try setting to M mode. The F stop won't show, that happens with A and later lenses.
11-01-2009, 04:09 AM   #3
Veteran Member
kent's Avatar

Join Date: May 2009
Location: Lithuania
Photos: Gallery
Posts: 344
Original Poster
QuoteOriginally posted by xjjohnno Quote
Try setting to M mode. The F stop won't show, that happens with A and later lenses.
I've tried,only exposition changes. I guess aperture is closed just too late, because on the same shutter speed there is no exposition changes between 1.7 and 22.
11-01-2009, 04:12 AM   #4
Veteran Member
RawheaD's Avatar

Join Date: Dec 2008
Location: MA, USA
Photos: Gallery
Posts: 831
QuoteOriginally posted by kent Quote
I've tried,only exposition changes. I guess aperture is closed just too late, because on the same shutter speed there is no exposition changes between 1.7 and 22.
Set eposure with the green button.

11-01-2009, 04:16 AM   #5
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,681
Kent, not sure if you know this already, but make sure the menu setting for permitting non-A apertures on your lens is set to allow non-A settings.

Then see here:
https://www.pentaxforums.com/forums/pentax-dslr-articles/32-can-i-use-k-m-len...ist-ds-dl.html

Basically, set the aperture on the lens, go to M mode on the camera, focus, stop-down meter using the green button (which automatically meters the scene for the aperture chosen and sets a shutter speed) then take the shot.
11-01-2009, 04:28 AM   #6
Senior Member
patriotap's Avatar

Join Date: Oct 2009
Location: South Jersey
Photos: Albums
Posts: 159
not sure if its different, but i have the same lens but on a k20d, i set the aperture ring to lock on A, then i can change f stop and shutter speed on the camera, the F-- goes away after that ring lock.
11-01-2009, 04:38 AM   #7
Veteran Member
kent's Avatar

Join Date: May 2009
Location: Lithuania
Photos: Gallery
Posts: 344
Original Poster
QuoteOriginally posted by Ash Quote
Kent, not sure if you know this already, but make sure the menu setting for permitting non-A apertures on your lens is set to allow non-A settings.

Then see here:
https://www.pentaxforums.com/forums/pentax-dslr-articles/32-can-i-use-k-m-len...ist-ds-dl.html

Basically, set the aperture on the lens, go to M mode on the camera, focus, stop-down meter using the green button (which automatically meters the scene for the aperture chosen and sets a shutter speed) then take the shot.
Thank you very much, I forgot about green button. Now everything works.
11-01-2009, 04:39 AM   #8
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,681
That's for an A lens, Brian. No indication from Kent yet that he has an A, F or an M lens. For all A, F and FA lenses (and their non-OEM equivalents), the aperture ring should be set at A, and aperture controlled on the camera. But for M lenses, the above guidelines need to be following for the lens to work well.

11-01-2009, 04:40 AM   #9
Veteran Member
kent's Avatar

Join Date: May 2009
Location: Lithuania
Photos: Gallery
Posts: 344
Original Poster
QuoteOriginally posted by patriotap Quote
not sure if its different, but i have the same lens but on a k20d, i set the aperture ring to lock on A, then i can change f stop and shutter speed on the camera, the F-- goes away after that ring lock.
There is no A position indicated. It is written on lens SMC Pentax-M . So all aperture values I have to set by myself
11-01-2009, 05:11 AM   #10
Senior Member
patriotap's Avatar

Join Date: Oct 2009
Location: South Jersey
Photos: Albums
Posts: 159
gothca, yes mine is the A version
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, button, k-mount, pentax lens, shutter, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
mz-s aperture reading problem? kxlxmx Pentax Film SLR Discussion 3 06-07-2010 12:05 AM
K200d aperture problem steveuk30 Pentax DSLR Discussion 3 10-29-2009 09:23 AM
M 50mm F1.7 aperture problem atyab Pentax DSLR Discussion 4 03-28-2009 08:22 AM
FA 24-90 aperture problem penpig Pentax SLR Lens Discussion 1 01-26-2009 10:08 AM
Bigma Aperture Problem GPeterson Pentax SLR Lens Discussion 4 07-02-2008 08:26 AM



All times are GMT -7. The time now is 08:47 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top