Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-24-2009, 06:37 PM   #1
Site Supporter
jonhock's Avatar

Join Date: Oct 2009
Location: NorthEast Pennsylvania, USA
Photos: Gallery | Albums
Posts: 373
Auto-focus doesn't auto anymore

I have a Sigma 1:4-5.6, 70-210mm, UC-II zoom lens that the auto-focus doesn't work on.
I'm pretty sure it's not the camera as my other zooms auto-focus perfectly.

In "auto" on my zx-50, although there is no auto-focus, it works fine. The camera reads the settings and adjusts the f-stop fine.

Has anybody had any experience with this or a similar situation?

11-24-2009, 07:10 PM   #2
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,679
I don't have any experience with failed screwdrive AF lenses, but is the focus ring moving freely?
Did the lens take any knocks or falls recently?
Is the lens fitting properly onto the camera mount?
11-26-2009, 05:52 AM   #3
Site Supporter
jonhock's Avatar

Join Date: Oct 2009
Location: NorthEast Pennsylvania, USA
Photos: Gallery | Albums
Posts: 373
Original Poster
Yes, Not sure, Yes...

Thank you for replying, Ash.
The focus ring moves like silk and retains focus through-out the entire zoom range.
I'm not sure if it has ever been dropped or such. I bought it on e-bay for $15.50.
It does "click" in when it is put on the camera.
11-26-2009, 09:49 AM   #4
Banned




Join Date: Sep 2006
Location: Millstone,NJ
Posts: 6,491
QuoteQuote:
I bought it on e-bay for $15.50
For $15.50 your lucky it worked at all.

11-26-2009, 11:28 AM   #5
Site Supporter
MikeW's Avatar

Join Date: Jan 2008
Location: Indiana
Photos: Gallery
Posts: 337
You might try cleaning the contacts with some rough paper or cloth. I was told that doing so sometimes helps. I have a Pentax-F 28mm that wouldn't autofocus, even though everything else was OK. The cleaning approach unfortunately didn't work for me and I had to have the circuitry repaired. But everything now works fine and I have a favorite lens that I initially bought very inexpensively. (With the repair it is now only a good price, but that is what sometimes happens when you buy used. It came from a thrift store as a package deal that I couldn't inspect.)
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto-focus, auto-focus doesn't auto, camera, fine, k-mount, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
10 Reasons why manual focus primes are better than those new auto focus zoom lenses JoepLX3 Pentax SLR Lens Discussion 188 07-25-2012 03:28 PM
Auto Revuenon MC Japan 200 mm f3,3 MC & MC Revue 2 x AUTO Teleconvertor K sadsun73 Pentax SLR Lens Discussion 1 11-07-2010 10:47 PM
IS there Auto Focus assist in Auto with the Metz 58? madman6767 Pentax DSLR Discussion 5 01-26-2009 06:27 AM
Auto focus seems slow, off focus after repair voicelit Pentax DSLR Discussion 0 10-14-2008 11:15 PM
Sears Auto 1:1.4 55mm vs. Nikkor-S Auto 1:1.4 50mm carpents Pentax SLR Lens Discussion 8 06-28-2007 03:29 AM



All times are GMT -7. The time now is 01:42 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top