Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-30-2009, 09:09 AM   #1
Site Supporter
SA Photo's Avatar

Join Date: Mar 2008
Location: Virgina
Posts: 122
Help! My DA* 16-50mm just broke!

Please help! I shot with this lens all day yesterday with no problems. At the end of the day when I removed the lens from the body I noticed that it would not zoom the full range. It will only go from about 35 to 50mm. I had been shooting at 16 all evening with no problems. Of course it ran out of warranty last month. Anyone else have this problem with this lens? This is one of my favorite lens, stays on one body 90% of the time.

11-30-2009, 12:07 PM   #2
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,687
Sorry to hear this.
I've not yet heard of this problem before - and it started doing this without having taken a knock at any stage?
Does it get tight trying to zoom out or does it just 'hit the wall' once 35mm is reached?
Is AF still working (that would be a miracle!)? Does it matter where on the focus ring you are as to whether you can freely zoom in and out?
11-30-2009, 01:07 PM   #3
Site Supporter
SA Photo's Avatar

Join Date: Mar 2008
Location: Virgina
Posts: 122
Original Poster
Hey Ash,

Everythings fine from 35-50 including auto-focus. It stops solid at 35 but no binding, spins smooth. I was shooting Christmas lights at 18 most of the evening with no problems. Pretty sure it never got hit or anything.
11-30-2009, 01:28 PM   #4
Veteran Member
roentarre's Avatar

Join Date: Oct 2006
Location: Melbourne, Australia
Posts: 11,794
Sounds similar to the story I have been hearing, SDM failure of some sort.

11-30-2009, 02:24 PM   #5
Veteran Member
Pentaxor's Avatar

Join Date: May 2009
Location: Vancouver, B.C.
Photos: Gallery
Posts: 6,513
why do I get the feeling that these SDM lenses tend to fail or display any malfunction right after their warranty expired.
11-30-2009, 03:22 PM   #6
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,687
It's a consipracy - they're programmed to do so!

But seriously, this is sad... hoghead, is there something obstructing the collapse of one of the extension parts of the zoom (sorry I don't know the name of those tube sections)?
11-30-2009, 03:23 PM   #7
Site Supporter
SA Photo's Avatar

Join Date: Mar 2008
Location: Virgina
Posts: 122
Original Poster
I don't think it's a problem with the SDM, the auto-focus works fine from 35-50. Would that stop the lens from rotating through the full range of 16-50? It doesn't seem to be a focus issue, something with the zoom range. Just my thoughts, really have no idea. I sent my K20 back to Pentax for repair under warranty and it seems to work fine now but it took seven weeks. I don't want to wait that long on the lens and since it's out of warranty by one month I'm thinking of taking it to my local repair shop.
11-30-2009, 03:30 PM   #8
Site Supporter
SA Photo's Avatar

Join Date: Mar 2008
Location: Virgina
Posts: 122
Original Poster
QuoteOriginally posted by Ash Quote
It's a consipracy - they're programmed to do so!
But seriously, this is sad... hoghead, is there something obstructing the collapse of one of the extension parts of the zoom (sorry I don't know the name of those tube sections)?

I really can't tell but everything appears fine. I put it in my truck and was working fine and when I got home it was broke, no idea what could have happened.

12-01-2009, 11:49 AM   #9
Site Supporter
SA Photo's Avatar

Join Date: Mar 2008
Location: Virgina
Posts: 122
Original Poster
Hey Guys,
I've got really good news. My lens is working again. Last night I had made my mind up to take my DA* 16-50 to a local repair shop for repair. Well, while I was fooling with it I said what the hell, it's already broke and applied a little force inward on the barrel of the lens as I tried to turn it. Well guess what, all of a sudden it broke free and will now zoom the entire range and seems to work fine, auto focus and all. I think maybe when I went to remove the lens hood the other night the lens got in a bind of some sorts. It sometimes gets very hard to remove unless you grab it it a particular spot. For whatever the reason I'm back in business at no cost. What a relief!
12-01-2009, 11:56 AM   #10
Senior Member




Join Date: Oct 2009
Photos: Albums
Posts: 125
That's really a good news.
12-01-2009, 11:58 AM   #11
Veteran Member




Join Date: Jan 2008
Location: Ste-Anne des Plaines, Qc., Canada
Posts: 2,014
I hope for you that there is nothing loose inside the lens. If there is something loose, it could happen again. Maybe you should try to shake (gently) the lens while listening carefully to make sure nothing is moving in it.
12-01-2009, 12:22 PM   #12
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,687
Good to hear, but if it does happen again, it's probably worth getting it definitively sorted out - let us know how it goes.
12-01-2009, 03:03 PM   #13
Veteran Member




Join Date: Jan 2008
Location: Southern California, USA
Photos: Gallery
Posts: 730
I agree with Yves. You might want to check the lens by shaking it a bit and see if you can hear any rattle / loose sound.
I remember somebody mentioned that Pentax repair center found something like plastic part that broke inside the lens that cause the SDM not working.
Just to make sure.
12-01-2009, 04:07 PM   #14
Site Supporter
SA Photo's Avatar

Join Date: Mar 2008
Location: Virgina
Posts: 122
Original Poster
QuoteOriginally posted by HermanLee Quote
I agree with Yves. You might want to check the lens by shaking it a bit and see if you can hear any rattle / loose sound.
I remember somebody mentioned that Pentax repair center found something like plastic part that broke inside the lens that cause the SDM not working.
Just to make sure.
Yea,
I did that when it broke loose, no rattles as of yet. Went out and took about 50 shots with it this afternoon and so far so good. I'm keeping my fingers crossed!
12-01-2009, 04:32 PM   #15
Pentaxian
Arpe's Avatar

Join Date: Sep 2006
Location: New Zealand
Photos: Gallery | Albums
Posts: 4,343
QuoteOriginally posted by hoghead Quote
I'm keeping my fingers crossed!
Is it awkward to take photos like that?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
body, day, k-mount, lens, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
My LCD broke... pbo Pentax DSLR Discussion 19 06-25-2009 02:48 PM
Broke Tak res3567 Pentax SLR Lens Discussion 4 04-15-2009 07:30 PM
I broke a lens and need some help tarponn22 Pentax SLR Lens Discussion 2 03-23-2009 11:43 AM
Darnit I broke down!!! ve2vfd Pentax DSLR Discussion 30 02-08-2009 10:39 AM
I Broke... Matthew Roberts Pentax DSLR Discussion 3 03-19-2007 05:05 PM



All times are GMT -7. The time now is 10:40 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top