Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-30-2009, 09:51 AM   #1
Pentaxian
builttospill's Avatar

Join Date: Jun 2009
Location: Utah, Idaho
Photos: Gallery
Posts: 1,651
DA 17-70mm Acting Up?

Over the weekend I mounted my Pentax DA 17-70 SDM only lens to my K10D. This lens was purchased new during the middle of August this year, and has been a great lens so far. However, this weekend it couldn't lock focus. It would just hunt back and forth and finally give up with the blinking hexagon and a blurry image in the viewfinder. I tried AF inside and out, with different subjects and different focal lengths and the lens just wouldn't lock focus. Anybody know what's wrong or have this happen to them? Thanks.

11-30-2009, 11:21 AM   #2
Veteran Member
filorp's Avatar

Join Date: Jun 2008
Location: Aberdeen Scotland
Photos: Gallery | Albums
Posts: 389
my lens spent 4 months at service until i get it back - it was the same issue... is your lens behaves the same way on every focal lenghts or just on specific? my refused to focus over 35mm...
11-30-2009, 12:24 PM   #3
Pentaxian
builttospill's Avatar

Join Date: Jun 2009
Location: Utah, Idaho
Photos: Gallery
Posts: 1,651
Original Poster
I wasn't paying attention to specific focal length, I just tried it across the entire range and it wouldn't focus.

Once your lens came back after four months, was it working properly?
11-30-2009, 12:27 PM   #4
Veteran Member
bc_the_path's Avatar

Join Date: Mar 2007
Location: Ankara, Turkey
Photos: Gallery
Posts: 390
I hope it is not the dreaded SDM failure that is discussed frequently here.
Please "search" using SDM as the major keyword to get the threads and see if the symptoms are the same.
If they are, you seem to be covered by warranty so, do not worry much and send your lens to the proper place.

11-30-2009, 12:36 PM   #5
Pentaxian
builttospill's Avatar

Join Date: Jun 2009
Location: Utah, Idaho
Photos: Gallery
Posts: 1,651
Original Poster
QuoteOriginally posted by bc_the_path Quote
I hope it is not the dreaded SDM failure that is discussed frequently here.
Please "search" using SDM as the major keyword to get the threads and see if the symptoms are the same.
If they are, you seem to be covered by warranty so, do not worry much and send your lens to the proper place.
At first I was wondering if the SDM was having problems, as I've read some of those threads you mentioned, but the barrel rotates fine from one end to the other, so the SDM motor is working, it just won't lock focus, or it can't find the proper focus.
11-30-2009, 01:11 PM   #6
Pentaxian




Join Date: May 2007
Location: WW community of Pentax users
Photos: Gallery | Albums
Posts: 2,141
Been there with a DA* 16-50.
It was finally replaced.
11-30-2009, 04:17 PM   #7
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,683
My response follows your verbatim post in the More SDM failures thread.
It's not necessarily 'about to fail' but it is perhaps more a shortcoming of SDM's ability to accurately lock focus.
11-30-2009, 05:27 PM   #8
Veteran Member
filorp's Avatar

Join Date: Jun 2008
Location: Aberdeen Scotland
Photos: Gallery | Albums
Posts: 389
QuoteOriginally posted by builttospill Quote
Once your lens came back after four months, was it working properly?
yes, but i must add that i was sending it two times within 4 months... after first repair ones i get it it turned out different problem, yest thay fixed one think and broke ather... btw one year ago i had similar problem with 16-50 (sdm failure - replaced by new one)

12-01-2009, 09:40 AM   #9
Pentaxian
builttospill's Avatar

Join Date: Jun 2009
Location: Utah, Idaho
Photos: Gallery
Posts: 1,651
Original Poster
QuoteOriginally posted by Ash Quote
. . . it is perhaps more a shortcoming of SDM's ability to accurately lock focus.
That's too bad. I purchased this lens after reading about SDM's ability to focus quickly, quietly and more accurately!!! Well, I guess I shouldn't complain too much, at least the SDM motor is working and the quick-shift helps lock focus.
12-01-2009, 10:18 AM   #10
Pentaxian
reeftool's Avatar

Join Date: Dec 2007
Location: Upstate New York
Photos: Gallery | Albums
Posts: 8,070
QuoteOriginally posted by builttospill Quote
That's too bad. I purchased this lens after reading about SDM's ability to focus quickly, quietly and more accurately!!! Well, I guess I shouldn't complain too much, at least the SDM motor is working and the quick-shift helps lock focus.
I think you should complain, and loudly! What good is an AF lens that won't lock focus most of the time? I am planning to purchase a 17-70 within the next few months and have been kicking around the Pentax or the Sigma and to be honest, I think it is going to be the Sigma and not because it is cheaper.
12-01-2009, 10:30 AM   #11
Veteran Member




Join Date: Nov 2007
Posts: 1,553
QuoteOriginally posted by Ash Quote
My response follows your verbatim post in the More SDM failures thread.
It's not necessarily 'about to fail' but it is perhaps more a shortcoming of SDM's ability to accurately lock focus.
If you read though the list of SDM posts, I posted in that thread, there are a few that post that the lens not locking focus was a first symptom. Unfortunately reading them as jumbled the accounts in my mind so I can't simply point to the posts that do mention this. It could also have even been in reading the threads of those post that I saw this. Gees, I sound like a Global Warming scientist talking about their data. ;-)

My point is, if it is under warranty, send it in as quick as possible.

Thank you
Russell
12-01-2009, 11:14 AM   #12
Pentaxian
builttospill's Avatar

Join Date: Jun 2009
Location: Utah, Idaho
Photos: Gallery
Posts: 1,651
Original Poster
Well, after reading some of these posts, I'm wondering if I can just get my money back and buy the similar Sigma. Or do I have to have the lens repaired under the warranty?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
da, da 17-70mm, focus, k-mount, lens, pentax lens, slr lens, weekend
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K100D is acting funky tam67 Pentax DSLR Discussion 4 09-28-2009 07:25 PM
Pentax istDl Acting Up - Help! anotherrandomuser Pentax DSLR Discussion 2 09-13-2009 06:49 PM
Battery acting weird loffen90 Troubleshooting and Beginner Help 2 03-20-2009 09:51 AM
lx is acting strangly. bensan9 Pentax Film SLR Discussion 3 09-19-2008 09:56 AM
Is my K10D acting up? Techguy Pentax DSLR Discussion 15 01-16-2008 08:16 PM



All times are GMT -7. The time now is 10:45 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top