Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-11-2009, 01:46 PM   #1
Inactive Account




Join Date: Mar 2009
Location: Fort Erie Ontario Canada
Posts: 18
Need exploded assembly diagram

Hi, I have the silver Pentax FA 100-300mm 4.7 AF lens. I need the schematic for it to reassembly it.
For some reason when it is locked into the "A" position, it does not tell the camera it is locked.

12-11-2009, 04:01 PM   #2
Pentaxian
Just1MoreDave's Avatar

Join Date: Feb 2007
Location: Aurora, CO
Photos: Gallery | Albums
Posts: 5,744
Sorry, no diagram, and I haven't seen this exact lens. The problem is probably the electrical connection between the A contact on the lens mount and the lens mount. Lenses like this have as many as 6 contacts on the mount close to the recess for the locking pin. When you take the mount off, there's a tiny brass or steel spring connecting the rounded pin on the mount to another contact on the lens body. One of these lens body contacts connects to a switch that's controlled by the A position on the aperture ring. When the aperture ring is locked in the A position, there's a connection between the lens mount and that A contact. Then the other contacts tell the camera about the lens. Make sure all the springs are installed and making good contact, and the switch mechanism is working, and the lens should work.
12-11-2009, 04:18 PM   #3
Inactive Account




Join Date: Mar 2009
Location: Fort Erie Ontario Canada
Posts: 18
Original Poster
My initial test showed no connection on the second pin to the ground. When the lens is in the "A" position pin 2 should have continueity to ground on a working lens. (I know this from my other FA lenses) I disassembled the lens, all the pins where good. I think the problem is the very small and fine ribbon cable. No real way to fix, so I guess I am going to have to toss the lens out. Too bad, it was mint....
12-11-2009, 04:30 PM   #4
Pentaxian
Just1MoreDave's Avatar

Join Date: Feb 2007
Location: Aurora, CO
Photos: Gallery | Albums
Posts: 5,744
Well, you don't really need the complicated switch bit to work. If you can create a connection between the A contact and the lens mount, the lens will be permanently in A according to the camera, where it is a lot more useful.

12-11-2009, 04:55 PM   #5
Veteran Member
keyser's Avatar

Join Date: Aug 2009
Location: Tsawwassen, BC
Posts: 376
QuoteOriginally posted by K200Duser Quote
No real way to fix, so I guess I am going to have to toss the lens out. Too bad, it was mint....
To save the environment, toss the lens to me! I'll even pay postage :P (I mean that in jest but PM me if you're being serious!)

Seriously though, is not having the 'A' setting really so bad? I have an older 'M' series camera so it's really not such a problem. It only becomes a pain because of the crippled mount on newer cameras,
12-11-2009, 06:15 PM   #6
Inactive Account




Join Date: Mar 2009
Location: Fort Erie Ontario Canada
Posts: 18
Original Poster
Still one last shot at it...

Well, I still would like to try and get it all put back together first, hence the schematic I need. There are 6 very thin shims that go in between the tubes, and it is very hard to see how they go back in. It's not something I could have taken pictures of first as the shims are buried in the assem...Also I need the diagram to show me the proper alignment of getting the assembly back together.
12-13-2009, 10:23 AM   #7
Inactive Account




Join Date: Mar 2009
Location: Fort Erie Ontario Canada
Posts: 18
Original Poster
Humpty dumpty....

Well it's been three days now and I still can't get this thing assembled right. All the cam gears and their starting postitions are messing me up. I can only guess how to put the shims in when I can't even get it together first. I wonder how much pentax would charge if I just mailed all the pieces to them?
KR
12-13-2009, 07:07 PM   #8
Veteran Member
keyser's Avatar

Join Date: Aug 2009
Location: Tsawwassen, BC
Posts: 376
You could always try Eric...

12-13-2009, 08:50 PM   #9
Inactive Account




Join Date: Mar 2009
Location: Fort Erie Ontario Canada
Posts: 18
Original Poster
Sorry, who's Eric?
12-13-2009, 09:36 PM   #10
Veteran Member
gokenin's Avatar

Join Date: Oct 2007
Location: lowell,ma
Posts: 1,892
Home

I dont know if he does repairs on lens that have electronic components in them but he would be the one to answer that question
12-14-2009, 08:24 AM   #11
Inactive Account




Join Date: Mar 2009
Location: Fort Erie Ontario Canada
Posts: 18
Original Poster
How do I get hold of him?
12-15-2009, 02:14 AM   #12
Senior Member




Join Date: Mar 2008
Location: Highland Park, IL
Posts: 217
QuoteOriginally posted by K200Duser Quote
How do I get hold of him?
The link gokenin provided should include contact info for Eric. For the exploded parts schematic, call Pentax parts dept -- they sent me one for my FA 50/1.4 a while back.
12-15-2009, 03:29 PM   #13
Inactive Account




Join Date: Mar 2009
Location: Fort Erie Ontario Canada
Posts: 18
Original Poster
Back together again... still no A setting

Wow, finally got it all back together. Though it still does not communicate to the camera that the lens is in the "A" position. Lens autofocuses and zooms great. I have to use it in the manual camera setting only. If I use Av, or program I get the flashing "f" in the viewfiner. When I use a fully working FA lens, the aperature number is displayed when in Av or program...
Oh, well,
Any one interested in purchasing it
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-mount, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lens light path diagram ? chromo Pentax SLR Lens Discussion 22 05-13-2010 03:31 PM
Sticky lens diagram MXP Pentax SLR Lens Discussion 4 10-11-2009 10:36 AM
K20D Exploded View of Parts odgc8 Pentax DSLR Discussion 17 02-11-2009 04:23 PM
Pentax ist DL Exploded View odgc8 Pentax DSLR Discussion 6 01-29-2009 02:34 PM
Aurora Borealis... the sky exploded last night... [4 IMG] Duplo Post Your Photos! 10 10-01-2007 03:27 PM



All times are GMT -7. The time now is 12:51 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top