Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-27-2009, 01:21 PM   #1
Inactive Account




Join Date: Jun 2009
Photos: Gallery | Albums
Posts: 35
K20D+A28mm f/2.8 Exposure trouble

I like this camera/lens combo a lot, great optical results but I had trouble with erratic exposure in the lens A mode. I'm thinking of getting an FA28 to get good autoexposure and autofocus, but I made a discovery yesterday.
The lens overexposes. Why?
Doing some testing I discovered the lens exposes correctly at 2.8 and overexposes 1 constant stop for other aperture values. So if I set compensation to -1 I get good autoexposure through the whole range except 2.8, underexposed.
Noticing that, I started looking at the diaphragm at different apertures and there was the surprise: when in A mode the lens doesn't start closing until after f/4. So I get f/2.8 for camera settings f/2.8 and F/4. Then, all other stops are displaced, 5.6 is in fact 4, and so on.
When out of the A mode, the lens closes down correctly, because it's the internal lens mechanism that determines the opening amount.
The camera is almost new and exposure with the kit lens is perfect. My other lenses are Ms so I can't try other As to see what happens.
But the problem is clearly the autoaperture lever doesn't move to the point of correct opening for the aprture set in the camera. What I notice is the 28mm doesn't have a proportional space between the wider fstops, could that be the problem?
Does anyone else's A 28 behave like this? Would buying the FA28 change that?


Last edited by max889; 12-27-2009 at 02:01 PM.
12-27-2009, 07:39 PM   #2
Veteran Member
creampuff's Avatar

Join Date: May 2007
Location: Singapore
Photos: Gallery
Posts: 3,955
I'll hazard a guess your lens might have sticky or slow aperture blades that prevents the lens from stopping down correctly. This could be due to oil on the blades. The other possibility is the aperture coupling pin is bent, so it is not stopping down correctly. Lens may need to be serviced.
01-03-2010, 12:08 PM   #3
Inactive Account




Join Date: Jun 2009
Photos: Gallery | Albums
Posts: 35
Original Poster
The lens is clean, it went to service. I'm using and FA 28 now, very happy with it, no flaws worth mentioning.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, exposure, f/2.8, f/4, fa28, k-mount, lens, mode, pentax lens, slr lens, trouble
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble with k20D enderkasim Pentax DSLR Discussion 14 08-01-2010 05:41 PM
Hoboken A28mm B&W Nesster Post Your Photos! 3 10-17-2008 09:14 AM
K20D - Trouble updating firmware NicholasN Pentax DSLR Discussion 3 06-17-2008 08:51 AM
Trouble with Exposure Time jcleary47 Photographic Technique 7 06-17-2008 04:24 AM
Lunch Time walk with Pentax A28mm f2.8 Timbuctoo Post Your Photos! 11 05-29-2008 04:14 AM



All times are GMT -7. The time now is 01:39 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top