Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-06-2010, 04:23 PM   #16
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,400
QuoteOriginally posted by emr Quote
What's that smell?!

Oh, it's all the Pentaxians with defective SDM lenses short-circuiting their camera bodies. Nothing to worry about.
you could also say that peter has proven electronics works on somke, and not on holes and electrons, because it stopped working when the smoke leaked out

01-06-2010, 05:07 PM   #17
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,438
QuoteOriginally posted by emr Quote
What's that smell?!

Oh, it's all the Pentaxians with defective SDM lenses short-circuiting their camera bodies. Nothing to worry about.
I am waiting to see photos of the flames!

Steve
01-06-2010, 11:14 PM   #18
Veteran Member




Join Date: Aug 2007
Location: Dayton, OH
Posts: 365
QuoteOriginally posted by Lowell Goudge Quote
Congratulations peter

you have discovered a user implementable software fix for the people wwho want tu use screw drive as opposed to SDM. Just tape over the KAF2 power pins
But I thought the community has already established that simply taping over them doesn't work. The camera refuses to fall for that trick. If enabling screw-drive was as simple as taping the pins, the forum would have had it settled a long time ago.

Peter seems to have shorted the pins and fried something, which has had a different effect.
01-06-2010, 11:16 PM   #19
Senior Member




Join Date: Oct 2008
Location: Vaughan, Ontario
Photos: Gallery
Posts: 269
lol well that's a peculiar way of reacting to damamging your own equipment

01-06-2010, 11:27 PM   #20
Veteran Member
heliphoto's Avatar

Join Date: May 2008
Location: Region 5
Photos: Gallery
Posts: 2,540
QuoteOriginally posted by LeDave Quote
Wow! That's great news, I really wished I kept my 50-135 so I could give this a try. =P
QuoteOriginally posted by dgaies Quote
Dave, got your 50-135 on my Kx right now
I'm so proud and happy of the journeys my 50-135 has taken .


QuoteOriginally posted by aerodave Quote
But I thought the community has already established that simply taping over them doesn't work. The camera refuses to fall for that trick. If enabling screw-drive was as simple as taping the pins, the forum would have had it settled a long time ago.

Peter seems to have shorted the pins and fried something, which has had a different effect.
Yeah, that's my understanding too - many people have taped over those contacts with no benefit, so there must have been something else that happened. There's someone else around here who has reported this exact thing before as well, months ago - I would have sworn it was Peter Zack, but I think we can rule that out .
01-07-2010, 06:15 AM   #21
Pentaxian
Moderator Emeritus




Join Date: May 2007
Location: Edmonton Alberta, Canada
Photos: Gallery | Albums
Posts: 10,648
Original Poster
It was me sort of. Different issue on another body. BTW. I don't recommend doing this until it can be figured out what really happened. I wish I had a PZ lens to see if that circuit is cooked.

The other one was a different K20D that started to develop a wierd AE-L button that would come on and off at any time. Then at the same time the SDM stopped working. I assumed that there was an internal issue that was all connected. That body is now gone as it wasn't cost effective to repair and no good for my work.

I'm going to see if I can replicate this on my K10D (I use it only for Screwmount leneses anyway) I'll try to do it carefully and see what happens. One thing I can say for sure. The camera was turned on and "awake" (I was rushing) and the pins would have been "live". I'll do my test this weekend.

The DA*16-50 is faster than it was but this lens sucks for focusing. It's frankly the worst lens I've ever used. In good light, it snaps right in. But if the light is poor or the contrast not well defined, then this lens is nearly useless. I don't use it in a dark church etc.

As someone said above, for a "top end" lens, this is a terrible representation of the company. Sad for a brand that built it's name on optics.
01-07-2010, 06:20 AM   #22
Veteran Member




Join Date: Jan 2009
Location: Canada
Posts: 1,255
QuoteOriginally posted by Peter Zack Quote
I'm going to see if I can replicate this on my K10D (I use it only for Screwmount leneses anyway) I'll try to do it carefully and see what happens.
Would taping over the contacts with electric tape work, as well? EDIT: It probably won't. I found this:

https://www.pentaxforums.com/forums/pentax-slr-lens-discussion/66344-pentax-s...-better-2.html
01-07-2010, 07:56 PM   #23
Veteran Member




Join Date: Jun 2008
Location: Borås, Sweden
Photos: Gallery
Posts: 3,165
So if SDM is less accurate and slower than in-body motor, what the heck's the point? Seems like it'd just add cost to each lens and not do any good.

01-07-2010, 08:55 PM   #24
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,438
QuoteOriginally posted by pingflood Quote
So if SDM is less accurate and slower than in-body motor, what the heck's the point? Seems like it'd just add cost to each lens and not do any good.
It might be because it doesn't wake the neighbors and/or summon the police when focusing!

Steve
01-08-2010, 02:21 AM   #25
Veteran Member




Join Date: Jan 2009
Location: Budapest
Posts: 821
Pentax will address this in the next firmware, it will disable screwdrive AF is SDM circuitry is fried
01-08-2010, 06:39 AM   #26
Senior Member




Join Date: Feb 2007
Location: Michigan/USA
Posts: 173
I recall trying to cover up those 2 pins to see if it would force the camera into screwdriving the focus, but it was not successful for me. Either I did it wrong, or the trick is to actually short them out as opposed to just covering them.
01-08-2010, 07:52 AM   #27
Veteran Member
heliphoto's Avatar

Join Date: May 2008
Location: Region 5
Photos: Gallery
Posts: 2,540
QuoteOriginally posted by simico Quote
Pentax will address this in the next firmware, it will disable screwdrive AF is SDM circuitry is fried
LOLed at that one
01-09-2010, 10:25 AM   #28
Pentaxian
Moderator Emeritus




Join Date: May 2007
Location: Edmonton Alberta, Canada
Photos: Gallery | Albums
Posts: 10,648
Original Poster
Well I'm sad to report that the SD focus is not much better. I detail it here

Therr's just something about this design that doesn't work nearly as well. Btw I tried to replicate the 'accident" on the K10D but I can't yet.
02-23-2010, 02:36 AM   #29
Veteran Member
PentaxPoke's Avatar

Join Date: Jan 2008
Location: Oklahoma
Posts: 1,411
QuoteOriginally posted by Peter Zack Quote
Well I'm sad to report that the SD focus is not much better. I detail it here
Peter,
What happened to the other thread you started (link in your post above) It just disappeared!
02-23-2010, 05:07 AM   #30
Senior Member




Join Date: May 2009
Location: Glasgow, Scotland
Posts: 132
I bet all the RROD'd DA* owners out there will be furiously trying to mate their cameras with car batteries :P

QuoteOriginally posted by pingflood Quote
So if SDM is less accurate and slower than in-body motor, what the heck's the point? Seems like it'd just add cost to each lens and not do any good.
Because the other brands do it, and (unlike, say keeping your lens prices stable in a recession rather than doubling/tripling them) this is one case where Pentax have caught 'me too' syndrome.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
body, camera, k-mount, lens, mount, pentax lens, sdm, shot, shots, slr lens, wedding
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Spencer's Camera for IR conversion, or, How Spencer's Camera broke my K200D LowVoltage Photographic Technique 47 04-03-2013 10:41 AM
Would you be happier if pentax refreshed lineup annually? mikemike Pentax News and Rumors 32 07-17-2010 07:41 AM
Broke Tak res3567 Pentax SLR Lens Discussion 4 04-15-2009 07:30 PM
Darnit I broke down!!! ve2vfd Pentax DSLR Discussion 30 02-08-2009 10:39 AM
I Broke... Matthew Roberts Pentax DSLR Discussion 3 03-19-2007 05:05 PM



All times are GMT -7. The time now is 01:22 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top