Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-25-2007, 08:27 AM   #1
Inactive Account




Join Date: Jun 2007
Location: Utah
Photos: Gallery
Posts: 17
Not so sure about my Sig 50-500:-(

I am new to this site,and pretty new to Photography.
I have been shooting for almost two years and am still struggling. I have the K-10 with a Sigma 70-300,Pentax 18-55 and the Bigma.The majority of what i use this camera for is widlife, I have a FZ20 for just shooting around the house. Anyway I am not getting very good pics when I get into the 300-500 range,which is very frustrating because I bought this lens for that reason. I am wondering if something is wrong with the lens because I can take a picture at 500 free hand,and see no difference if I put it on my tri-pod. maybe I am expecting to much from this lens?

06-25-2007, 09:23 AM   #2
Pentaxian
Moderator Emeritus




Join Date: May 2007
Location: Edmonton Alberta, Canada
Photos: Gallery | Albums
Posts: 10,648
Bigma issue

Welcome to the site, always good to see new Pentaxians.
I have the same lens and like the results. You should post some pictures as examples of the issues. One thing is you should have the SR on when hand holding and off when on a good solid tripod. What are the lighting conditions like when you use the lens? What shutter speeds are you shooting at? I'd say the minimum when hand held should be around 1/200 or above when fully zoomed in and min 1/100th+ when on a tripod. I'd recommend speeds higher than these but those would be the minimums in my opinion.

below is a picture of the zoom at 420mm and @1/320 hand held.

Last edited by Peter Zack; 12-08-2007 at 04:55 AM.
06-25-2007, 02:12 PM   #3
Inactive Account




Join Date: Jun 2007
Location: Utah
Photos: Gallery
Posts: 17
Original Poster
I really notice it when I am shooting at a distance,if I am fairly close to what I am shooting they are great.My concern is at a distance they are not good(100Yards+)
06-25-2007, 10:27 PM   #4
Veteran Member




Join Date: Sep 2006
Photos: Gallery
Posts: 5,713
I only have the Sigma 135-400 APO on a K100D, so this might not apply to you.

I've noticed that when I have the AV set between 8 and 13 it's a very soft image.
Anything lower than 8 and the pictures are pretty sharp, and when I have it cranked to a higher number the pictures become sharp again.

My advice is try playing around with different exposures, and see if that cures your problems.
Possibly set out a stuffed animal to work it through. They're always good models

I had my camera out for about an hour on the tripod today, snapping pictures of marmots to work out the sharpness issue with my camera today, and I learned a lot


Last edited by little laker; 06-26-2007 at 05:45 AM.
06-26-2007, 02:29 PM   #5
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,118
Thread moved to the SLR lens forum- please remember to post in the correct category!

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

06-27-2007, 01:25 AM   #6
Veteran Member
roentarre's Avatar

Join Date: Oct 2006
Location: Melbourne, Australia
Posts: 11,794
When using 500mm, air quality is also a concern. If you have a polluted place or have air filled with dust or mist, the result would not be great regardless what lens is used.

Otherwise it is quite a good performer for its price
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
k-mount, lens, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigma 50-500 vs 150-500 vs 170-500 juanraortiz Pentax SLR Lens Discussion 19 10-30-2009 03:32 PM
Tamron 200-500/6.9 AD2 vs 500/8 AD wujek Pentax SLR Lens Discussion 6 04-29-2009 05:14 AM
K20D & Sig 50-500 owners skinja Pentax SLR Lens Discussion 10 10-29-2008 02:41 PM
Sigma 175-500 vs Bigma 50-500 VAV Pentax SLR Lens Discussion 2 07-04-2008 01:24 PM
Not so sure about my Sig 50-500:-( Cvrn Pentax SLR Lens Discussion 3 06-25-2007 10:48 PM



All times are GMT -7. The time now is 03:18 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top