Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-27-2010, 06:32 AM   #1
Inactive Account




Join Date: Aug 2009
Location: kalgoorlie
Posts: 187
autofocus lock issue with sigma 100-300 f/4

hi all
this is really bugging me as all other lenses work fine with the k-7
but the focus locks just past the subject and is not very accurate at all!
would this be a problem with the lens or body?
has anyone else had these issues with the sigma 100-300 f4?
ive tried everything,now i need some insight into this.

02-27-2010, 11:37 PM   #2
Inactive Account




Join Date: Aug 2009
Location: kalgoorlie
Posts: 187
Original Poster
well i guess im the only one then.thanks
02-28-2010, 12:14 AM   #3
Veteran Member
sterretje's Avatar

Join Date: Dec 2008
Location: Roodepoort, South Africa
Photos: Gallery | Albums
Posts: 3,534
Pleasure

I don't have a camera with 'focus calibration' option and it might not work for lenses other than Pentax, but have you tried the focus adjustment on your camera?
02-28-2010, 01:53 AM   #4
Pentaxian
Mike.P's Avatar

Join Date: Mar 2008
Location: South Coast .. UK
Photos: Gallery
Posts: 1,758
I have the lens but not the camera .. sorry

02-28-2010, 02:27 AM   #5
Inactive Account




Join Date: Aug 2009
Location: kalgoorlie
Posts: 187
Original Poster
yes i tried the focus adjust but ff bf issues arent the problem.
the actual focus lock on af s locks out of focus.
i can see quite clearly that its out of focus through the viewfinder,i can focus it back a bit manually and it comes into focus,then half depress the shutter and it goes out again.
ive searched all over the internet and found nothing.
im just curious as to this being a camera malfunction or a lens malfunction.
or both!
anyway i might as well send it to cr kennedy,has any aussies send their gear to crk in perth w.a?
thanks anyway guys
02-28-2010, 03:38 AM   #6
Veteran Member




Join Date: Nov 2007
Posts: 1,553
Is your diopter adjustment on the viewfinder off?

Thank you
Russell
02-28-2010, 07:45 AM   #7
Inactive Account




Join Date: Aug 2009
Location: kalgoorlie
Posts: 187
Original Poster
thanks for the input russ, but no.the actual images taken are clearly out of focus
even when the focus confirmation lock is all go.the diopter was the first thing i adjusted when i got the camera.
i think ill just be sending the combo(k-7 and sigma 100-300 f/4)into cr kennedy.
let them sort it out.
it really is a awesome lens.i can use it manually but kinda defeats the purpose of the lens abit,as the manual focusing ring is very sensitive so tiny little turns are needed
02-28-2010, 08:21 AM   #8
Veteran Member
pcarfan's Avatar

Join Date: Sep 2007
Location: Dayton, Ohio
Photos: Gallery | Albums
Posts: 2,960
The sigma 100-300 F4 EX DG has the best AF mechanism in every aspect to any lens I've ever owned or currently own. It is super fast, accurate and not that noisy (I've never owned an SDM/HSM lens). Something is wrong with yours, definitely send it back for repairs.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
issue with sigma, k-mount, pentax lens, sigma, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Sigma Zoom Telephoto 100-300mm f/4 EX DG IF Autofocus Lens for Pentax AF jgredline Sold Items 7 02-04-2010 06:59 PM
Tamron adaptall 300/2.8 or Sigma 100-300/4 pinholecam Pentax SLR Lens Discussion 10 11-07-2009 05:52 AM
Tamron 300/2.8, Sigma 100-300 F4, 1.7 AF TC images: A link to the DPR froum. pcarfan Pentax SLR Lens Discussion 0 02-07-2009 08:48 PM
Wildlife & sports tele: DA*300 vs Sigma 100-300 f4 dspdx Pentax SLR Lens Discussion 4 08-28-2008 09:27 PM
Sigma 100-300 APO vs New Pentax 300 dylansalt Pentax SLR Lens Discussion 10 07-24-2008 05:44 AM



All times are GMT -7. The time now is 07:59 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top