Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-10-2010, 01:51 AM   #1
Pentaxian
Pablom's Avatar

Join Date: Feb 2010
Location: Jerusalem
Posts: 1,940
F 35-70mm lens problem

Hello everybody,

I bought myself a SMC Pentax-F 35-70mm F3.5-4.5 from ebay and have it for a few days now. I got it for my K-x as a replacement for the kit lens because it has the most useful focal range for me for everyday use and I've read good things about it. I haven't fully tested it yet but the optical quality seems to be very good (considering expectations), AF is lightning fast and very noisy, the build quality is awful (I understand this is common in lower end F lenses), the zoom ring is the worst I've encountered ever and the focusing ring is pretty bad too (especially for a lens that claims macro capabilities, still not a big step down from the kit lens in that aspect) and very loose (it also can be rotated when in AF mode which is very disturbing, and I'm pretty sure it doesn't have quick shift ).

But that is not why we gathered here today ladies and gentlemen. my problem is that when AF struggles, whether it is too close to the object or it doesn't lock and just goes all the way to the short or long end, it sometimes shuts down the camera.
well, it doesn't really shut down but stuck, I can still see all the data in the viewfinder but I can't change anything or take a photo and the LCD usually freezes and sometimes shows some weird line pattern. it comes back to life after turning off the camera and waiting a few seconds.
No problems when using MF of course.

So can this be harmful to my camera? I still find the lens useful but I really don't want to make any damage to my camera.

Has anyone encountered a similar problem with this or some other lens? is it something I should worry about?

Any help would be appreciated. Thanks.

Pablo.

04-10-2010, 04:51 AM   #2
Pentaxian
Pablom's Avatar

Join Date: Feb 2010
Location: Jerusalem
Posts: 1,940
Original Poster
No electricians here?

I hope this is not the wrong forum
04-10-2010, 02:25 PM   #3
Pentaxian
Just1MoreDave's Avatar

Join Date: Feb 2007
Location: Aurora, CO
Photos: Gallery | Albums
Posts: 4,859
The F and later lenses communicate with the camera digitally, so they can send the camera focal length, lens name and other data. My guess is your lens has a loose or dirty interior contact that gives the camera corrupted data, which locks the camera up. If I'm right, it wouldn't cause damage. The ones I've used and the one I have now are really good at locking focus, though noisy as you say.

These lenses are fairly inexpensive. I'd take it apart and look at the contacts, usually easy to access on the side of interior barrels. If you're not into disassembly, maybe look for another one, as the problem won't fix itself.
04-11-2010, 12:42 AM   #4
Pentaxian
Pablom's Avatar

Join Date: Feb 2010
Location: Jerusalem
Posts: 1,940
Original Poster
QuoteOriginally posted by Just1MoreDave Quote
The F and later lenses communicate with the camera digitally, so they can send the camera focal length, lens name and other data. My guess is your lens has a loose or dirty interior contact that gives the camera corrupted data, which locks the camera up. If I'm right, it wouldn't cause damage. The ones I've used and the one I have now are really good at locking focus, though noisy as you say.

These lenses are fairly inexpensive. I'd take it apart and look at the contacts, usually easy to access on the side of interior barrels. If you're not into disassembly, maybe look for another one, as the problem won't fix itself.
I'm not sure what you mean by interior contacts, it looks fine from outside, do I have to open the screws and mess inside? I'm willing to do it if I'd have an idea of what to do.

I appreciate the help

here's what it looks like from outside:


04-11-2010, 01:06 AM   #5
Veteran Member
jct us101's Avatar

Join Date: Jun 2008
Location: Rohnert Park, CA
Posts: 3,695
Get a cue tip or something and clean out all the contacts, that's always the first step to see if there's maybe something in there that might be blocking the contacts from connecting with the camera, after you've done that then let us know and we can see what else it might be.
04-11-2010, 05:30 AM   #6
Inactive Account




Join Date: Nov 2008
Location: USA
Posts: 924
I have two like new F35-70 lenses. The focus rings on both will turn when in AF mode.
The problem with the lens sounds like an internal contact problem. You can try taking it apart. But they can be a pain to work on.
04-11-2010, 07:38 AM   #7
Pentaxian
Pablom's Avatar

Join Date: Feb 2010
Location: Jerusalem
Posts: 1,940
Original Poster
Thanks,
I'll try to clean the visible contacts once I get a hold on some alcohol and come back with results after testing.
04-11-2010, 11:51 AM   #8
Pentaxian
Just1MoreDave's Avatar

Join Date: Feb 2007
Location: Aurora, CO
Photos: Gallery | Albums
Posts: 4,859
QuoteOriginally posted by Pablom Quote
I'm not sure what you mean by interior contacts, it looks fine from outside, do I have to open the screws and mess inside? I'm willing to do it if I'd have an idea of what to do.
The outside contacts might need cleaning but I was thinking inside the lens. The contact that transmits digital information is closest to the shaft-drive AF socket. Inside the lens you'll see one or two brush contacts like this:



As the barrel rotates, the contacts are either connected or not, so you can see how different positions are different binary codes. I said before that these contacts are easy to get to. Obviously in this case, it involved removing a lot of the lens stuff, but sometimesthis brush contact is on the outside of the barrel.

04-25-2010, 09:47 AM   #9
Pentaxian
Pablom's Avatar

Join Date: Feb 2010
Location: Jerusalem
Posts: 1,940
Original Poster
Thank you all for the help. I didn't open anything or even clean the contacts but I've been using the lens quite a lot and the problem never came back since the first day, I wonder what might be the reason for that...

very nice lens btw
04-25-2010, 04:21 PM   #10
Veteran Member
twokatmew's Avatar

Join Date: Jan 2010
Location: Lansing, MI
Photos: Albums
Posts: 509
QuoteOriginally posted by Pablom Quote
Thank you all for the help. I didn't open anything or even clean the contacts but I've been using the lens quite a lot and the problem never came back since the first day, I wonder what might be the reason for that...

very nice lens btw
Cool! I love it on those rare occasions when something broken magically starts working again.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
35-70mm, af, camera, k-mount, kit, lens, pentax lens, quality, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Which smc m lens up to 70mm? bigK Pentax SLR Lens Discussion 7 09-30-2009 11:48 AM
Help with lens problem Glenn M Pentax SLR Lens Discussion 2 08-23-2009 07:46 AM
Kit lens lens shade problem... grhazelton Pentax SLR Lens Discussion 4 10-28-2008 01:41 PM
Sigma 28-70mm f/2.8 EX DF lens Mechan1k Pentax SLR Lens Discussion 0 04-06-2008 05:31 AM
What is this lens? Pentax 35-70mm f3.5 Papersniper Pentax SLR Lens Discussion 11 11-03-2007 06:24 AM



All times are GMT -7. The time now is 11:44 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top