Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-21-2010, 01:29 AM   #1
New Member




Join Date: Jan 2010
Location: London
Posts: 6
50mm f1.4 FA aperture reading not showing

Hi

I've just bought a second-hand 50mm f1.4 which appears to be in very good condition. On my k-x it works just fine. However, on my K-7, it only intermittendly shows an aperture reading in the viewfinder/LCD etc.

There seems to be a little bit of "give" in the lens mount/aperture ring A setting, and moving the lens around while mounted does seem to help bring up the aperture reading.

All other lenses work fine on my k-7.

My question is: Does anyone have experience of this issue? And can I resolve it by, eg, tightening the mount screws or cleaning the lens contact points? Otherwise I will return it.

Thanks in advance.

04-21-2010, 01:43 AM   #2
Veteran Member
Zebooka's Avatar

Join Date: May 2008
Location: Russia, Siberia, Novosibirsk
Posts: 323
Clean up contacts of the lens and the camera.
This happens when data or A contacts of lens are not in contact with a body.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
50mm, 50mm f1.4 fa, aperture, f1.4, k-7, k-mount, lens, pentax lens, slr lens
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax M 50mm f1.7 aperture ring kbryant Pentax SLR Lens Discussion 1 03-25-2010 10:38 AM
lens model in EXIF not showing in Aperture 2.1.2 debbie Digital Processing, Software, and Printing 19 02-03-2010 11:19 AM
vivitar series 1 v3 f2.8-5_No aperture reading dcmsox2004 Pentax SLR Lens Discussion 5 04-05-2009 06:08 PM
M 50mm F1.7 aperture problem atyab Pentax DSLR Discussion 4 03-28-2009 08:22 AM
aperture not opening at 50mm chals Pentax SLR Lens Discussion 11 03-12-2007 06:20 AM



All times are GMT -7. The time now is 10:00 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top