Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-29-2010, 09:09 AM   #1
Inactive Account




Join Date: May 2010
Location: Texas
Posts: 4
Film Advance issues- ME Super

I have an ME Super and it has worked fine through 3 rolls of film. My wife picked it up at a yard sale for $10.00 with all manuals,cleaning equip, case,
strap, & 200mm zoom. Halfway through my fourth roll the film advance lever
stopped halfway through the advance. It WILL NOT move! What is the problem, and how can I fix it? I want to sell the whole set up on E-bay and
I know I'd get more if the body functioned. Any help would be much ap-
preciated.Thanks.
Nathan
************

05-29-2010, 10:25 AM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,959
I though I replied to this thread in a different forum. Please don't post duplicate threads!
05-29-2010, 10:29 AM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,959
See this thread: https://www.pentaxforums.com/forums/pentax-film-slr-discussion/102932-film-ad...-me-super.html
06-01-2010, 07:19 AM   #4
B&H Photo Specialist
Chuck-B&H's Avatar

Join Date: May 2010
Location: New York
Posts: 856
Hello,

The first thing I would do is remove the film and see if this was the cause. Film will sometimes jam inside the canister. Additionaly, I have been guilty of thinking I had a 36 exp roll of film in my camera and found out the hard way it was not.

C h u c k C a p r i o l a
Live Chat and E-Mail Sales Manager B&H Photo-Video

Thank you, we appreciate your business.
*** Peace on Earth ***

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
advance, film, film advance
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Film Advance issues- ME Super halfpack Pentax Film SLR Discussion 4 05-29-2010 09:20 AM
ME Super help - no film advance crank tension, rewind button stuck mclean8 Pentax Film SLR Discussion 2 11-06-2009 07:27 PM
Super Program problem with film advance and shutter release Laurie60014 Pentax Film SLR Discussion 6 07-18-2008 09:00 PM
ME Super film advance lever problem! Thursday Pentax Film SLR Discussion 8 09-12-2007 12:07 AM
Pentax MG film advance Vellian Pentax Film SLR Discussion 1 02-05-2007 07:13 AM



All times are GMT -7. The time now is 06:49 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top