Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-29-2011, 09:34 AM   #1
Site Supporter
Pepe Guitarra's Avatar

Join Date: Nov 2010
Location: California
Photos: Gallery | Albums
Posts: 2,060
Question for B&H

Hi B&H, on October 9/11 I purchased a Pentax DA 35mm f2.4 lens via website and I got it several days later. I tested immediately with the K5 and worked fine. It is an awesome lens. I kepted in the box since then. Few days ago, I used it for some Thanksgiving photos and was excellent. Great photos. However, when I switched to my K5, the lens stayed at f2.4 (wide opened) and did not shoot unless I allowed apperture ring open (option 2 in the manual). Even then only shot wide open. It does not shoot in manual either. It does shoot in automatic but wide open. WHen I put it back on the K5, it works fine. To check it was not my Kx, I tried my other Kx and it is the same thing. I tried it on a friend's Kx and it is the same. Do you know of any setting or any other thing that may be causing this? I even reset on e of the Kx to factory setup and still does not work. I sent an email to customer service and am waiting for the response. The reason I place this post here is to see if any one has had the same experience and what if anything, they did to solve the problem before determining that the lens is faulty. Thanks.

11-29-2011, 03:11 PM   #2
B&H Photo Specialist
Chuck-B&H's Avatar

Join Date: May 2010
Location: New York
Posts: 866
Hello,

I E-mailed Pentax Tech support:

"The lens needs to be looked at by our shop. If the lens behaved the same way on a different K-x, the camera is probably OK. Did the customer mention if other lenses are working OK on his K-x? If they are, there could be an issue with the contacts on the lens."


C h u c k C a p r i o l a
Live Chat and E-Mail Sales Manager B&H Photo-Video

Thank you, we appreciate your business.
*** Peace on Earth ***
11-29-2011, 03:24 PM   #3
Site Supporter
Pepe Guitarra's Avatar

Join Date: Nov 2010
Location: California
Photos: Gallery | Albums
Posts: 2,060
Original Poster
Thank you B&H: The lens is fine with the K5, but not ok with the two Kx I have. I contacted your B&H customer service and am waiting for their instructions on how to ship it back to you or two whom. Thanks, Pepe.
12-01-2011, 02:46 PM   #4
Site Supporter
Pepe Guitarra's Avatar

Join Date: Nov 2010
Location: California
Photos: Gallery | Albums
Posts: 2,060
Original Poster
Have you updated your Pentax K-x with the latest Firmare ?

I contacted Pentax Customer Service and they offer to receive the lens for review and repair, since it is still covered by the 1-year manufacturer's warranty. They asked me that before I send the lens, I should upgrade the firmaware of the Kx to 1.02. This could solve the problem. I kee updating this post in case you have the same case. I will let you know after update the firmare of the Kx if the problem is solved. In the meantime, I continue using the lens on my K5.

12-03-2011, 07:46 PM   #5
Site Supporter
Pepe Guitarra's Avatar

Join Date: Nov 2010
Location: California
Photos: Gallery | Albums
Posts: 2,060
Original Poster
Firmware upgraded, still lens does not work on Kx. Lens is going to Pentax en Arizona for repairs.
12-20-2011, 06:20 PM   #6
Site Supporter
Pepe Guitarra's Avatar

Join Date: Nov 2010
Location: California
Photos: Gallery | Albums
Posts: 2,060
Original Poster
Lens sent 2 weeks ago, no news from pentax yet (CRIS Camera does the customer tec support for Pentax). Any body has any experience with them and their turn around?
12-28-2011, 09:28 AM   #7
Site Supporter
Pepe Guitarra's Avatar

Join Date: Nov 2010
Location: California
Photos: Gallery | Albums
Posts: 2,060
Original Poster
Update

I am still without the lens and Pentax Customer Service (customerservice@criscamera.com) does not return emails. Let's wait and see.

Last edited by Pepe Guitarra; 01-03-2012 at 11:01 AM.
01-03-2012, 11:03 AM   #8
Site Supporter
Pepe Guitarra's Avatar

Join Date: Nov 2010
Location: California
Photos: Gallery | Albums
Posts: 2,060
Original Poster
I got my lens back on time for Christams. Those Pentax guys are really good. The lens had one contact that could not read well (electronic problem). They changed it and the lens is 100 % perfect. I was able to shoot my Christmas photos. Thanks to B&H for their support and quick response. Their contact with Pentax Customer Service was really valuable. I am a happy man again.

01-03-2012, 11:18 AM   #9
B&H Photo Specialist
Chuck-B&H's Avatar

Join Date: May 2010
Location: New York
Posts: 866
Another Christmas miracle !

Enjoy, thanks for posting.

Chuck
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
days, f2.4, fine, k5, kx, lens, photos
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
DA 35 f1.4 & Sweespot question sany Pentax SLR Lens Discussion 8 06-14-2011 02:30 AM
Dear B&H a question about shipping costs Ehlacore Ask B&H Photo! 41 01-10-2011 09:36 AM
Prime & Zoom Lens Question LadyRo Pentax SLR Lens Discussion 9 06-01-2010 06:34 PM
For Sale - Sold: (AUS) SMC Pentax-M 50mm/1.4 & A35-105mm/3.5 & MV1 body & DB1 Grip (AUS) ddhytz Sold Items 4 04-22-2010 03:28 AM
B&W Highlight question pdxbmw Digital Processing, Software, and Printing 4 04-03-2010 08:18 PM



All times are GMT -7. The time now is 02:47 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top