Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-07-2010, 07:32 PM   #1
New Member




Join Date: Oct 2010
Location: New York
Photos: Albums
Posts: 6
New Pentax K-5 owner great camera but..

Hi all. I was going to introduce myself earlier but I wanted to take some more pictures along with the introduction of myself being a new member. I took some shots out today and when I got home to check the pictures my LCD looked all distorted... I was so upset... I didn't drop it or mistreated it.. I had the K20D and the K7 before and it never gave me any issues.. now what worries me is that I bought it from a Canadian ebay store named "prodigital2000" looks like they have great feedback and all but I'm worried if they might think I dropped it or something.. I know when something has been physically damaged or when it's a manufacture defect...and to me this looks like it's a manufacture defect... I checked the sensor to see if anything was wrong but everything looks perfect... does anyone know why this may have happened? very depressed here :'(

I bought the camera on the 26th of October.. they say there is a 14 day return period.. I hope they don't think I done something to the camera intentionally to get a refund or something.. I know because I work at Geek Squad and I seen people done that... sigh.......

11-07-2010, 07:36 PM   #2
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,574
It sounds like the LCD weirdness issue some K-x users have reported from time to time when their batteries are playing up.

What debug steps have you taken to try and identify why this happens?

EDIT: Does the screen look like the K-x screen shown in this thread? Pls post a pic if not.
https://www.pentaxforums.com/forums/pentax-dslr-discussion/119017-k-x-spazz-attack.html

Last edited by rawr; 11-07-2010 at 07:41 PM.
11-07-2010, 07:43 PM   #3
New Member




Join Date: Oct 2010
Location: New York
Photos: Albums
Posts: 6
Original Poster
QuoteOriginally posted by rawr Quote
It sounds like the LCD weirdness issue some K-x users have reported from time to time when their batteries are playing up.

What debug steps have you taken to try and identify why this happens?

EDIT: Does the screen look like the K-x screen shown in this thread? Pls post a pic if not.
https://www.pentaxforums.com/forums/pentax-dslr-discussion/119017-k-x-spazz-attack.html

QuoteOriginally posted by rawr Quote
It sounds like the LCD weirdness issue some K-x users have reported from time to time when their batteries are playing up.

What debug steps have you taken to try and identify why this happens?
My girlfriend googled to see if there was anyone else with this issue but she found something with the same exact description to what was going on with mine:
Pentax Offers Part-Replacement for Six Optio Models - Compact Cameras - DigitalCamerainfo.com

earlier today I took this shot of my cat and everything was A-ok:

http://www.adept-foto.com/Camerashots/Hylus%20%282%29.jpg

I wouldn't know how to debug..(noob here when it comes to fixing issues like this since this is my first time this ever happened)

that picture of the KX looks way worse than mine.. I will try my best to take a clear picture..
11-07-2010, 07:56 PM   #4
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,574
By debug I mean take a few steps to try and narrow down the causes of the problem.
You said you worked at Geek Squad. Isn't that what you do...

Eg - did you take the batteries out and try again, swap SD cards around etc to try and see under what circumstances the problem occured, if it happened only sometimes, or if it happened all the time etc.

11-07-2010, 07:58 PM   #5
Veteran Member




Join Date: Aug 2010
Location: Missouri
Posts: 535
Houston, we have a problem...
11-07-2010, 07:59 PM   #6
Pentaxian
Miguel's Avatar

Join Date: Sep 2007
Location: Near Seattle
Photos: Gallery
Posts: 2,694
So exchange it for another one. If the vendor hassles you I would think the credit card company would offer some protection. It's not like they don't get returns at the dealer.

M
11-07-2010, 08:01 PM   #7
New Member




Join Date: Oct 2010
Location: New York
Photos: Albums
Posts: 6
Original Poster
QuoteOriginally posted by rawr Quote
By debug I mean take a few steps to try and narrow down the causes of the problem.
You said you worked at Geek Squad. Isn't that what you do...

Eg - did you take the batteries out and try again, swap SD cards around etc to try and see under what circumstances the problem occured, if it happened only sometimes, or if it happened all the time etc.

yeah I know lol.. I'm just a bit nervous and scared about the issue.. I saved to much for this camera sigh...ok here are some of the steps I toook:

1. Removed Sigma 50mm f1.4 Lens and used my old 18-55 Pentax lens = Same issue
2. Replaced 8GB Sandisk Extreme with 16GB Kingston = same issue
3. Removed battery charged it for a bit = same issue
4.
11-07-2010, 08:09 PM   #8
Veteran Member




Join Date: Dec 2007
Posts: 923
Thats's not normal.
Looks like there's some buggy electronics in your unit.

If a camera was dropped with sufficient force to damage its workings, it would show on the body. There shouldn't be any mistaken suspicion of that happening.

11-07-2010, 08:17 PM   #9
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,574
QuoteOriginally posted by Hylus-AF Quote
here are some of the steps I toook:
Good moves. But it doesn't look promising so far.

- Does it occur in all display modes - eg is it only when you use LiveView, or does it look like that when you just do stuff like browse the menus.
- Does it occur only after using LiveView or video for a long period of time?
- Does it occur in all shooting modes (TAv, P, Av etc) or just a specific mode?
- When you reset the camera to all it's defaults (Menu > Setup > 3 > Reset) does that help?
- Does it occur under all lighting conditions (tungsten, flouro, sunlight)?
- Does it have any impact on images recorded by the camera?

Other than that, send it back as a return.
11-07-2010, 08:20 PM   #10
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,574
QuoteOriginally posted by Hylus-AF Quote
I even put a screen protector the first day I got it...
If you take the screen protector off, does the problem go away?

BTW: why use a screen protector? I never figured out why people did that.

EDIT: what a piece of crap that screen protector seems to be:
- UV (Ultraviolet) Coating
- Proprietary Low-Reflection Coating
- High light Transmission [sic] - over 92%

In other words it blocks about 10% of the light coming out from your LCD screen and distorts the color fidelity of your display too. Ughh.

Last edited by rawr; 11-07-2010 at 08:29 PM.
11-07-2010, 08:26 PM   #11
New Member




Join Date: Oct 2010
Location: New York
Photos: Albums
Posts: 6
Original Poster
- Does it occur in all display modes - eg is it only when you use LiveView, or does it look like that when you just do stuff like browse the menus: yes all displays

- Does it occur only after using LiveView or video for a long period of time? Both

- Does it occur in all shooting modes (TAv, P, Av etc) or just a specific mode? All modes

- When you reset the camera to all it's defaults (Menu > Setup > 3 > Reset) does that help? Same issue

- Does it occur under all lighting conditions (tungsten, flouro, sunlight)? yes
- Does it have any impact on images recorded by the camera? Pictures look perfect when I uploaded to computer

If you take the screen protector off, does the problem go away? Same issue

BTW: why use a screen protector? I never figured out why people did that: Just in case I guess Obviously didn't protect from this happening lol...

Other than that, send it back as a return: Yes


Thanks for the help everyone.. Hopefully the seller will issue an exchange or a refund.. this won't drive me away from Pentax because I believe and even when customers come to me for advice on which camera to get I always tell them to get a Pentax camera..
11-07-2010, 08:31 PM   #12
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,042
I wouldn't bother trying to debug it, I'd just go get another one.
I realize the peril of dealing mail order, this is the price you pay.
Call them and have them ship you a new one. When it arrives, ship the broken one back in the packaging ProDigital sends out.
11-07-2010, 08:47 PM   #13
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,574
Oh well, it was worth a try to see if there was something specific or simple causing the problem. Thanks for patiently answering all the questions.

If the problem is there all the time no matter how you use the camera or what you play with or adjust, it's gotta be dud hardware.

But next time, skip the screen protector perhaps, just to be safe. Install screen protector, then have screen problems seems a bit suss to me.
11-07-2010, 08:51 PM   #14
New Member




Join Date: Oct 2010
Location: New York
Photos: Albums
Posts: 6
Original Poster
QuoteOriginally posted by rawr Quote
Oh well, it was worth a try to see if there was something specific or simple causing the problem. Thanks for patiently answering all the questions.

If the problem is there all the time no matter how you use the camera or what you play with or adjust, it's gotta be dud hardware.

But next time, skip the screen protector perhaps, just to be safe. Install screen protector, then have screen problems seems a bit suss to me.
Thanks rawr and everyone else for your help. I will ask for a replacement! and once I do expect to see me here showing off some pictures I will take with the K-5. Another reason why I got the K-5 was for the video.. I am actually going to shoot my first film next year and plan to use the K-5 along with my Panasonic GH1.
11-07-2010, 08:59 PM   #15
Veteran Member




Join Date: Aug 2009
Location: NY
Posts: 407
Tough to get a faulty camera, they are rare but stuff happens. Good to see this has not put you off. It's a great camera and I am sure you will have many years of pleasure taking pictures and video.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-5, k-5 ii, k-5 iis, k5, manufacture, pentax k-5, pictures
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Olympus Stylus Epic, black, very compact film camera with great lens pingflood Sold Items 4 03-15-2009 11:03 AM
Great camera bag deal SpecialK Pentax Camera and Field Accessories 5 06-23-2008 07:00 PM
GREAT Beginner DSLR owner tips kiamon Pentax DSLR Discussion 10 06-03-2008 03:42 PM
what about a great compact camera from Pentax??? celetron Pentax DSLR Discussion 10 01-17-2007 09:37 AM



All times are GMT -7. The time now is 05:46 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top