Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-19-2010, 02:28 AM   #1
Senior Member
eigelb's Avatar

Join Date: Mar 2009
Location: Italy
Posts: 174
Pentax k-5 Debug mode

how can i enter in the debug mode / menu of the K-5

tried with MODSET.505 - [OPEN_DEBUG_MENU]
[DEBUG_MODE EN]

Turned camera on with MENU or delete button pressed
flash door open and closed - dosent work.

Does anyone know how it works ?


Last edited by eigelb; 11-24-2010 at 12:30 PM.
03-21-2011, 02:27 PM - 1 Like   #2
Junior Member
Antanico's Avatar

Join Date: Feb 2010
Location: Taneto Beach
Posts: 38
Hi Egelb,
edit the MODSET.505 in the following way as you missed a part in the second line:
[OPEN_DEBUG_MENU]
[SW_DEBUG_MENU EN]
[DEBUG_MODE EN]
[DEBUG_MODE DIS]
[RELEASE_AGING]
[SCRIPT_EN_MODE EN]
[SCRIPT_EN_MODE DIS]

Save it and restart the camera pressing menu and the card door opened.
Ciao
Ant
03-21-2011, 03:49 PM   #3
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
Can the version number be changed so that one can re-install an Older firmware?

03-22-2011, 05:00 AM   #4
Senior Member
Mikhail_Kriviniouk's Avatar

Join Date: Sep 2010
Location: Ekaterinburg
Posts: 111
does not work for me

QuoteOriginally posted by Antanico Quote
Hi Egelb,
edit the MODSET.505 in the following way as you missed a part in the second line:
[OPEN_DEBUG_MENU]
[SW_DEBUG_MENU EN]
[DEBUG_MODE EN]
[DEBUG_MODE DIS]
[RELEASE_AGING]
[SCRIPT_EN_MODE EN]
[SCRIPT_EN_MODE DIS]

Save it and restart the camera pressing menu and the card door opened.
Ciao
Ant

done all this. no debug menu...

03-22-2011, 02:46 PM   #5
Senior Member
LeFanch's Avatar

Join Date: Dec 2007
Location: Bordeaux area when off, working in Norway
Posts: 101
I think I have read somewhere that the base name for the file is not MODSET for the K5.
And I do not remember reading the correct one either.
I think it is still being investigated. Am I mistaken?
03-24-2011, 12:00 PM   #6
Veteran Member
Smeggypants's Avatar

Join Date: Sep 2010
Posts: 1,536
QuoteOriginally posted by Antanico Quote
Hi Egelb,
edit the MODSET.505 in the following way as you missed a part in the second line:
[OPEN_DEBUG_MENU]
[SW_DEBUG_MENU EN]
[DEBUG_MODE EN]
[DEBUG_MODE DIS]
[RELEASE_AGING]
[SCRIPT_EN_MODE EN]
[SCRIPT_EN_MODE DIS]

Save it and restart the camera pressing menu and the card door opened.
Ciao
Ant
Modest.505 doesn't work here. Maybe this was for version 1.01 only. I have 1.03 installed
03-24-2011, 12:11 PM   #7
Site Supporter




Join Date: Jul 2008
Location: South Africa
Posts: 62
I also tried MODSET.505 last night without any success, tried with the card door open and pressing all the different button combinations, no luck. Version 1.03
Greg
03-24-2011, 01:03 PM   #8
Pentaxian
Class A's Avatar

Join Date: Aug 2008
Location: Wellington, New Zealand
Posts: 8,934
QuoteOriginally posted by Antanico Quote
edit the MODSET.505 in the following way as you missed a part in the second line:
[OPEN_DEBUG_MENU]
[SW_DEBUG_MENU EN]
[DEBUG_MODE EN]
[DEBUG_MODE DIS]
[RELEASE_AGING]
[SCRIPT_EN_MODE EN]
[SCRIPT_EN_MODE DIS]
...
I would not run that script.
"RELEASE_AGING" starts a sequence that artificially ages the shutter.

Also, even if the script had been started, it would have disabled the debug menu again.

The only two entries needed to open the debug menu are
[DEBUG_MODE EN]
[SCRIPT_EN_MODE EN]
Have a look at the respective Pentax Hack page.

It will tell you, among other things, that the base filename for the K-5 is not "MODESET" and so far unknown.

Just out of interest: Why do you want to go into the debug menu? As a K100D user I found it useful to adjust the AF calibration but K-5 users can do that without the debug menu. So I'm interested what the motivation is for a K-5 user.

03-24-2011, 01:22 PM   #9
Site Supporter




Join Date: Jul 2008
Location: South Africa
Posts: 62
Pentax k-5 Debug mode

QuoteOriginally posted by Class A Quote
Just out of interest: Why do you want to go into the debug menu? As a K100D user I found it useful to adjust the AF calibration but K-5 users can do that without the debug menu. So I'm interested what the motivation is for a K-5 user.
Hi, Thanks for the feed back, I've been trying to set the AF fine adjustment on all my AF lenses and found that the +10 "Apply all" and the +10 "this lens only" was not quite enough to fix the BF on my Sigma 50-500. So before taking it in I wanted to play with what I hoped was the base setting for the phase detect AF system. I must admit that I'm also a bit confused as to weather or not the two adjustments "Apply All" and "Apply this Lens" are cumulative. The other reason for trying Debug is because it's there :<)) I have used it on my K200D
Greg

Last edited by gregmoll; 03-24-2011 at 01:27 PM.
03-24-2011, 01:37 PM   #10
Veteran Member
RBellavance's Avatar

Join Date: Nov 2006
Location: Near Montréal, Canada
Photos: Gallery
Posts: 1,716
QuoteOriginally posted by gregmoll Quote
I must admit that I'm also a bit confused as to weather or not the two adjustments "Apply All" and "Apply this Lens" are cumulative.
They are not.
03-24-2011, 01:48 PM   #11
Site Supporter




Join Date: Jul 2008
Location: South Africa
Posts: 62
Thanks, that's what I thought and that's why I was interested in getting into the Debug mode to try and add a bit more + adjustment. Maybe I should play with the three AF module screws on the bottom of the camera :<(((((

Greg
03-24-2011, 02:22 PM   #12
Pentaxian
Class A's Avatar

Join Date: Aug 2008
Location: Wellington, New Zealand
Posts: 8,934
QuoteOriginally posted by gregmoll Quote
Maybe I should play with the three AF module screws on the bottom of the camera :<(((((
They are called "screws" because you can easily screw up fiddling with them. Seriously, I wouldn't touch them unless you know exactly what you are doing. There might be one that just controls overall distance but in general you need a calibration test bed to set them to their optimal positions.

Does the K-5 show any BF on Pentax lenses? Normally you'd send in the camera plus lens but to the best of my knowledge Pentax only calibrates cameras in conjunction with Pentax lenses. If your camera shows a balanced performance with other lenses, it might be that the Bigma needs servicing.
03-24-2011, 02:42 PM   #13
Site Supporter




Join Date: Jul 2008
Location: South Africa
Posts: 62
Now AF Adjust

DA*16-50 needed +10.
DA*60-250 needed +5.
DA18-55 +4.
50-500 was still back focusing at +10, I guess it needs about another +5.
FA100 2.8 macro was -1.

Once I've got the Phase AF correct and in agreement with the Contrast focus I can fit my Canon Ec-b split focus screen and calibrate that.
Greg
03-24-2011, 05:08 PM   #14
Pentaxian
Class A's Avatar

Join Date: Aug 2008
Location: Wellington, New Zealand
Posts: 8,934
QuoteOriginally posted by gregmoll Quote
DA*16-50 needed +10.
DA*60-250 needed +5.
DA18-55 +4.
50-500 was still back focusing at +10, I guess it needs about another +5.
FA100 2.8 macro was -1.
Seems like there is a positive bias in there which could be caused by the camera. If a camera calibration could knock off ~+6, you'll probably find working adjustment settings for all your lenses. You could send in the camera plus the 16-50 with a note that you need positive adjustments for other lenses as well (some exceeding the +10 minimum) and hence expect that they can recalibrate the AF module to need less adjustment for most of your lenses out of the box.

Of course it could be the case that your camera is spot on and all the lenses are off. Only a proper service agent is able to find out.

It would be interesting to hearing from your experience, should you choose to send the camera in.
03-24-2011, 07:45 PM   #15
Site Supporter




Join Date: Jul 2008
Location: South Africa
Posts: 62
Thanks, I'll do some more checking this weekend.

Greg

Last edited by gregmoll; 03-24-2011 at 08:12 PM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, debug, dslr, k-5, k-5 ii, k-5 iis, k5, menu, mode, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
k-7 debug mode - how to enter Nass Pentax DSLR Discussion 17 01-17-2015 04:56 PM
Anyone use K10D at debug mode? rosier19 Pentax DSLR Discussion 25 12-18-2010 07:34 PM
K10D Firmware 1.3 Debug Mode Unleashed! RiceHigh Pentax DSLR Discussion 148 10-01-2010 01:48 PM
How to access Debug Mode of Pentax K200 Thareen Pentax DSLR Discussion 28 04-08-2010 01:39 PM
Debug mode on K-x. ilya80 Pentax DSLR Discussion 2 11-04-2009 05:12 AM



All times are GMT -7. The time now is 11:09 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top