Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-21-2010, 05:29 PM   #1
Inactive Account




Join Date: Nov 2010
Location: New Jersey
Photos: Albums
Posts: 9
K-5 strange behavior - rear dial wheel delay and battery issue.

I've had my k5 for three weeks now and notice a few small bugs other than those already mentioned in other threads.

1. My rear dial wheel will not respond immediately when turned. It sometimes takes a few clicks to begin whatever function asssigned. Does anyone else have this problem?

2. Even when there is charge remaining on the battery the camera will suddenly show zero or low battery, evertything will blink and everything stops working for about 2 seconds and then it goes back to normal. I originally thought this might be the byproduct of a new batty but it happened again today in the 4 th charge cycle.

Any thoughts? This is my first pentax (a100, d90, a550) and thought this might be a common issue?


Last edited by limbonaut; 11-21-2010 at 07:33 PM.
11-21-2010, 09:57 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,217
Are you sure your camera isn't going into standby mode, and then the turning of the e-dial wakes it up? That's about the only explanation I can think of.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

11-21-2010, 10:20 PM   #3
m8o
Veteran Member
m8o's Avatar

Join Date: Jul 2007
Location: 40-55'-44" N / 73-24'-07" W [on LI]
Photos: Gallery | Albums
Posts: 3,102
Upgrade to the v1.01 bios. I think there was debug code in the v1.00 bios. A lot of things are a lot snappier in v1.01.

I found the battery meter to go from 2/3 to near zero whenever I went to live view or movie mode with the v1.00 bios. I didn't try either on the v1.01 bios yet to determine if this has changed.
11-21-2010, 10:26 PM   #4
Inactive Account




Join Date: Nov 2010
Location: New Jersey
Photos: Albums
Posts: 9
Original Poster
QuoteOriginally posted by Adam Quote
Are you sure your camera isn't going into standby mode, and then the turning of the e-dial wakes it up? That's about the only explanation I can think of.
The rear dial delay happens all the time. I take it that it's not common to have several clicks with no response? At first I thought it was a software bug or that it wss a normal delay but the front dial has no such lag

I did the 1.01 update and the problem persists.

The battery issue happens in regular p mode and not in live view.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, charge, dslr, k-5, k-5 ii, k-5 iis, k5, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange behavior from Tele-Takumar 300mm straightshooter Pentax SLR Lens Discussion 6 06-06-2010 05:56 AM
Matrix metering strange behavior... dlacouture Pentax DSLR Discussion 20 01-22-2009 08:20 AM
Strange *ist ds behavior trd300gt Pentax DSLR Discussion 1 11-14-2008 04:53 AM
Strange K10D + Pentax 18-250 behavior henzo Pentax DSLR Discussion 1 06-03-2008 05:54 PM
K100d built in flash: strange behavior Rafael Pentax DSLR Discussion 5 12-17-2007 03:02 PM



All times are GMT -7. The time now is 04:56 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top