Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-30-2010, 02:39 AM   #1
Inactive Account




Join Date: Nov 2010
Posts: 3
Battery Grip AA problem!

Hi all,

Today i was supposed to shoot some video with my k-5, and I forgot to charge my main battery pack. I thought that I was safe anyway since i had a battery grip that also has the option to use AA batteries.

I inserted a set of newly charged Varta 2700 mAh, but after about 4-5 min of use the camera shut down due to low battery level!

I then inserted non rechargeable Duracell Alkaline batteries. The same thing happened.

I even opened a new pack of Duracels, and the same thing happened...

Anyone with the same problem?

11-30-2010, 04:26 AM   #2
Senior Member




Join Date: Jan 2009
Posts: 138
There is an option in the menu for different batteries, have you checked that? I can't check it for you because I just came from outside and the camera is warming up.
11-30-2010, 04:36 AM   #3
New Member




Join Date: Nov 2010
Location: Michigan
Posts: 5
I had the same problem with mine - new alkalines exhausted after a very short time. Didn't matter what battery type I selected (auto, alkaline) from the menu. I did get an extra standard Pentax battery, and that works fine in the battery grip.

I'm wondering if there's a bug in the software where you specify which battery to use first (main, grip, or auto).

Disappointing that AA's are a problem in my grip. Pete
11-30-2010, 05:54 AM   #4
Pentaxian
Mike.P's Avatar

Join Date: Mar 2008
Location: South Coast .. UK
Photos: Gallery
Posts: 1,737
Is this with the original Pentax grip or are you using one of the cheap chinese copies. ?

11-30-2010, 07:23 AM   #5
Forum Member
PinarelloOnly's Avatar

Join Date: Jan 2009
Location: Shoreline CT
Photos: Gallery | Albums
Posts: 86
Rechargeable batts DO NOT have the fast voltage recovery that lithiums do so,
you will see a low or dead battery on your display. More so than ever, when
shooting video with DSLRs you are going to have to use AA lithiums in your grips!!!!!
11-30-2010, 08:24 AM   #6
Senior Member
Rick Clark's Avatar

Join Date: Nov 2010
Location: Provo, Utah
Posts: 128
QuoteOriginally posted by emblemex Quote
I had the same problem with mine - new alkalines exhausted after a very short time. Didn't matter what battery type I selected (auto, alkaline) from the menu. I did get an extra standard Pentax battery, and that works fine in the battery grip.

I'm wondering if there's a bug in the software where you specify which battery to use first (main, grip, or auto).

Disappointing that AA's are a problem in my grip. Pete
Read page 279 in the users manual.
11-30-2010, 08:24 AM   #7
ogl
Pentaxian
ogl's Avatar

Join Date: Dec 2007
Location: Siberia
Photos: Gallery | Albums
Posts: 7,114
QuoteOriginally posted by Blanco Quote
Hi all,

Today i was supposed to shoot some video with my k-5, and I forgot to charge my main battery pack. I thought that I was safe anyway since i had a battery grip that also has the option to use AA batteries.

I inserted a set of newly charged Varta 2700 mAh, but after about 4-5 min of use the camera shut down due to low battery level!

I then inserted non rechargeable Duracell Alkaline batteries. The same thing happened.

I even opened a new pack of Duracels, and the same thing happened...

Anyone with the same problem?
USE SANYO ENELOOP or LITHIUM AA.
11-30-2010, 08:50 AM   #8
Forum Member
pentax user's Avatar

Join Date: Oct 2010
Posts: 85
chinese knock off grip does that

11-30-2010, 09:47 AM   #9
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
QuoteOriginally posted by emblemex Quote
I had the same problem with mine - new alkalines exhausted after a very short time. Didn't matter what battery type I selected (auto, alkaline) from the menu. I did get an extra standard Pentax battery, and that works fine in the battery grip.

I'm wondering if there's a bug in the software where you specify which battery to use first (main, grip, or auto).

Disappointing that AA's are a problem in my grip. Pete
Alkaline batteries have always been terrible in dSLRs. I think since the intro of the *istD they have been a problem. If I remember correctly the K7/K5 has a menu option where you can tell the camera what Type of AAs you are using but you're far better off getting a third party generic D-Li90..

Welcome aboard btw.

12-02-2010, 12:23 PM   #10
Senior Member
sjtryon's Avatar

Join Date: Nov 2010
Location: Upstate, NY, USA
Posts: 170
Same Issue...

I have had exactly the same problem using Lithium AA. I discovered the problem when using Live View. After a shot or two, the camera would shut down with the low battery message.

My grip is from Pentax, not a knock-off.

I think there is a problem...

Also, have any other grip users discovered that their EV compensation value button doesn't work on the grip? I noticed this a couple days ago and am guessing that reason alone will have me contacting Pentax repair.

Steven
12-02-2010, 02:29 PM   #11
Senior Member
jrforman's Avatar

Join Date: Mar 2008
Location: Minneapolis
Photos: Gallery | Albums
Posts: 202
QuoteOriginally posted by sjtryon Quote
Also, have any other grip users discovered that their EV compensation value button doesn't work on the grip? I noticed this a couple days ago and am guessing that reason alone will have me contacting Pentax repair.

Steven
Mine works just fine.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
batteries, battery, battery grip, camera, dslr, grip, k-5, k-5 ii, k-5 iis, k5, pack, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM
For Sale - Sold: Pentax D-BG2 battery grip for K10D or K20D (battery included) (US) pswann Sold Items 1 11-01-2010 11:37 AM
battery grip causing K20 problem cwood Pentax DSLR Discussion 8 06-16-2009 11:19 PM
anyone else had a problem with broken shutter button on the D-BG2 battery grip? sholtzma Pentax Camera and Field Accessories 4 07-06-2008 01:27 PM
k20d battery grip problem qksilver Pentax DSLR Discussion 8 04-21-2008 12:22 AM



All times are GMT -7. The time now is 01:38 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top