Forgot Password
Pentax Camera Forums Home
 

View Poll Results: Is your K5d sensor stained?
YES - There are stains on my sensor 19356.43%
NO - My sensor has no stains 14943.57%
Voters: 342. You may not vote on this poll

Closed Thread
Show Printable Version Search this Thread
12-07-2010, 04:48 PM   #196
Veteran Member
alexeyga's Avatar

Join Date: Dec 2008
Location: Montreal, Canada
Posts: 838
Picked up the only one that Simon's in Laval got so far...

SN: 388XXXX ----- CLEAN!!!

made a shot of white paper sheet at f/22... boosted up the contrast... smooth as babies butt... However, I felt like an idiot inspecting a 16MP shot at 400% screen by screen... I think we're being too anal and over-paranoid.... After first dozen of lens-changes there will be more dust running around to worry about... These WR bodies do tend to attract lots of dust...

For what it's worth... Simon's is about to stop selling Pentax... main reason - Pentax Canada is doing nothing for marketing and they having a lot of issues getting any gear at all from them...

My 18-135 is not in yet... Got a very nice camera on my hands with no lenses to attach it to... There's more than a couple of DA and FA primes waiting for me this Saturday though..


Last edited by alexeyga; 12-07-2010 at 04:54 PM.
12-07-2010, 05:01 PM   #197
New Member




Join Date: Nov 2010
Location: United Kingdom
Posts: 12
Mine's dirty two

Hi There
actually, there's 3 dust bunnies, but not the stains that others have (I really have looked).

The dust bunnies only show above f22, so I think I'll keep house for them while the camera settles down.
12-07-2010, 07:17 PM   #198
Veteran Member
nulla's Avatar

Join Date: Jul 2008
Location: Melbourne Australia
Posts: 1,560
serial 3842383

all clear... was concerned with 2 spots and purchased Pentax suitable sensor swab and all is clear now


A lot have given serials... is there a recorded trend yet against serial numbers.


Neil

Last edited by nulla; 12-07-2010 at 07:38 PM.
12-07-2010, 07:38 PM   #199
Inactive Account




Join Date: Dec 2010
Posts: 6
I wrote a post on this thread a couple of pages ago. Since it seems that some people is still asking for pictures of the stains, there you have three:







My serial number is 38241261.

I never noticed anything strange on real-life pictures. No mysteries here, if we take into account that I rarely go beyond f/10. You can take a look of some of my pictures with the K-5 at flickr.

I am returning the camera. I will wait for Pentax to pronounce on this issue and meanwhile I will be back to my old good K10D.


Last edited by Jorge; 12-07-2010 at 09:54 PM. Reason: Grammar
12-07-2010, 07:54 PM   #200
Site Supporter




Join Date: Dec 2010
Location: Oregon
Posts: 44
QuoteOriginally posted by janneman Quote
Or fanboys pushing the "no"- button....
QuoteOriginally posted by ogl Quote
it's easy to see poll results with names.
Somehow I doubt over 50% of these cameras have the stain issue. A lot of QC goes into developing a camera and I would hope that Pentax engineers are just as capable of using the 100% crop tool as us consumers...
12-07-2010, 08:01 PM   #201
New Member
sean's Avatar

Join Date: May 2009
Location: Fort Chipewyan, AB, Canada
Photos: Gallery
Posts: 24
Got spots

3883038

Big blob appears in the middle of the frame at f/10 bad by f/16 up to f/22

Just got this camera today.
Bummer.

Think I'll hang on the camera for a bit, until Pentax has a fix.

Don't see the point of sending it off just to get another one with the same issue.

Did the sensor cleaning built in to the camera, tried to blow it off with rocket bulb. No joy.

Guess saying it's a big blob might be overstating it a bit. Still this fouls me up for macro, and I'd like it fixed/replaced for the money I spent as an early adopter.
Attached Images
View Picture EXIF
PENTAX K-5  Photo 

Last edited by sean; 12-07-2010 at 08:09 PM. Reason: clarification
12-07-2010, 08:24 PM   #202
Site Supporter




Join Date: Dec 2010
Location: Oregon
Posts: 44
QuoteOriginally posted by sean Quote
3883038

Big blob appears in the middle of the frame at f/10 bad by f/16 up to f/22

Just got this camera today.
Bummer.

Think I'll hang on the camera for a bit, until Pentax has a fix.

Don't see the point of sending it off just to get another one with the same issue.

Did the sensor cleaning built in to the camera, tried to blow it off with rocket bulb. No joy.

Guess saying it's a big blob might be overstating it a bit. Still this fouls me up for macro, and I'd like it fixed/replaced for the money I spent as an early adopter.

Maybe its my sceen, but I dont see anything...
12-07-2010, 08:31 PM   #203
Inactive Account




Join Date: Dec 2010
Posts: 6
QuoteOriginally posted by sean Quote
3883038

Big blob appears in the middle of the frame at f/10 bad by f/16 up to f/22

Just got this camera today.
Bummer.

Think I'll hang on the camera for a bit, until Pentax has a fix.

Don't see the point of sending it off just to get another one with the same issue.

Did the sensor cleaning built in to the camera, tried to blow it off with rocket bulb. No joy.

Guess saying it's a big blob might be overstating it a bit. Still this fouls me up for macro, and I'd like it fixed/replaced for the money I spent as an early adopter.
It seems a dust or water stain to me. Since you have tried with the sensor, did you take a look to the lens or to the filter? Have you tried a different lens?

I know these questions are quite obvious, but sometimes the most obvious causes can be the origin of the problem.

Anyway, good luck.


Last edited by Jorge; 12-07-2010 at 09:46 PM.
12-07-2010, 08:32 PM   #204
Pentaxian
bobmaxja's Avatar

Join Date: Mar 2010
Location: Laval, Quebec Canada
Posts: 1,700
Same for me . This is a not a string I do not count this as a defect
Seem a lot of Canadian K-5 start with 3883 as I ahave of of them
12-07-2010, 08:36 PM   #205
New Member
sean's Avatar

Join Date: May 2009
Location: Fort Chipewyan, AB, Canada
Photos: Gallery
Posts: 24
QuoteOriginally posted by PixleFish Quote
Maybe its my sceen, but I dont see anything...
It's there. Easier to see on full-size image.
Maybe it's not such a big deal. I'll use camera for a few weeks, see if and how it impacts my photos.
Might get the sensor cleaned or buy a kit.
12-07-2010, 08:40 PM   #206
New Member
sean's Avatar

Join Date: May 2009
Location: Fort Chipewyan, AB, Canada
Photos: Gallery
Posts: 24
If it wasn't for these forums, I doubt I'd have noticed this in real use.
There's a lesson here for me, I think.
12-07-2010, 10:45 PM   #207
Senior Member




Join Date: Oct 2009
Location: Kolkata
Photos: Gallery
Posts: 115
Sensor Stain

Checked mine thrice. No stain. none nada zero.
Serial 3815822, bought in Tokyo.
12-07-2010, 11:15 PM   #208
Junior Member




Join Date: Oct 2009
Posts: 25
No stains for me - tried at f11 and f13
12-07-2010, 11:52 PM   #209
Veteran Member
Tommot1965's Avatar

Join Date: Sep 2010
Location: Perth Western Australia
Photos: Gallery | Albums
Posts: 1,026
QuoteOriginally posted by sean Quote
If it wasn't for these forums, I doubt I'd have noticed this in real use.
There's a lesson here for me, I think.

Agree with you there mate..none of us know how crap our cameras are until we read it on a forum...I thought my K7 was the ducks nuts, until the forum told me otherwise..LMAO.

mind you if i got a K5 with the stains..id want to know why..
12-08-2010, 01:06 AM   #210
Site Supporter
bpjod's Avatar

Join Date: Apr 2009
Location: Wetaskiwin, Alberta
Posts: 82
Rats, I thought this issue was dreamed up by the conspiracy theorists. Then I tested mine. Large string of spots centrally that's this issue for sure. Many other spots that look more like dust. I'll have to take a closer look at my sensor but too tired to bother tonight.

S/N: 3820***; bought in Edmonton, Canada
Closed Thread

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, database, dslr, k-5, k-5 ii, k-5 iis, k5, k5d, pentax, pentax k-5, poll, sensor
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Some K-5s shipped with stains on the sensor/AA filter? Peter Fang Pentax K-5 292 03-06-2011 01:57 PM
% of k5 showing stains on sensor? stormcloud Pentax K-5 2 12-05-2010 08:41 PM
Full Frame Fisheye Zoom F and 43 Limited on K5D (Sample Photos) RiceHigh Pentax SLR Lens Discussion 7 10-09-2008 10:48 PM
Pentax K20D, K5D, or K1D (or both a K5D and a K1D)? stewart_photo Pentax News and Rumors 42 01-04-2008 02:45 AM
Sensor cleaning: Pec-Pads or Sensor Swabs gadgetnu Pentax Camera and Field Accessories 29 09-24-2007 10:52 AM



All times are GMT -7. The time now is 05:45 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top