Forgot Password
Pentax Camera Forums Home
 

View Poll Results: Is your K5d sensor stained?
YES - There are stains on my sensor 19356.43%
NO - My sensor has no stains 14943.57%
Voters: 342. You may not vote on this poll

Closed Thread
Show Printable Version Search this Thread
12-23-2010, 03:16 PM   #406
Veteran Member
ve2vfd's Avatar

Join Date: Aug 2007
Location: Montreal, Canada
Photos: Gallery
Posts: 2,433
Original Poster
QuoteOriginally posted by JayBee Quote
My first email via Pentaxcanada.ca's webform generated a reply from Pentax USA. This website International Service Network (America) : Support & Service : PENTAX lists the email address service@pentaxcanada.ca. That's the one that got me a reply from Mississauga.
Thats good to know! At least now I know that the Pentax Canada webform email app is flawed.

I'll resend (for the third time) my email at that address right now.

Thanks a million!

Pat

12-23-2010, 04:20 PM   #407
Senior Member
stormcloud's Avatar

Join Date: Oct 2009
Posts: 235
sadly have to report mine is stained too but thankfully only one very small one off to the very edge of the frame so dont think i'll send it back specially since its only visable at apertures i very rarely use
12-23-2010, 06:14 PM   #408
Veteran Member
falconeye's Avatar

Join Date: Jan 2008
Location: Munich, Alps, Germany
Photos: Gallery
Posts: 6,863
QuoteOriginally posted by 2form Quote
Falconeye, Could your analysis of AndyNick’s images possibly be the first confirmation of your earlier concerns “The most worrysome possibility is particles evaporating from a hot ceramic package (condensing on the inner side of the cover glass).”Falconeye - Advanced stainology…. or do you have another hypothesis as to how the string of pearls may have developed after the camera was shipped in AndyNicks case.
I don't think Andy's stains are at a different place than other string of pearl stains. Supposed to be IN the cover glass. A different mechanism wouldn't create the same pattern.

My #1 explaination is an error on our part. After all, physicists found a magnetic monopole and cold fusion. So, why not a dynamic string of pearls.

My #2 explaination would be a hidden glass defect becoming obvious only after mechanical tension. Where the mechanical stress is caused by the thermal expansion of the ceramic chip housing due to heat of operation.

As no other case was reported so far, I guess this is a very rare coincidence. I've put my K-5 into heat with 1h of continuous video and the stains didn't change.

QuoteOriginally posted by AndyNick Quote
will send off a message to them about this particular case.
Thanks.
12-24-2010, 10:41 AM   #409
Senior Member




Join Date: Feb 2010
Photos: Gallery
Posts: 175
Has anyone received a k-5 with the os upgrade installed from the factory that had the sensor stain issue or have all of these been 'clean'?

12-24-2010, 06:10 PM   #410
New Member




Join Date: Dec 2010
Photos: Gallery | Albums
Posts: 10
SN: 390XXXX No Stains

Last edited by Lumix; 12-27-2010 at 10:33 AM.
12-24-2010, 07:52 PM   #411
Veteran Member
ve2vfd's Avatar

Join Date: Aug 2007
Location: Montreal, Canada
Photos: Gallery
Posts: 2,433
Original Poster
QuoteOriginally posted by ve2vfd Quote
Thats good to know! At least now I know that the Pentax Canada webform email app is flawed.

I'll resend (for the third time) my email at that address right now.
Well, that was the problem! I got an answer from Pentax Canada service within 24 hours of emailing service@pentaxcanada.ca It's a relief to see the problem seems to be with their site's webform.

I'll be sending in my K5d after the holidays for an exchange.

They confirmed that they are looking into the webform-mail on their site.

Pat
12-24-2010, 08:26 PM   #412
New Member




Join Date: Jan 2010
Location: Philly
Posts: 8
QuoteOriginally posted by tram57 Quote
Has anyone received a k-5 with the os upgrade installed from the factory that had the sensor stain issue or have all of these been 'clean'?
I replaced my first K-5 with an obvious string of pearls and the new one came with the firmware update slip and a very stubborn single speck near the center of the frame. when i i view actual pixels, there might be a halo but i'm not positive. Haven't tried a wet clean but this speck was there right out of the box. (shrug)

Ian
12-25-2010, 01:28 PM   #413
Forum Member




Join Date: Jan 2008
Location: Evanston IL
Posts: 61
Stainless

K-5 arrived yesterday 12/24 from B&H. S/N 396XXXXX. No stains. A couple of very tiny dust motes (one in the upper left corner, one in the lower center right) visible at f22 but not at f8. The box carries a small white label with the S/N over a grey circle -- I read somewhere that cameras retested for stains would carry a label with a circle, but don't know if this is the one mentioned. Firmware version is 1.01.

12-25-2010, 04:35 PM   #414
Veteran Member




Join Date: Sep 2006
Location: Netherlands
Photos: Gallery
Posts: 908
is the poll closed?/

cannot seem to cast a vote anymore...
anyways, Hamid the deliveryguy was brave enough to deliver me my second K-5 of the socalled "checked batch" in snow and ice...
No3913415.....

oooh yes a string... again....
12-25-2010, 07:47 PM   #415
Senior Member




Join Date: Feb 2010
Photos: Gallery
Posts: 175
Well opened the beast from amazon. Sn390xxxx. No stains. A couple of isolated spots with dark center and halo at f32 but a couple of sensor cleans and a puff from the rocket with the mirror up removed these.

No stain.
12-26-2010, 03:20 AM   #416
Veteran Member
jolepp's Avatar

Join Date: Oct 2010
Location: Finland
Photos: Albums
Posts: 3,196
QuoteOriginally posted by janneman Quote
cannot seem to cast a vote anymore...
anyways, Hamid the deliveryguy was brave enough to deliver me my second K-5 of the socalled "checked batch" in snow and ice...
No3913415.....

oooh yes a string... again....
Stinketh :-(
12-26-2010, 06:12 AM   #417
Veteran Member




Join Date: Apr 2010
Location: Suomi , Finland
Posts: 373
Ei uusia Sony antureita seuraavaan Pentax malliin.
12-26-2010, 12:11 PM   #418
Forum Member




Join Date: Dec 2007
Location: Bulgaria
Photos: Gallery
Posts: 94
Today I went to the local photo-store. First checked the available K5 for stains and for AF on tungsten light.

The first one SN 38XXXXX had 1 stain. It was visible even on the camera's display preview.
The second and the last one SN 391XXXX was clear. It's mine already.
12-26-2010, 11:43 PM   #419
Veteran Member




Join Date: Apr 2010
Location: Suomi , Finland
Posts: 373
Jotain vikaa on silloinkin jos uudessa tai viikonvanhassa kamerassa näkyy pölyhiukkasiakin. Puhumattakaan tahroista, olisi kaikki kamerat vaihdettava ja sony kennot poistettava kokonaan.
Kaikki turhat selitykset pois ja asia korjattava.
12-27-2010, 07:08 AM   #420
Veteran Member




Join Date: Apr 2010
Location: Suomi , Finland
Posts: 373
Jo oli minullakin tahroja. Uusi mittaus paljasti kaiken. 300mm MF Ääretön F32 ISO 80 - 100 +1 EV
Harmaa taivas. Yksi selkeä piste ympärillä vaaleampi kekä, siaitsi vasen alareuna ja muutama vaaleempi läiskä yläpuolella lähellä keski viivaa. En tiedä näitten sensorien tekotapaa, mutta arvelisin kuivuneita nesteläiskiä? Eli huono hykieenia.
Closed Thread

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, database, dslr, k-5, k-5 ii, k-5 iis, k5, k5d, pentax, pentax k-5, poll, sensor
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Some K-5s shipped with stains on the sensor/AA filter? Peter Fang Pentax K-5 292 03-06-2011 01:57 PM
% of k5 showing stains on sensor? stormcloud Pentax K-5 2 12-05-2010 08:41 PM
Full Frame Fisheye Zoom F and 43 Limited on K5D (Sample Photos) RiceHigh Pentax SLR Lens Discussion 7 10-09-2008 10:48 PM
Pentax K20D, K5D, or K1D (or both a K5D and a K1D)? stewart_photo Pentax News and Rumors 42 01-04-2008 02:45 AM
Sensor cleaning: Pec-Pads or Sensor Swabs gadgetnu Pentax Camera and Field Accessories 29 09-24-2007 10:52 AM



All times are GMT -7. The time now is 09:36 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top