Forgot Password
Pentax Camera Forums Home
 

View Poll Results: Is your K5d sensor stained?
YES - There are stains on my sensor 19356.43%
NO - My sensor has no stains 14943.57%
Voters: 342. You may not vote on this poll

Closed Thread
Show Printable Version Search this Thread
01-02-2011, 10:29 AM   #466
New Member




Join Date: May 2010
Location: Niwot, Colorado, USA
Posts: 8
Got mine just before xmas from Amazon, no stains. sn3909021.

01-02-2011, 04:00 PM   #467
Senior Member
JayBee's Avatar

Join Date: Sep 2008
Location: Manitoba
Photos: Gallery
Posts: 119
QuoteOriginally posted by falconeye Quote
AndyNick has kindly asked my opinion on his case. I'll try my best

First and most interestingly, this is the first significant report I see that a string of pearls may develop in the field. If it can be confirmed, it puts the cover glass imperfection explaination at doubt. So, extra care must be applied in this case.

ATM, I'm not sure what I see. It looks like a string of pearls. But the individual stains seem to be a bit soft (no clear halo) for the typical stain we know, at f/22.

The slight shadow is nice as it does allow to compare the scale and position of the two crops. In itself of course, it is nothing.

I think we need some more tests.
Andy, can you shoot additional tests at f/11 16 22 32 and ideally a f/32 with a macro at closest distance. Maybe even a pinhole shot? I'd like to be sure w're not seeing a strange alien visiting the top of the AA filter

If it can be confirmed, Pentax should be made aware of this particular case.

There is theoretical chance of course, that the cover glass imperfection develops after mechanical tension due to heat. If this is the case, one should do the string of pearls test after a first video session until temperature warning. When I first searched and found MY stains, I already happened to use video this long. However, further tests did NOT agravate the issue anymore. So, I have one more question:

Andy, when you did the first photo w/o the new string, did you use video or LV for more than a few trials before?
I held off sending my K5 to Pentax until after Christmas. During the holidays, I noticed a new spot - much more noticeable that the original stain. Tried in-camera sensor cleaning and mirror-up blower, but it's stuck. Could be dirt, or could be a worsening of the sensor stain? I haven't used video mode, but I did make use of LV a few times. I wasn't going to put any more effort into cleaning since Pentax has given me the go-ahead to return it for replacement.
Attached Images
View Picture EXIF
PENTAX K-5  Photo 
01-02-2011, 04:58 PM   #468
Senior Member
jrforman's Avatar

Join Date: Mar 2008
Location: Minneapolis
Photos: Gallery | Albums
Posts: 202
Originally reported mine as clear. Need to revise that. Was checking for dust today, and noticed the stains. I have gone back to the original pictures I took when problem was first reported and they aren't there. Needless to say I am confused as to how they are now appearing. I got my camera in Mid September so it was one of the first. And yes, attempted to clean them. They wouldn't move....
01-02-2011, 10:16 PM   #469
New Member




Join Date: Dec 2010
Photos: Gallery | Albums
Posts: 10
Help I think I have a stain on my new K-5, is this a stain or just dust.
Iso400
250mm
F/16
1/500


Send it back I am not sure what to do

01-02-2011, 10:19 PM   #470
Banned




Join Date: Nov 2010
Location: Williston, VT
Posts: 268
QuoteOriginally posted by jrforman Quote
Originally reported mine as clear. Need to revise that. Was checking for dust today, and noticed the stains. I have gone back to the original pictures I took when problem was first reported and they aren't there. Needless to say I am confused as to how they are now appearing. I got my camera in Mid September so it was one of the first. And yes, attempted to clean them. They wouldn't move....
Same here, new stains are appearing. I initially thought I had some dust spots next to the stains, so I used a Rocket Blower to clean the sensor. When I checked again, not only were the "dust spots" still there in exactly the same places, but the string of pearls suddenly had some new dots.

I went back to the pictures I took on the very first day I received the K-5 back in November. There's a very convenient shot with tons of blue sky in it taken at F16. That picture is entirely blemish-free. I scrutinized it to be sure. Also, I've run the Dust Alert feature on the camera at least weekly. It never registered any spots initially. Now it registers the stains consistently.

It's entirely possible that some of those people who have reported stain-free sensors are in for a bad surprise down the road.

Last edited by Hound Tooth; 01-03-2011 at 01:21 AM.
01-02-2011, 11:01 PM   #471
Senior Member
raphtze's Avatar

Join Date: Dec 2010
Location: Oakland, CA
Posts: 136
QuoteOriginally posted by jolepp Quote
I got in touch with the seller who put me in contact with the company that does Pentax warranty repairs here: they advised to send/bring it in, they'll check it (and I'll get a replacement). It is a drag, but can't really ask for more at this point I suppose.
i plan on heading out to them soon as i get back to norcal. i had some luck with a sensor swab today. for shame, since the K-5 is really one heck of a great camera.
01-02-2011, 11:07 PM   #472
Senior Member
raphtze's Avatar

Join Date: Dec 2010
Location: Oakland, CA
Posts: 136
QuoteOriginally posted by Hound Tooth Quote
Same here, new stains are appearing. I initially thought I had some dust spots next to the stains, so I used a Rocket Blower to clean the sensor. When I checked again, not only were the "dust spots" still there in exactly the same places, but the string of pearls suddenly had some new dots.

I went back to the pictures I took on the very first day I received the K-5 back in November. There's a very convenient shot with tons of blue sky in it taken at F16. That picture is entirely blemish-free. I scrutinized it to be sure. Also, I've run the Dust Alert feature on the camera at least weekly. It never registered any spots initially. Now it registers the stains consistently.

It's entirely possible that some of those people who have reported stain-free sensors are in for a bad surprise down the road.
arghhh....this is really aggravating! i really wonder what's the root cause of this? well of course i couldn't send back my camera back....until after i get back from vacation. i did use it to take pics of my pals on NYE
01-03-2011, 12:53 AM   #473
Veteran Member
cbaytan's Avatar

Join Date: Nov 2008
Location: Trabzon/Turkey
Photos: Gallery
Posts: 1,010
QuoteOriginally posted by Lumix Quote
Help I think I have a stain on my new K-5, is this a stain or just dust.

Send it back I am not sure what to do
It's a dust for sure, just blow it away, don't forget it's on the counter side of your sensor.

01-03-2011, 01:35 AM   #474
Senior Member




Join Date: Mar 2010
Posts: 230
Sorry I don't have a K-5 for this poll, but I have two questions:

Has there been indications that is Sony's fault (them being the sensor manufacturer), and since the K-5 has the same sensor as the D7000, are there any reports of the same issue with the Nikon (or any Sony's for that matter)?

Sorry I don't have any knowledge about sensor manufacturing or if Pentax (or Nikon) adds something to Sony's finished product.
01-03-2011, 02:57 AM   #475
Inactive Account




Join Date: Mar 2009
Posts: 8
Same here, stain spot almost in the same location and size. S/N 3836752 bought in italy
01-03-2011, 05:23 AM   #476
New Member
Finrod's Avatar

Join Date: Jan 2011
Location: Berlin, Deutschland
Posts: 8
After cleaning

Hi there,

after extensive blowing the bulb in order to get rid of the dust, one spot stayed. In comparison to my first post, you can see that all the other spots are gone.

I think my K5 is stained, too.

Now I need your opinions. Is it a stain? If it is a stain, what should I do next? Go to the place, where I bought it or call Pentax Germany. I'm a bit lost by now.

In the first picture I marked it. The second is cropped.
Attached Images
   
01-03-2011, 05:36 AM   #477
Senior Member




Join Date: Aug 2010
Location: Brussels
Posts: 103
QuoteOriginally posted by ksm Quote
3919753 no stains
btw Pentax Belgium are checking each camera before sending to stores. Also I have able to check the camera myself before buying.
Where did you got this information ?
01-03-2011, 05:55 AM   #478
Veteran Member
jolepp's Avatar

Join Date: Oct 2010
Location: Finland
Photos: Albums
Posts: 3,196
@Finrod: The blower sure helped a lot there and the remaining spot seems more like dust than the typical sensor stain - those usually have a dark center and a halo because their location. You might retry the blower first; sometimes the dust just settles back on the sensor so it might take a more than one go. If that doesn't help, I'd try another cleaning method such as the Pentax O-ICK1 before getting touch with the seller or Pentax if only to avoid being parted with the camera for a while :-)
01-03-2011, 06:34 AM   #479
Veteran Member
cbaytan's Avatar

Join Date: Nov 2008
Location: Trabzon/Turkey
Photos: Gallery
Posts: 1,010
QuoteOriginally posted by Finrod Quote

Now I need your opinions. Is it a stain? If it is a stain, what should I do next? Go to the place, where I bought it or call Pentax Germany. I'm a bit lost by now.

In the first picture I marked it. The second is cropped.
I second jolepp, it is a dust, inevitable mistakes started to happen, "some" people might think dust spots are stain spots. Dust spots are easy to recognize, bigger, low contrast, chunky round shapes with generally lighter halo around it just like yours, not darker like stain. there are tons of dust samples on the forum.
01-03-2011, 07:15 AM   #480
New Member
Finrod's Avatar

Join Date: Jan 2011
Location: Berlin, Deutschland
Posts: 8
QuoteOriginally posted by cbaytan Quote
I second jolepp, it is a dust, inevitable mistakes started to happen, "some" people might think dust spots are stain spots. Dust spots are easy to recognize, bigger, low contrast, chunky round shapes with generally lighter halo around it just like yours, not darker like stain. there are tons of dust samples on the forum.
First of,

thanks you for answers. After blowing and blowing and so forth... I have some new friends on the sensor that I can't get rid of. The only good thing is. Those new ones just look like this one I thought would be a stain.

Fantastic, the blower blows dust on my sensor.
Closed Thread

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, database, dslr, k-5, k-5 ii, k-5 iis, k5, k5d, pentax, pentax k-5, poll, sensor
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Some K-5s shipped with stains on the sensor/AA filter? Peter Fang Pentax K-5 292 03-06-2011 01:57 PM
% of k5 showing stains on sensor? stormcloud Pentax K-5 2 12-05-2010 08:41 PM
Full Frame Fisheye Zoom F and 43 Limited on K5D (Sample Photos) RiceHigh Pentax SLR Lens Discussion 7 10-09-2008 10:48 PM
Pentax K20D, K5D, or K1D (or both a K5D and a K1D)? stewart_photo Pentax News and Rumors 42 01-04-2008 02:45 AM
Sensor cleaning: Pec-Pads or Sensor Swabs gadgetnu Pentax Camera and Field Accessories 29 09-24-2007 10:52 AM



All times are GMT -7. The time now is 07:28 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top