Forgot Password
Pentax Camera Forums Home
 

View Poll Results: Is your K5d sensor stained?
YES - There are stains on my sensor 19356.43%
NO - My sensor has no stains 14943.57%
Voters: 342. You may not vote on this poll

Closed Thread
Show Printable Version Search this Thread
12-06-2010, 03:23 PM   #61
Veteran Member
MrPetkus's Avatar

Join Date: Feb 2010
Location: Long Island, NY
Posts: 388
QuoteOriginally posted by falconeye Quote
What is different with my K-5 (and the other images I see) is that there is a string of particles (in the upper left quadrant) which other cameras probably don't have. cf. image where I marked the stain positions in red.
That's what I've noticed with mine. A string of particles running horizontally near the center like so ........

12-06-2010, 03:57 PM   #62
Veteran Member




Join Date: Sep 2006
Location: Netherlands
Photos: Gallery
Posts: 908
QuoteOriginally posted by blende8 Quote
One mini spot 10 x 10 pixels. Unremovable with Isoprop.
I do not consider this a problem.
But it is, it is four times larger than the K-5 shutter blur. 3 times that of K-7
12-06-2010, 04:18 PM   #63
Veteran Member




Join Date: Sep 2006
Location: Netherlands
Photos: Gallery
Posts: 908
here we go again

382xxxx - yes
3820670 - no
3820688 - yes
3820888 - yes
38226xx - yes
3822724 - yes
3822871 - yes
3823812 - no
3823850 - no
3823862 - no
3823875 - yes
3823936 - no
3823993 - yes
3825xxx - yes
3827069 - yes
3828xxx - no
3830xxx - yes
3836407 - no
3839502 - yes
3842*** - yes
3842409 - yes
3842568 - yes
3849.. - yes
3849889 - no
3850... - yes ( a dot is a yes Blende)
3850011 - yes
3850025 - yes
38506xx - yes
3851607 - yes
3858324 - yes
3877*** - no
3889... - no
3889359 - yes
3890099 - yes
3894*** - no
3894706 - no
3900xxx. - no
(updated..... )
12-06-2010, 04:43 PM   #64
Veteran Member




Join Date: Jan 2007
Location: New Mexico
Photos: Albums
Posts: 1,125
How about testing some other cameras?

QuoteOriginally posted by jhnpennington Quote
Yes, but my point is that there are not many people showing that.
I very much suspect that a lot of the people voting YES simply have normal sensor dust

This is certainly a possibility, which raises an interesting question: If everyone tested their other cameras in the same way as they are now testing their K-5s, how many would find similar artifacts? The answer might be surprisingly high. I am not saying that there is not a genuine "stain" problem with some K-5s, but the actual prevalence may be far less than we are led to believe by threads such as this one.

Rob

12-06-2010, 04:50 PM   #65
Pentaxian




Join Date: Dec 2009
Location: Sydney, Australia
Photos: Gallery
Posts: 1,612
Mine got one spot, serial 3851xxx

Bought it from Paxton's Sydney
12-06-2010, 04:51 PM   #66
Veteran Member
David's Avatar

Join Date: Jul 2007
Location: Sandy Bay, Tasmania, Australia
Photos: Albums
Posts: 344
I originally voted no, then with some additional pixel peeping the answer is definitely yes. Posted a sample image but it seems to be lost in Adam Land.

Serial No. is 3842407
12-06-2010, 04:58 PM   #67
Veteran Member




Join Date: Dec 2010
Location: Frog-eaters country
Photos: Gallery
Posts: 359
It often looks like a splash on pics posted. Is is possible than it's a transparent liquid on the top of the sensor, or maybe between the AA & glasses layers. Could the liquid, be "cooked" by the heat of the sensor, then turn harsh and opaque ?
12-06-2010, 05:01 PM   #68
Senior Member
Rick Clark's Avatar

Join Date: Nov 2010
Location: Provo, Utah
Posts: 128
Yes mine was stained in one spot at 7:O'Clock could not see untill f22 or higher.

12-06-2010, 05:20 PM   #69
Veteran Member
ve2vfd's Avatar

Join Date: Aug 2007
Location: Montreal, Canada
Photos: Gallery
Posts: 2,433
Original Poster
QuoteOriginally posted by jhnpennington Quote
I very much suspect that a lot of the people voting YES simply have normal sensor dust
Sorry, but we're not all newbs...

I can confirm like many others that the so called "dust" doesn't go away after a wet cleaning. If you check out the threads I quoted in the original post you'll see that some people have even had their sensor professionally cleaned to no avail.

Besides dust most often looks like dark spots whereas these stains look like clusters or strings of "cells".

I'm also surprised by the high numbers, but not THAT surprised...

Pat
12-06-2010, 05:22 PM   #70
Veteran Member
fccwpe's Avatar

Join Date: Mar 2009
Location: Perris, CA
Photos: Gallery
Posts: 380
No visible spots at f11 and ISO 160. Serial 385**** bought from Amazon last week.
12-06-2010, 05:25 PM   #71
Col
Veteran Member
Col's Avatar

Join Date: Apr 2007
Location: Stansted Essex
Photos: Gallery
Posts: 615
QuoteOriginally posted by MrPetkus Quote
That's what I've noticed with mine. A string of particles running horizontally near the center like so ........
QuoteOriginally posted by allantois Quote
Mine has a small row of marks similar to others which show up at high f values. There is a blemish on the sensor which is visible to the naked eye.
Obviously my concerns are that it might get worse and that if I wanted to sell it in a year or so the used value would be badly dented.

Serial number 38226xx

I bought it at the end of October from SRS Microsystems in UK They are a pentax dealer. I 'phoned today and they are waiting from a response from Japan. It seems that the problem has been acknowledged as a 'known issue' and they are waiting for intructions whether to replace or repair.

Very glad I bought from SRS. It is clear that customer satisfaction is very important to them.

Allan
My camera is showing a similar pattern, first UK batch s/n: 3820665
Also bought from SRS so I would appreciate being kept up to date as to the SRS position Allan.

Stretches about 1/5th of the sensor's width. Oh and I've not used movie mode.

Last edited by Col; 12-06-2010 at 05:44 PM.
12-06-2010, 05:34 PM   #72
Veteran Member
dgaies's Avatar

Join Date: Oct 2009
Location: Maryland / Washington DC
Posts: 3,917
It certainly appears that there are two distinct types of stains. 1) the long string of (typically) horizontal dots and 2) the single or small grouping of darker circles with a lighter outer ring (the ones that almost look like biological cells). I wonder if they are from the same contamination-source or if it's possible there were actually two different types of contamination.
12-06-2010, 05:58 PM   #73
Inactive Account




Join Date: May 2008
Location: New Jersey, USA
Posts: 94
I have spent last 3 days to see whether any stains or dust on my K-5 sensor. After taking more than 25 shots (mostly at F22) with two lenses (43mm and 31mm), I found NO stains on my K-5 sensor. My serial number is 3823791. I bought the camera from my ever reliable local store (ABES OF MAINE - I live in Edison, NJ)

-iunknown
12-06-2010, 06:08 PM   #74
Inactive Account




Join Date: Dec 2010
Posts: 6
Same problem here. I bought it at Adorama a couple of weeks ago and didn't notice anything.

I read that it could be noticeable at f/22 and, after trying it, I found a long string of dots just at the centre which is fairly visible from f/18 to f/22, and noticeable at f/14 but easily corrected on PP. I found another parallel line of dots just below this one, but it is almost unnoticeable even at f/20. I never use these apertures in real life, but as you might understand and don't feel exactly happy with them in a newly acquired 1,500$ camera.

I am looking forward to listening to Pentax on this issue. I am leaving the country next week (USA to Spain) for 4 months, so returning it to Adorama doesn't seem reasonable to me. ┐Does anyone know if the warranty is applicable overseas? ┐Has anyone experienced a similar situation to mine with International Warranty?

By the way, my serial number is: 3824126
12-06-2010, 06:09 PM   #75
Senior Member




Join Date: Sep 2009
Posts: 200
This is such a BS. Sorry guys.
First, all the sensors of all the existing cameras have stains/dust/whatever.
The highest used f stop is usually f11, nothing seen there.
And most of all, please show me those amazing photos affected by that colossal
issue because all I can see right now here is complains and BS, no pictures
what so ever. If your photography is so amazing and your absolutely perfect photos
suffer because of a few darker spots seen only at f22, please show us all
those great pictures, we'd love to see them.
Closed Thread

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, database, dslr, k-5, k-5 ii, k-5 iis, k5, k5d, pentax, pentax k-5, poll, sensor
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Some K-5s shipped with stains on the sensor/AA filter? Peter Fang Pentax K-5 292 03-06-2011 01:57 PM
% of k5 showing stains on sensor? stormcloud Pentax K-5 2 12-05-2010 08:41 PM
Full Frame Fisheye Zoom F and 43 Limited on K5D (Sample Photos) RiceHigh Pentax SLR Lens Discussion 7 10-09-2008 10:48 PM
Pentax K20D, K5D, or K1D (or both a K5D and a K1D)? stewart_photo Pentax News and Rumors 42 01-04-2008 02:45 AM
Sensor cleaning: Pec-Pads or Sensor Swabs gadgetnu Pentax Camera and Field Accessories 29 09-24-2007 10:52 AM



All times are GMT -7. The time now is 04:09 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top