Forgot Password
Pentax Camera Forums Home
 

View Poll Results: Is your K5d sensor stained?
YES - There are stains on my sensor 19356.43%
NO - My sensor has no stains 14943.57%
Voters: 342. You may not vote on this poll

Closed Thread
Show Printable Version Search this Thread
12-06-2010, 07:37 PM   #91
Site Supporter
jamesk8752's Avatar

Join Date: Dec 2006
Location: Suburban Detroit, MI, USA
Posts: 226
No problem here...

My K-5, s/n 390071x, purchased from Amazon on Black Friday, has no sign of this defect. During my testing I did find one little dust bunny which my Rocket blower disposed of very neatly.

Regards, Jim

12-06-2010, 07:54 PM   #92
Senior Member




Join Date: Sep 2009
Posts: 200
QuoteOriginally posted by dadipentak Quote
Well, I did post photos in the "no more tests" thread ...

Great! Look, since my post, there's been around 50 posts about the so called stains
and not a single picture posted...
That looks to me like a case of paranoia.
12-06-2010, 07:58 PM   #93
m8o
Veteran Member
m8o's Avatar

Join Date: Jul 2007
Location: 40-55'-44" N / 73-24'-07" W [on LI]
Photos: Gallery | Albums
Posts: 3,102
QuoteOriginally posted by andi Quote
Great! Look, since my post, there's been around 50 posts about the so called stains and not a single picture posted...
That looks to me like a case of paranoia.
What are you on? ...you conveniently ignore my link because it doesn't fit your narrative?
12-06-2010, 08:00 PM   #94
Senior Member
Trig's Avatar

Join Date: Aug 2009
Location: Acushnet, MA
Photos: Gallery
Posts: 211
I tested mine. Started to panic when I saw 2 specks. Did a cleaning with a rocket blower and it was just dust. It sure looked like the single dots people are reporting here. It did not look like the "strings".

I have NO stains on my K-5's Sensor.

My K-5 Serial Number: 3836XXX purchased here is the US from B&H

Question: Do these "stains" show up on a "dust alert"?


Last edited by Trig; 12-08-2010 at 01:34 PM.
12-06-2010, 08:00 PM   #95
Veteran Member
ve2vfd's Avatar

Join Date: Aug 2007
Location: Montreal, Canada
Photos: Gallery
Posts: 2,433
Original Poster
QuoteOriginally posted by andi Quote
Great! Look, since my post, there's been around 50 posts about the so called stains
and not a single picture posted...
That looks to me like a case of paranoia.
Edited what I initially wrote... it was juvenile and I apologize...

Look Andi, as I mentioned in the initial post this thread is for reporting defective (and non defective) K5d's, NOT for discussion, opinions and arguing.

If you want to start an argument then please START YOUR OWN THREAD.

Pat

Last edited by ve2vfd; 12-06-2010 at 08:14 PM.
12-06-2010, 08:00 PM   #96
Veteran Member




Join Date: Aug 2009
Location: NY
Posts: 407
Well my replacement camera is on it's way, should be here Thursday or Friday. First thing I will do is shoot at F32 using the same lens and distance I did for the tests that Falk worked on. I will let you know how I get on.

If I get another one with the spots I will send it back and keep sending faulty units back until I get one without this defect. My wife's K5 does not have these spots so it is possible to get a decent one.

I shoot Macro, often at F16-F32 for DOF. I cannot accept a camera with splodges most right in the center of the field of view.
12-06-2010, 08:01 PM   #97
Veteran Member
dgaies's Avatar

Join Date: Oct 2009
Location: Maryland / Washington DC
Posts: 3,917
QuoteOriginally posted by andi Quote
Great! Look, since my post, there's been around 50 posts about the so called stains
and not a single picture posted...
That looks to me like a case of paranoia.
I hate to say this, as I really enjoy the photos you've posted in other threads and think you're a very talented photographer, but at the moment you're coming off as a bit of a jerk. Whether or not this issue would bother you if it was present on your sensor is hardly the point of this thread. And to call the issue BS and/or a case of paranoia is somewhat disrespectful, IMO, to the people who feel there is an issue.
12-06-2010, 08:22 PM   #98
Senior Member
Itai's Avatar

Join Date: Sep 2009
Location: Montreal
Photos: Gallery
Posts: 211
No stains on my sensor but some on my mirror, luckily those were easy to clean.

Think Pentax forgot to put a sign saying "Employees must wash hands"

- Itai

12-06-2010, 08:45 PM   #99
Veteran Member
MrPetkus's Avatar

Join Date: Feb 2010
Location: Long Island, NY
Posts: 388
I posted earlier but didn't post my handsome string of pearls.

Last edited by MrPetkus; 04-17-2012 at 08:49 PM.
12-06-2010, 08:54 PM   #100
Site Supporter




Join Date: Oct 2009
Location: North
Photos: Gallery
Posts: 3,779
Stains/dust/indents could come from anything in the assembly process (ie. sensor pickup tool that was not clean; process that involves wiping; maybe lint free cloth used was not clean; operator #3361xxx not following assembly procedures; etc).
Good to alert Pentax to the real problem and they should scrutinize the assembly process to get it corrected.

Personally, having looked though enough scopes and failure analysis for my day job, I'd have to say that nothing looks 'clean' under high enough magnification, so expectations have to be realistic.
For me f8, f11 (for my usage) and nothing shows up, its considered. Ok. YMMV of course

Almost the same case with the hot pixel issue for the D7K. Some ppl are testing with lens cap on, ISO1600 or higher and shutter speeds under 1s. Expecting that the higher sensitivity and bias currents to not show up anything, under non-usage conditions, which blows the problem out of proportion.


my few cents.
12-06-2010, 09:04 PM   #101
Site Supporter




Join Date: Mar 2008
Location: Prince George, BC
Photos: Gallery
Posts: 2,255
Clean, s/n 3823965.
12-06-2010, 09:15 PM   #102
Inactive Account




Join Date: Dec 2010
Posts: 4
Sadly I see the spots too.

S/N:3849420
Bought in Canada.
12-06-2010, 10:09 PM   #103
Inactive Account




Join Date: Sep 2006
Location: Lone Tree, Colorado, USA
Posts: 77
3836xxx stained and on it's way back to B&H Photo.
12-06-2010, 10:10 PM   #104
Pentaxian




Join Date: Mar 2009
Location: Perth Australia
Photos: Albums
Posts: 1,511
I was about to order one from an over seas online retailer and i asked them to check my camera for stains before shipping it to save postage in the event they found stains, and they found them Its the last one anywhere till new batches arrive next year.

QuoteOriginally posted by Itai Quote
Think Pentax forgot to put a sign saying "Employees must wash hands"
Ahh, so its urine? This does not make things better....
12-06-2010, 10:12 PM   #105
Senior Member




Join Date: May 2010
Location: WA, Australia
Posts: 164
Gee... there's a fair ratio of stained:unstained k5's out there...
Closed Thread

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, database, dslr, k-5, k-5 ii, k-5 iis, k5, k5d, pentax, pentax k-5, poll, sensor
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Some K-5s shipped with stains on the sensor/AA filter? Peter Fang Pentax K-5 292 03-06-2011 01:57 PM
% of k5 showing stains on sensor? stormcloud Pentax K-5 2 12-05-2010 08:41 PM
Full Frame Fisheye Zoom F and 43 Limited on K5D (Sample Photos) RiceHigh Pentax SLR Lens Discussion 7 10-09-2008 10:48 PM
Pentax K20D, K5D, or K1D (or both a K5D and a K1D)? stewart_photo Pentax News and Rumors 42 01-04-2008 02:45 AM
Sensor cleaning: Pec-Pads or Sensor Swabs gadgetnu Pentax Camera and Field Accessories 29 09-24-2007 10:52 AM



All times are GMT -7. The time now is 06:59 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top