Forgot Password
Pentax Camera Forums Home
 

Closed Thread
Show Printable Version Search this Thread
01-18-2011, 08:46 AM   #136
Veteran Member




Join Date: Jan 2009
Location: London
Posts: 469
Don't be silly. I am happy with my camera. I am trying to assist others here in identifying whether all K5s have this issue or not. If they all have it, it could be a firmware fix, otherwise it won't be, obviously.

01-18-2011, 08:54 AM   #137
Senior Member
Serpiente's Avatar

Join Date: Jul 2008
Posts: 154
Strange problem.. I can get focus with my K10d+DA* 300 in low light..
01-18-2011, 09:06 AM   #138
Veteran Member




Join Date: Jul 2008
Location: Var, South of France
Photos: Albums
Posts: 1,071
Well, guys (and gals!) time to return to your bench tests : Pentax has issued a silent firmware update for the K5, the v1.02.21.10... (official one was v1.02.21.07)

Quick tests seems to show no more FF in low light, just before the AF lamp kicks in... On the other hand, I'm stuck in my bed after a surgical operation, so doing advanced tests is quite hard!!!
01-18-2011, 09:34 AM   #139
Veteran Member
blende8's Avatar

Join Date: Feb 2007
Location: Bremen, Germany
Photos: Albums
Posts: 1,484
I doubt very much that they would do this in a "silent" one.
I have been told by Pentax that this silent one was about some bug:
SDM+Liveview+internal flash didn't work. Now it should work, haven't tested though.

01-18-2011, 09:57 AM   #140
Veteran Member




Join Date: Jul 2008
Location: Var, South of France
Photos: Albums
Posts: 1,071
Well, at least, they made more than one change... There is an increment of 3 on the internal version digit (from .07 to .10), so I guess they made several changes.

We will never know...
01-18-2011, 10:00 AM   #141
Senior Member
Spag's Avatar

Join Date: Oct 2008
Location: Berlin
Photos: Gallery | Albums
Posts: 121
QuoteOriginally posted by blende8 Quote
I doubt very much that they would do this in a "silent" one.
I have been told by Pentax that this silent one was about some bug:
SDM+Liveview+internal flash didn't work. Now it should work, haven't tested though.
I just tested it, and the bug is now gone on my K-5.
01-18-2011, 01:21 PM   #142
Veteran Member
Tommot1965's Avatar

Join Date: Sep 2010
Location: Perth Western Australia
Photos: Gallery | Albums
Posts: 1,026
QuoteOriginally posted by peterh337 Quote
I have two lenses now (16-45 and 17-70) but both are F4.

I have done shots to test the focus (outdoors, good light) and cannot see an issue.

If someone can suggest a test scenario I would happily have a go. A while ago I posted a couple of files here (ignore the patent one) which show that there is nothing apparently wrong with the focus under those conditions. Those pics were taken with the 38... "spotted sensor" K5; I now have a new one with a clean sensor.


Peter

you will need to set up on a tripod, make sure the light source is around 4EV..and focus on the subject at 500 mm from the focal plane ...this will give a DOF of 20mm at a FL of 45mm F4

EV 4 @ F4 X100 ISO = 1 sec shutter speed
EV 3 @ F4 x 100 ISO = 2 sec shutter speed
01-18-2011, 03:17 PM   #143
Veteran Member




Join Date: Jan 2009
Location: London
Posts: 469
OK, I have put several pics here.

The lens is my new (secondhand) 17-70 Pentax.

All pics were taken at 70mm as this has the shallowest depth of focus.

The first and fifth were taken with flash, X mode, F8 and F4, to show focus in good light.

The ones in between were done at F4, 1sec 2 secs 4 secs, M mode, with the ambient light set to show 0.0 on the exposure indicator.

The focus assist beam came on on the 4 sec pic.

I defocused the camera before each pic.

Anyway, you can see the EXIF data.

Can anyone see a problem? Certainly the F8 flash pic is sharper than the F4 flash pic It was probably focused in good light. All the other pics are less sharp than the F8 flash pic.

P.S. the very last pic is another low light one and was taken at F8 1sec no flash, to see if there is indeed a focus problem. That one is sharper than the F4 low light pics, which does suggest the camera has a problem focusing accurately at these very low light levels.

What I can't say is whether this performance is to be expected, or is substandard. 1 sec shutter is very low light although to be fair one would not be shooting at 100 ISO then... A bigger problem is probably a focus issue on pics where flash will be used.

I am not sure what to make of it. I took other pics afterwards and all F4 pics are less sharp than F5.6 or F8, regardless of the ambient light during focusing. Could the ex-Ebay 17-70 lens be faulty? I redid the two flash pics (F4 and F8) with my old 16-45 lens, on the 45 setting, and they are of comparable sharpness.


Last edited by peterh337; 01-18-2011 at 03:35 PM.
01-18-2011, 04:36 PM   #144
Veteran Member
filorp's Avatar

Join Date: Jun 2008
Location: Aberdeen Scotland
Photos: Gallery | Albums
Posts: 389
QuoteOriginally posted by Wheatfield Quote
I see we have another convert to the "I must find something wrong with my camera" club.

I'd tell you to enjoy your camera, but now you will never be able to enjoy either your camera or photography again.
You know Wheatfield it remindes me about my k10d. I was enjoying with shooting until i decided to do something more it turned out that my friends with canicon had sharper pictures maybe better maybe worse but sharper, it turned out that i have massive back or front focus (i didnt even knew something like this existed) conclusion is: better to find out the issue before it start to be annoying.... or before your warrenty expires....
01-19-2011, 02:14 AM   #145
Veteran Member




Join Date: Jan 2009
Location: Budapest
Posts: 821
QuoteOriginally posted by Tommot1965 Quote
you really need a F2.8 lenses or quicker
What's you theory on my K-5 working fine with f/2.8 and f/1.4 lenses down to EV2-3?
01-19-2011, 02:41 AM   #146
Veteran Member
Tommot1965's Avatar

Join Date: Sep 2010
Location: Perth Western Australia
Photos: Gallery | Albums
Posts: 1,026
QuoteOriginally posted by simico Quote
What's you theory on my K-5 working fine with f/2.8 and f/1.4 lenses down to EV2-3?

not too sure, unless your are not limiting your DOF enough by focusing to far away from the subject,

my k5 will show FF at EV4 if i limit the DOF to around 40mm, any more than that and I dont see it.

I take it you have tested it within the recommended test parameters ?

eg

at F2.8 no more that 1 metre away from the subject @ 50mm F2.8 shutter @ 1sec ISO 100
01-19-2011, 03:23 AM   #147
Pentaxian




Join Date: Mar 2009
Location: Perth Australia
Photos: Albums
Posts: 1,511
QuoteOriginally posted by dlacouture Quote
silent firmware update for the K5, the v1.02.21.10... (official one was v1.02.21.07)
how the hell does a silent firmware update help anyone... retarded.
01-19-2011, 03:38 AM   #148
Veteran Member




Join Date: Jul 2008
Location: Var, South of France
Photos: Albums
Posts: 1,071
QuoteOriginally posted by WerTicus Quote
how the hell does a silent firmware update help anyone... retarded.
Sorry? Is that intended as an insult?

FYI, Pentax has an history of solving important bugs in hidden updates to their firmware... The infamous green lines that were plaguing the K20 suddenly disappeared this way. Nothing is announced on their website, the firmware seems to be the same version (down to the same date!), but they updated it to include further modifications... Only thing changing is the small 4th digit in the version.
01-19-2011, 03:48 AM   #149
Veteran Member




Join Date: Jan 2009
Location: London
Posts: 469
Every manufacturer does covert bug fixes.

I am a pilot and have seen a variety of safety-critical bugs fixed covertly, under the guise of a routine update which claims to fix some innocuous issues. This benefits the manufacturer several ways: avoids corporate image damage (in fact it improves it), avoids liability for the real bug causing some real trouble, enables the fixing of bugs which nobody has yet reported, avoids having to re-certify the product (that's a major one) especially under duress.

In this case, it is highly desirable to find issues ASAP because not only the warranty is only 12 months but also under the consumer laws there may be only a 30-day or a 6-month period during which a defect is presumed to be inherent, and if it is reported after that cutoff date then you cannot get a refund or a replacement; all you can do is a warranty repair and you have to wait for it to come back.

Pentax is a good company but not every retailer is upright and some will screw you around.

Back to my tests, I wonder if anybody has actually looked at the images I posted. I could not replicate the lack of focus at F4 (versus F8) with my 16-45 and I am returning the 17-70 to the seller. I am happy to have another go with the 16-45 in low light, if anybody cares
01-19-2011, 04:22 AM   #150
Pentaxian




Join Date: Mar 2009
Location: Perth Australia
Photos: Albums
Posts: 1,511
QuoteOriginally posted by dlacouture Quote
Sorry? Is that intended as an insult?

An insult to a corporation?
Closed Thread

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, issue, k-5, k-5 ii, k-5 iis, k5, pentax k-5, re, thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! K7 malfunctioning samski_1 Pentax DSLR Discussion 9 07-11-2010 03:24 PM
Probably not relevant or welcome here climbertrev Non-Pentax Cameras: Canon, Nikon, etc. 4 05-24-2010 05:15 AM
camera based sensorcleaning how relevant is it. hein Pentax DSLR Discussion 13 09-13-2009 12:26 PM
Light fluff but news.. sort of jeffkrol Pentax News and Rumors 8 12-30-2008 06:30 PM
Snowflakes... ( artificial ) TrailSeeker Post Your Photos! 0 12-12-2006 08:33 AM



All times are GMT -7. The time now is 06:22 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top