Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-08-2011, 12:04 PM   #151
Veteran Member
vievetrick's Avatar

Join Date: Sep 2006
Location: Easthampton - Massachusetts - USA
Photos: Gallery
Posts: 5,175
Original Poster
QuoteOriginally posted by jrforman Quote
Remember that if you sneak into the bathroom stall to test your camera for sensor stains, and you get caught doing it, it will be real hard to explain.
lol

02-08-2011, 03:46 PM   #152
Veteran Member
Tommot1965's Avatar

Join Date: Sep 2010
Location: Perth Western Australia
Photos: Gallery | Albums
Posts: 1,026
QuoteOriginally posted by Tom S. Quote
Apparently you missed his post. Wheatfield has left the forum (and I for one am sorry he did). So I guess you're free to run amok.
where was that posted..?

while I didnt always agree with Wheatfield. his information was always worthwhile, I appreciated his candour and common sense. sometimes delivered with a sledge hammer I know ....but non the less mostly correct
02-08-2011, 04:13 PM   #153
Veteran Member
jthommo's Avatar

Join Date: Sep 2006
Location: Canberra, Australia
Photos: Gallery
Posts: 339
QuoteOriginally posted by Tom S. Quote
Apparently you missed his post. Wheatfield has left the forum (and I for one am sorry he did). So I guess you're free to run amok.
That's a shame. A useful member of the community run out of town. I great pity.
02-08-2011, 04:14 PM   #154
Veteran Member
alexeyga's Avatar

Join Date: Dec 2008
Location: Montreal, Canada
Posts: 838
Picked up mine from Simon's Today... When i've got the call, the information that I was given is that the camera was "cleaned and checked"... However, when i've opened the box and got the camera body out, there was a note from Pentax saying that due to the nature of the problem, my camera was replaced.

The replacement is a brand new unit, serial number 3842xxx... came with the 1.02 firmware... the original one was 3881xxx... (got it with the 1.01 fw) go figure...

That being said, so far so good... sensor seems clean, AF looks on the money... Gonna get it a good workout during the next few days to make sure everything works as it should...

What a sense of relief that is... Gonna pick up the 18-135 later this week as well...


Last edited by alexeyga; 02-08-2011 at 05:17 PM.
02-08-2011, 04:54 PM   #155
Veteran Member
vievetrick's Avatar

Join Date: Sep 2006
Location: Easthampton - Massachusetts - USA
Photos: Gallery
Posts: 5,175
Original Poster
Ok the K5 is back. Here is one of those strange un-boxing type posts. I thought it would be relative since sounds like others around have had UPS / shipping issues. (all attached photos taken with iPhone 3gs)

UPS BOX clean no issues



Inside was regular shipping peanuts and complete box, there was the packaging type thing with my WO # and a few circles colored stickers. Not sure what that's about.



Inside the Pentax box was a copy of all the emails included that I sent them.



A full box with all the things you would get if bought at the store.



The odd thing, but I am sure really nothing, the little thing that holds the straps was not attached in the first model I received but are on this one.



Last not least it included v1.01



Seems to focus much better with 50 FA1.4 in low light. Also when I would take a shot with the first model it seemed to take 3-4 seconds to show a review. Now seems like right away.

I will post more as I play more over the next few days.

So for the record from Western Mass to Arizona it was 26 days from UPS office back to my office

New serial number is 3982XXX batch - (why should I be worried about posting entire number?)

Last edited by vievetrick; 02-08-2011 at 05:07 PM.
02-08-2011, 04:58 PM   #156
Senior Member
raphtze's Avatar

Join Date: Dec 2010
Location: Oakland, CA
Posts: 136
wow you have your camera back good luck and happy shooting !!!

-raph
02-08-2011, 06:23 PM   #157
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
Show off!

Great to see one go right. Maybe they're in the swing of things now and have the process down to a science. Then again, maybe not.

Enjoy the new (again) camera.

02-08-2011, 06:30 PM   #158
Veteran Member
ve2vfd's Avatar

Join Date: Aug 2007
Location: Montreal, Canada
Photos: Gallery
Posts: 2,433
QuoteOriginally posted by bobmaxja Quote
Look like they repair it. First time we see it
Hard to tell if it's a repaired unit. It looks brand new... but with the sensor so dirty I don't know what to think.

QuoteOriginally posted by vievetrick Quote
it really sounds like Pentax Canada is not doing it's part to keep the customers happy
You are right, I'm glad I have a working and seemingly clean K5d but the whole experience with Pentax Canada left a very bad taste in my mouth.

QuoteOriginally posted by Tommot1965 Quote
it would have been nice if you had received a full retail Kit....Pentax Canada don't sound like they have a clue...did you ring them about the dirty sensor
I agree, I think a full retail kit like Pentax-USA, or a warranty extension of a few years or something would have been a nice gesture for the trouble we were put thru. As for the dirty sensor I'll be sending registered mail to the Service director with a CC to the VP Marketing).

QuoteOriginally posted by RBellavance Quote
If my calculations are correct, 2010-12-23 is during week 51, so hopefully you'll be ok
Yup, if that cut-off date was right then I should be ok... but I agree that the early serial number seems very odd!!!

QuoteOriginally posted by jthommo Quote
tell, how do you know?
LOL! A guess

QuoteOriginally posted by alexeyga Quote
Pat, I think we're being too tolerant...
We are, which is why I'm going to be writing to some folks at Pentax Canada to let them know I am not very happy with the way they handled this. Nothing much else we can do about it...

QuoteOriginally posted by JayBee Quote
That's what I did not want to hear! They did a sensor replacement
I have my doubts that it may be the case, but I checked it carefully and none of the screws have screwdriver marks and it shows no marks of normal use (like the flash shoe has no tiny scratches from a flash being inserted...) I'm just not quite sure what to think.

QuoteOriginally posted by Tom S. Quote
Pat, that is just plain wrong on the part of Pentax! If the US is replacing them, Canada (and everywhere else) should be too. If I were you, I'd be inclined to contact them and ask what the heck was going on.
I am in full agreement and do intend on sending the powers that be at Pentax Canada a nicely worded letter asking them WTF? as politely as I can. The 1:1 replacement without any smoothing of ruffled feathers I can accept - though I don't like it - but having to clean the sensor... thats unacceptable.

QuoteOriginally posted by Parallax Quote
It worries me a little that you are that familiar with Calcutta brothels.
LOL! I watch a lot of documentaries on Current-TV and VBS.tv

QuoteOriginally posted by vievetrick Quote
My NEW in box with all the bells and whistles is here in the office
Awesome!!! I'm glad for ya and hope you'll enjoy your re-new toy!

QuoteOriginally posted by alexeyga Quote
The replacement is a brand new unit, serial number 3842xxx... came with the 1.02 firmware... the original one was 3881xxx... (got it with the 1.01 fw) go figure...

That being said, so far so good... sensor seems clean, AF looks on the money... Gonna get it a good workout during the next few days to make sure everything works as it should...
Great! Looks like you also have a strange serial number, but hey at least this unpleasantness is over! Have fun with your camera!

I'm on night shifts at work so I have very little time to play with my camera until the end of the week, but I still went for a quick drive by the river to try out my K5d with my new DA*60-250 and DA*16-50. One word.... WOW!

Pat

02-08-2011, 06:31 PM   #159
Loyal Site Supporter




Join Date: Jun 2007
Location: Lehigh Valley, PA
Photos: Gallery
Posts: 512
QuoteOriginally posted by JeffJS Quote
Show off!

Great to see one go right. Maybe they're in the swing of things now and have the process down to a science. Then again, maybe not.

Enjoy the new (again) camera.


I hope so...I dropped mine off at UPS last Tues...tracking says delivered at CRIS today. Hopefully it's a quick turnaround....
02-08-2011, 06:59 PM   #160
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
QuoteOriginally posted by jgmankos Quote
I hope so...I dropped mine off at UPS last Tues...tracking says delivered at CRIS today. Hopefully it's a quick turnaround....
Yours is probably in the same lot as mine. Send CRIS an email through their contact page to get your ball rolling. I don't know how, and didn't give them the chance, on the ball they are with making first contact. They say it takes 24 hours to put it into the system.

02-09-2011, 08:32 AM   #161
Veteran Member




Join Date: Dec 2008
Location: Paris, France
Photos: Gallery
Posts: 337
I got a new K-5 through my reseller today (sent to Pentax France, and a new has been sent back for me). As you can guess, as soon as I was back home I did a quick test. Guess what ?



The serial is 3959xxx so you would think it is not from the affected batch, but the EXIF show a "Manufacture Date" of 2010:12:04, which is saturday on week 48 and if I remember correctly cameras manufactured until week 49 are affected.
As it's a new camera sent by Pentax's official repair shop, it's supposed to be a thoroughly checked camera. The guy on the phone actually didn't seem to believe me when I said I had stains. And still, it looks like a nice stains trail. What do you think?

So I'm filling the contact form again, I guess I'll have to sent the camera again. I'm actually pretty pissed. It took a month for a camera exchange, not even repair. How long will I have to wait again?
02-09-2011, 09:45 AM   #162
Veteran Member
ve2vfd's Avatar

Join Date: Aug 2007
Location: Montreal, Canada
Photos: Gallery
Posts: 2,433
PhiippeG meeeerde! You camera has freakin ebola man! Thats a pretty long string of contamination

Did you try a wet cleaning just in case this is a dirty sensor? (It does look like contamination to me, but it may be worth a try...) The "new" camera Pentax Canada sent me had a very dirty sensor but after a few wet cleanings it appears to be spotless.

pat
02-09-2011, 10:47 AM   #163
Senior Member




Join Date: Feb 2010
Location: California
Posts: 190
@Philippe
Are you sure it is not a flock of birds flying at high altitude and migrating to the north? OK, jokes aside, seems that serial numbers mean nothing and that an unknown number of defective sensor assemblies are still floating around in the pipeline. Are you paying for the shipping costs? I don't own a K-5, but share your disappointment. It may be a good idea to leave a post in the "serial number database" for reference:
Pentax Serial Number Database - PentaxForums.com
The trend shows the issue being gradually resolved, but maybe people should lay low a little longer before making a commitment in purchasing a K-5. At least that is what I plan to do, if not even skip this generation.
02-09-2011, 12:06 PM   #164
Senior Member
raphtze's Avatar

Join Date: Dec 2010
Location: Oakland, CA
Posts: 136
phillippe.......that's absolutely unacceptable. sorry for your woes, send it back asap and demand a new one.

-raph
02-09-2011, 02:13 PM   #165
Pentaxian




Join Date: Sep 2007
Location: Boston, MA
Posts: 7,411
Sent mine off just now. Already counting down the hours till I get it back.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
address, camera, dslr, email, k-5, k-5 ii, k-5 iis, k5, label, pentax, pentax k-5, sensor
Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -7. The time now is 05:08 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top