Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-26-2011, 06:36 PM   #241
Senior Member




Join Date: May 2007
Location: Atlanta, Ga
Photos: Albums
Posts: 157
QuoteOriginally posted by andi Quote
a brand new replacement kit arrived today, new camera looks great, clean,
no dust, no stains, nothing. Sure my extra battery, charger, strap etc will come handy
Firmware needed to be updated.

Thanks Pentax!
When did you send it in?

02-26-2011, 08:31 PM   #242
Site Supporter




Join Date: Sep 2010
Location: Seattle, WA area
Posts: 29
I called Pentax and did as I was told. I sent my K5 "immediately" as instructed to the Pentax repair facility in Chandler Arizona, which is C.R.I.S. camera repair, as it turns out. Got the camera back within in three weeks, new body, charger, cords, manual, including a new battery! C.R.I.S. has a web site where you can follow the progess and when I called them, they were excellent in updating me.

The Pentax support person did not tell me that Pentax would supply UPS labels and cover the fees to send it to Chandler.
02-27-2011, 01:40 PM   #243
Senior Member
JayBee's Avatar

Join Date: Sep 2008
Location: Manitoba
Photos: Gallery
Posts: 119
My K-5 came back from Pentax Canada a few weeks ago. Since then I have run a lot of Live View and video mode just to heat up the sensor and give it a good 'burn-in'. Conclusion: stain problem solved. I will soon stop taking those f/32 sky shots.
Additionally, Adam has staked a lot of credibility on a coming firmware fix for the low-light focus problem (I use LV as a workaround), so, I am confident that it's just a matter of a short time before we all have the unmatched "Super Camera".

All is good again.
02-27-2011, 01:43 PM   #244
Pentaxian




Join Date: Sep 2006
Location: Kaunas
Posts: 1,452
I've replaced my stained K-5 too. Left my old K-5 in shop on Monday, on Friday I picked up the replacement

02-27-2011, 08:03 PM   #245
Senior Member




Join Date: Sep 2009
Posts: 200
QuoteOriginally posted by Scottie137 Quote
When did you send it in?
From me dropping it at the UPS store to the UPS guy coming with a new one -
18 days
02-28-2011, 05:12 PM   #246
Senior Member




Join Date: May 2007
Location: Atlanta, Ga
Photos: Albums
Posts: 157
QuoteOriginally posted by andi Quote
From me dropping it at the UPS store to the UPS guy coming with a new one -
18 days
I am hoping that with this Tuesday's shipment of replacement bodies, mine will be replaced this week as well. I actually sent it in on the 27th of January, unfortunately UPS lost it for almost a week and a half and it didn't get to Cris until the 11th, which was a Friday. Been "on hold for replacement review and processing" since the 14th.
02-28-2011, 06:33 PM   #247
Loyal Site Supporter




Join Date: Jun 2007
Location: Lehigh Valley, PA
Photos: Gallery
Posts: 512
QuoteOriginally posted by Scottie137 Quote
I am hoping that with this Tuesday's shipment of replacement bodies, mine will be replaced this week as well. I actually sent it in on the 27th of January, unfortunately UPS lost it for almost a week and a half and it didn't get to Cris until the 11th, which was a Friday. Been "on hold for replacement review and processing" since the 14th.
Mine's there since the 9th....I was hoping for a shipment last week but no dice. I'm' hoping they get some in soon!
02-28-2011, 08:46 PM   #248
Junior Member
jonk's Avatar

Join Date: Jan 2008
Location: Woodland CA
Photos: Gallery | Albums
Posts: 29
My replacement is back ordered. CRIS received my first defective K-5 on 2/10/11. I have a second K-5 to be sent in after I get the new one.

03-01-2011, 11:03 AM   #249
Senior Member




Join Date: Nov 2008
Location: BC
Posts: 219
Here we go again....my second K5 has now developed it's staining...Pentax Canada won't give me any idea of how long it will take.....ugh
03-01-2011, 11:57 AM   #250
Senior Member
JayBee's Avatar

Join Date: Sep 2008
Location: Manitoba
Photos: Gallery
Posts: 119
QuoteOriginally posted by mokey Quote
Here we go again....my second K5 has now developed it's staining...Pentax Canada won't give me any idea of how long it will take.....ugh
Oh-oh. That's disappointing - sorry to hear it. How long have you had the replacement? Did you use much Live View or video mode? What is the manufacture date in PhotoMe? I'm wondering if yours was one of the early replacements - before Pentax had it fully figured out.

Last edited by JayBee; 03-01-2011 at 03:58 PM.
03-01-2011, 02:27 PM   #251
Site Supporter
opiedog's Avatar

Join Date: Jan 2008
Location: NC
Posts: 787
QuoteOriginally posted by mokey Quote
Here we go again....my second K5 has now developed it's staining...Pentax Canada won't give me any idea of how long it will take.....ugh
how did that happen? did you take a long video by any chance?
that's not too re-assuring.
03-01-2011, 02:58 PM   #252
Senior Member




Join Date: May 2007
Location: Atlanta, Ga
Photos: Albums
Posts: 157
QuoteOriginally posted by opiedog Quote
how did that happen? did you take a long video by any chance?
that's not too re-assuring.
Those in Canada seems to be getting a very different experience from the U.S. folks, or even those in Europe...
03-01-2011, 04:21 PM   #253
Inactive Account




Join Date: Aug 2008
Location: Michigan, USA
Photos: Gallery | Albums
Posts: 7,485
QuoteOriginally posted by Scottie137 Quote
Those in Canada seems to be getting a very different experience from the U.S. folks, or even those in Europe...
Not to be cruel but I certainly hope so. Some of us haven't had our replacement cameras long enough to determine that however. My initial stain didn't Show up for close to 3 months in my original camera. I hope Pentax Canada gets these people sorted out but based alone on this thread, I'm glad I'm dealing with Pentax USA.

03-01-2011, 04:51 PM   #254
Senior Member




Join Date: Nov 2008
Location: BC
Posts: 219
I've hardly used video, and I never use LV. I've had the replacement for 6 weeks. There were no stains when I got the camera, but now they're back.... It is an early production model - my store replaced mine with a "clean" sensor model. Alas, Pentax Canada here I come! I have to hold off sending it in, as I can't have a camera gone for weeks- hockey playoffs and tourney's coming up!
03-01-2011, 05:49 PM   #255
Senior Member
JayBee's Avatar

Join Date: Sep 2008
Location: Manitoba
Photos: Gallery
Posts: 119
QuoteOriginally posted by mokey Quote
. It is an early production model - my store replaced mine with a "clean" sensor model.
OK - that explains it then - a lot of initial replacements from store stock were also tainted. They were from earlier production, before the problem had been properly identified and dealt with. There will still be some bad sensors out there in the K-5 population - some will get noticed; others will slide under the radar. But anything built after late December is probably good.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
address, camera, dslr, email, k-5, k-5 ii, k-5 iis, k5, label, pentax, pentax k-5, sensor
Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -7. The time now is 02:58 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top