Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-22-2011, 05:56 AM   #1
New Member




Join Date: Jan 2011
Posts: 5
K-5 body problem - can't turn it on

Hello everyone,

I bought K-5 three days ago, took 140 pictures so far - everything was great, K-5 was working perfect until today. I went out to take some photos today (finally found some time for that) and when I came to the location I was able to take one photo, after which the K-5 has turned off and so far I haven't managed to turn it back on.

The battery was full (original K-5 battery), I've already tried with another one (also full original battery), I've tried connecting the camera to the PC ... and nothing. Off - on switch - no response, all screens black, buttons - nothing, sound - nothing, ...

If someone happens to have an idea what could be the problem/solution I would be grateful for your help. If not - I'm taking it back to the shop next week.

01-22-2011, 06:31 AM   #2
Veteran Member
jolepp's Avatar

Join Date: Oct 2010
Location: Finland
Photos: Albums
Posts: 3,196
Mine is remarkably unresponsive without the SD card so taking that out and reinserting it or maybe even trying a different card would seem like worth trying before taking the thing back to shop.
01-22-2011, 06:36 AM   #3
New Member




Join Date: Jan 2011
Posts: 5
Original Poster
QuoteOriginally posted by jolepp Quote
Mine is remarkably unresponsive without the SD card so taking that out and reinserting it or maybe even trying a different card would seem like worth trying before taking the thing back to shop.
Already tried that
01-22-2011, 07:02 AM   #4
Veteran Member




Join Date: Jul 2008
Location: Var, South of France
Photos: Albums
Posts: 1,071
Mine did this twice, only way to solve the problem was to remove the battery... But as you already tried another battery, I don't have any other idea... Try leaving it without battery for some time...

01-22-2011, 07:11 AM   #5
Veteran Member
jolepp's Avatar

Join Date: Oct 2010
Location: Finland
Photos: Albums
Posts: 3,196
QuoteOriginally posted by njofrazg Quote
Already tried that
Sounds like returning it is the thing to do then .
01-22-2011, 08:31 AM   #6
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,108
Other than making sure the card door is fully closed, I can't really think of why it would be doing what it's doing
01-22-2011, 09:01 AM   #7
New Member




Join Date: Jan 2011
Posts: 5
Original Poster
QuoteOriginally posted by dlacouture Quote
Try leaving it without battery for some time...
Tried, nothing

QuoteOriginally posted by Wheatfield Quote
Other than making sure the card door is fully closed, I can't really think of why it would be doing what it's doing
I've tried with 3 different cards, without card, ... and nothing, not even a slightest sign of life. Bad luck for me. And I was really looking forward to the K-7 to K-5 upgrade.
01-22-2011, 01:02 PM   #8
Veteran Member
nulla's Avatar

Join Date: Jul 2008
Location: Melbourne Australia
Posts: 1,560
QuoteOriginally posted by njofrazg Quote
Tried, nothing



I've tried with 3 different cards, without card, ... and nothing, not even a slightest sign of life. Bad luck for me. And I was really looking forward to the K-7 to K-5 upgrade.
Does not sound good.

does it show any signs of power?

01-22-2011, 01:37 PM   #9
Veteran Member




Join Date: Apr 2010
Location: Suomi , Finland
Posts: 373
Staattinen sähkö häiriö. Jos peili jumittuu vaikka poistaa akun on se takuuhuollon paikka, muuten ei. Samoja vikoja on ollut Nikon ja Canon. käyttäjän käsikirjassa on tästä maininta.
01-22-2011, 02:53 PM   #10
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,108
QuoteOriginally posted by njofrazg Quote
Tried, nothing



I've tried with 3 different cards, without card, ... and nothing, not even a slightest sign of life. Bad luck for me. And I was really looking forward to the K-7 to K-5 upgrade.
Just get it replaced when you are able to. Failures of this particular type seem pretty rare.
01-22-2011, 03:38 PM   #11
New Member




Join Date: Jan 2011
Posts: 5
Original Poster
QuoteOriginally posted by 30v iPentax Quote
Staattinen sähkö häiriö. Jos peili jumittuu vaikka poistaa akun on se takuuhuollon paikka, muuten ei. Samoja vikoja on ollut Nikon ja Canon. käyttäjän käsikirjassa on tästä maininta.
Thanks but I already knew that. The first thing I tried was taking out the battery and putting it back again. I've done that about 50 times already. I'm taking the camera back next week.

QuoteQuote:
does it show any signs of power?
Nope, no signs of power, nothing at all.
01-22-2011, 05:58 PM   #12
Veteran Member
nulla's Avatar

Join Date: Jul 2008
Location: Melbourne Australia
Posts: 1,560
QuoteOriginally posted by njofrazg Quote
Thanks but I already knew that. The first thing I tried was taking out the battery and putting it back again. I've done that about 50 times already. I'm taking the camera back next week.



Nope, no signs of power, nothing at all.
Its a return job 4sure
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, dslr, k-5, k-5 body, k-5 ii, k-5 iis, k5, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K20D body or DA 35ltd problem? lon_ton_sai_vat Pentax DSLR Discussion 5 12-14-2010 10:20 AM
K20 body problem? Ben Pentax DSLR Discussion 3 12-18-2009 03:22 PM
Problem with Program PLus body Wxman Pentax Film SLR Discussion 4 06-01-2009 03:23 AM
To turn right or to turn left spura Pentax SLR Lens Discussion 14 04-15-2009 11:29 AM
Optio W10 turn-on problem Pappa Bear Pentax Compact Cameras 2 08-29-2008 11:16 AM



All times are GMT -7. The time now is 05:31 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top