Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-12-2011, 11:02 AM   #1
New Member




Join Date: Feb 2011
Location: Dallas
Posts: 4
K-5 with old SMC-M lenses

Hello,
I am new here, but I used to read many important threads posted on this site. I'd think my question could be primitive (or may be a stupid question), but please help me .

I recently bought a K-5 with a DA 18-135mm lens. All works fine. I have then tried to use old SMC-M lenses for my K-5. However, my K-5 won't take photo with SMC-M lenses (whenever the SMC-M lens is mounted on the K-5, its shutter does NOT work). I guess there could be some sort of setting(s) that I don't know.

Does anybody know how to take photos with the old SMC-M lens mounted on K-5?

Thank you.

02-12-2011, 11:07 AM   #2
Veteran Member
bobell69's Avatar

Join Date: Sep 2007
Location: Courtenay BC
Photos: Gallery | Albums
Posts: 422
You must use the camera in manual in order to make it work with the M lens. Set your autofocus to Manual as well as the set the top dial to Manual. Set the aperture to your desired f stop and then press the green button which will set the shutter speed. Press the shutter and it should work.
02-12-2011, 11:26 AM   #3
New Member




Join Date: Feb 2011
Location: Dallas
Posts: 4
Original Poster
Hello,
Thank you for the answer. I actually have set the 'AF-S' to 'MF' as well as the top dial into the position of M (manual). However, whenever the K-5 is mounted with the M lens, the symbol for "F' is blinking (shown as 'F --'; thus no Aperture value)', and the camera does not take any photos. I have tried the green bottom as well. I guess, there could be a problem for setting "Aperture". Also, when the modes are in 'MF' and 'M', I am not able to control ISO, which is frustrating.

Last edited by Aspirin006; 02-12-2011 at 11:33 AM.
02-12-2011, 11:35 AM   #4
Loyal Site Supporter




Join Date: Sep 2006
Location: Bronx NY
Photos: Gallery | Albums
Posts: 5,611
You need to go into the custom menu and set "use aperture ring" to "permitted" I don't own the K-5 so I don't know exactly where in the custom menu it is. Check your manual.

NaCl(it's in there somewhere)H2O

02-12-2011, 11:44 AM   #5
New Member




Join Date: Feb 2011
Location: Dallas
Posts: 4
Original Poster
Dear sodium cloride in dihydrogen oxide and bobell69,

I got it (it is under "C 27: Using aperture ring Reset Custom Functions). All works fine.

Thank you very much.
02-12-2011, 11:48 AM   #6
Senior Member
LeFanch's Avatar

Join Date: Dec 2007
Location: Bordeaux area when off, working in Norway
Posts: 101
Hi!

The item [27. Using Aperture ring] must be set to [Allowed] in the [C Custom setting 4] menu.

I hope that helps!

LeFanch

Edit: Way too slow! ;-)
02-12-2011, 01:58 PM   #7
Site Supporter
kiwi_jono's Avatar

Join Date: Dec 2009
Location: Christchurch, New Zealand
Photos: Gallery | Albums
Posts: 1,085
Really wish they would enable it by default -would save so many questions.

No idea why they don't.
02-12-2011, 02:21 PM   #8
Veteran Member




Join Date: Dec 2007
Location: Prague
Photos: Gallery
Posts: 1,198
Doesn't the additional step slow the camera down? That may be valid reason. No one uses M lenses anyway. Only me and few others. :-)

02-12-2011, 03:57 PM   #9
Veteran Member
bobell69's Avatar

Join Date: Sep 2007
Location: Courtenay BC
Photos: Gallery | Albums
Posts: 422
QuoteOriginally posted by elho_cid Quote
Doesn't the additional step slow the camera down? That may be valid reason. No one uses M lenses anyway. Only me and few others. :-)
I agree no one uses them anymore.......Guess I had better stop using mine too.
02-12-2011, 07:51 PM   #10
New Member




Join Date: Feb 2011
Location: Dallas
Posts: 4
Original Poster
Dear LeFanch,

Thank you anyway. A lot of things to know to use this cool K-5...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-5, k-5 ii, k-5 iis, k5, lens, lenses, pentax k-5, question, smc-m
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Km and old manual lenses: SMC Takumars & Tamron Adaptall 2 lenses Kendrick Troubleshooting and Beginner Help 10 04-14-2010 03:23 AM
SMC vs non-SMC versions of Lenses dosdan Pentax SLR Lens Discussion 2 08-16-2009 05:02 AM
smc f and smc fa lenses on k100d wombat62 Troubleshooting and Beginner Help 4 04-04-2009 11:11 AM
For Sale - Sold: 3 Lenses: SMC M50/2 - SMC M28/2.8 - Vivitar M42 400/5.6 IF Buddha Jones Sold Items 8 05-27-2008 05:40 AM
For Sale - Sold: M42 Lenses - SMC 50mm F1.4 | SMC 135mm | 135mm barbosas Sold Items 8 02-17-2008 11:49 AM



All times are GMT -7. The time now is 11:52 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top