Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-27-2011, 03:57 PM   #46
Veteran Member




Join Date: Sep 2008
Posts: 484
Cr@p, found this thread after applying the update...is there a way to convert from DNG to PEF? I know DCU can convert the other way, but that doesn't help now...

02-28-2011, 12:03 AM   #47
Veteran Member




Join Date: Apr 2010
Location: Suomi , Finland
Posts: 373
Aina uusi päivitys tuoo parenpia ominaisuuksia.
02-28-2011, 05:30 PM   #48
jac
Loyal Site Supporter




Join Date: Dec 2010
Location: Clyde River, Nunavut, Canada
Posts: 2,363
QuoteOriginally posted by ario arioldi Quote
Yes the raw file support is part of the OS; most probably the finder will just use the embeddeb jpg, so there is no rendering problem due the bug in the raw support.
Took 11 shots at my son's gym w/flash. 8 at ISO800, 3 at ISO280. 2 of the ISO800 processed nicely and the rest had the magenta cast. Unfortunately just shot raw. The previews looked normal so i did my usual and deleted the originals from the SD card. Oops! Bad move. But since two did work out there still seems to be some random element involved.
02-28-2011, 05:38 PM   #49
Pentaxian
twitch's Avatar

Join Date: Nov 2009
Posts: 4,571
Does this particular problem affect PEF's and DNG's? Previous problems with colour casts have, is this one any different?

02-28-2011, 06:11 PM   #50
jac
Loyal Site Supporter




Join Date: Dec 2010
Location: Clyde River, Nunavut, Canada
Posts: 2,363
Workaround

QuoteOriginally posted by jac Quote
Took 11 shots at my son's gym w/flash. 8 at ISO800, 3 at ISO280. 2 of the ISO800 processed nicely and the rest had the magenta cast. Unfortunately just shot raw. The previews looked normal so I did my usual and deleted the originals from the SD card. Oops! Bad move. But since two did work out there still seems to be some random element involved.
Just found a solution if you have Photoshop or PSE. I exported the magenta DNG to the desktop and the preview was fine. Opened it both Adobe products, saving back in the same folder as a *.tif file. When I imported this back into Aperture, the cast was gone. Seems like a painful expletive deleted solution but at least a work-around. Or, I suppose, any other other conversion process. Interestingly, the two posted snaps at converted to '.jpg's so I could attach them and the cast is still there.
Attached Images
   
02-28-2011, 06:42 PM - 1 Like   #51
Senior Member
jrforman's Avatar

Join Date: Mar 2008
Location: Minneapolis
Photos: Gallery | Albums
Posts: 202
QuoteOriginally posted by twitch Quote
Does this particular problem affect PEF's and DNG's? Previous problems with colour casts have, is this one any different?
This problem just affects K-5 DNG files. If you take PEF's, they are fine.

If you don't reprocess old DNG files (previously processed under 3.5), they will be O.K. I have upgraded to 3.6 and changed to PEF and it works well. I just make sure I don't select the reprocessing of the old DNG photos in the adjustments section. Make sense?
02-28-2011, 07:15 PM   #52
Veteran Member




Join Date: Jan 2008
Location: Brooklyn
Photos: Gallery
Posts: 316
QuoteOriginally posted by jrforman Quote
This problem just affects K-5 DNG files. If you take PEF's, they are fine.

If you don't reprocess old DNG files (previously processed under 3.5), they will be O.K. I have upgraded to 3.6 and changed to PEF and it works well. I just make sure I don't select the reprocessing of the old DNG photos in the adjustments section. Make sense?
This has been my approach.
02-28-2011, 07:20 PM   #53
Pentaxian
twitch's Avatar

Join Date: Nov 2009
Posts: 4,571
QuoteOriginally posted by jac Quote
Just found a solution if you have Photoshop or PSE. I exported the magenta DNG to the desktop and the preview was fine. Opened it both Adobe products, saving back in the same folder as a *.tif file. When I imported this back into Aperture, the cast was gone. Seems like a painful expletive deleted solution but at least a work-around. Or, I suppose, any other other conversion process. Interestingly, the two posted snaps at converted to '.jpg's so I could attach them and the cast is still there.
Interesting. That was the kind of rubbish conversion I was getting on my high ISO K-x DNG's before 3.6, with 3.6 now it's OK. Adobe have (not surprisingly) nailed DNG conversion, but to Apple is seems illusive; they fix it for one camera and break it for another.

02-28-2011, 10:49 PM   #54
Veteran Member




Join Date: Apr 2010
Location: Suomi , Finland
Posts: 373
Päivitän aina Mac kun tulee uusi versio.
03-23-2011, 04:47 PM   #55
Veteran Member




Join Date: Jan 2008
Location: Brooklyn
Photos: Gallery
Posts: 316
Looks like 10.6.7 and/or Aperture 3.1.2 fixes this problem.
03-23-2011, 08:09 PM   #56
Veteran Member




Join Date: Mar 2010
Photos: Gallery | Albums
Posts: 1,545
Ugh! I'm having problems with the magenta cast too! It's only on pictures that are in the range of ISO 200-800. I upgraded to Aperture 3.1.2 but that didn't fix the problem (or maybe it did but my pictures are all still colored). I'm installing OS X SL 10.6.7 now.

Unfortunately, I deleted the photos from my card as soon as I finished uploading, so does anyone know if Aperture will fix the problem or do I have to go in and manually edit each photo?
03-24-2011, 06:06 AM   #57
Site Supporter




Join Date: Sep 2010
Location: Cedar Falls, IA
Photos: Gallery
Posts: 19
Original Poster
The new upgrades fix the problem. However, the photos I changed to fix the problem, either using auto curves or auto levels, had a green cast instead of a magenta cast. I had to reverse my previous fixes. Now they're fine.
03-24-2011, 09:03 AM   #58
Veteran Member




Join Date: Mar 2010
Photos: Gallery | Albums
Posts: 1,545
Oh, the OS X update fixed the problem! Yay.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, conversion, dslr, k-5, k-5 ii, k-5 iis, k5, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
PC or Mac? Sparkle General Talk 147 01-27-2011 10:05 AM
For Mac Users: Upgrade tiger to snow leopard? lurchlarson Digital Processing, Software, and Printing 22 02-18-2010 07:38 PM
Upgrade Advice: Upgrade Lenses or Camera krs Pentax DSLR Discussion 10 07-17-2009 05:24 AM
Getting my first Mac - PSPX2 & SILKYPIX & MAC?? vievetrick Digital Processing, Software, and Printing 17 03-25-2009 09:59 AM
K10D photo series - mac / aperture / .mac Tom M Photographic Technique 7 12-29-2007 03:13 PM



All times are GMT -7. The time now is 09:47 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top