Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-25-2011, 06:38 PM   #1
Senior Member




Join Date: Jan 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 131
K-5 Dust Removal and SR

I just bought a K-5 (and have a K-x) I updated the K-5 firmware to 1.02

If I select Dust Removal ("wrench" menu #4), nothing happens, no vibration. This is after resetting the camera to factory settings ("wrench" menu #3). I don't think the SR or Dust Removal is working at all.

Some blurry pictures this morning, and granted it could have been me shaking from the cold.

Could a K-5 owner verify the camera vibrates when selecting Dust Removal? Thanks!

02-25-2011, 06:42 PM   #2
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,853
You don't feel or hear the dust removal on the K-7 and K-5. It is an ultra-sonic system rather than a slower shaking of the sensor.
02-25-2011, 06:51 PM   #3
Senior Member




Join Date: Jan 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 131
Original Poster
Thanks - I sure can feel it wacking away on the K-x.

The new K-5 sensor is incredibly clean, not a hint of dust or "stain" at F22 on a couple of different lenses shot on a solid white/sky background.
02-25-2011, 07:53 PM   #4
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,853
I have been shooting a lot with a K-7 - never had a dust problem. I think the new system is much better than the old.

02-25-2011, 08:07 PM   #5
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,518
QuoteOriginally posted by leadfoot Quote
I don't think the SR or Dust Removal is working at all.

Some blurry pictures this morning, and granted it could have been me shaking from the cold.
First check that SR On was selected on the menu.

Then, you must remember to wait 1-2 s for the SR light/icon to come on in the view finder, once you half-press the shutter.

In other words:
- hlaf-press the shutter
- wait for focus confirmation (hexagon)
- wait for the SR icon (Hand icon); it may take 1-2 s
- then shoot.

Many forget to wait for the SR icon to come on and the pictures are burry.

Hope that the comments will help.

Last edited by hcc; 02-25-2011 at 11:37 PM.
02-26-2011, 02:10 AM   #6
Veteran Member




Join Date: Aug 2009
Posts: 2,311
The K-7 sensor clean is somewhat audible, especially without a lens attached, has a very hight pitched sound to it. I guess it varies from camera to camera. The K-5 sensor clean is so quiet you cant hear it.

Im one of those who take the lens off and try to put my ear inside the camera. Maybe i heard something in the K-5 Can not say for sure though!

The SR: In the K-5 the SR turns on almost instantly after half-press, a big step up from the lag in the K-7.

You may have a defect camera, we cant rule that out, so....

Hand hold the camera with your lens at 50mm or so. Select a medium slow shutterspeed like 1/30 and set aperture and ISO to get a nice exposure.

Now, half press the shutter button and pan the camera in circles in front of you (imaging that the camera is inside a car on a bumpy road). Take the picture, then turn of SR and do the same. Experiment a litle....

OR, this is easier! Turn the camera into Live View, move the camera, can you hear the SR working?
02-26-2011, 09:30 AM   #7
Veteran Member




Join Date: Apr 2010
Location: Suomi , Finland
Posts: 373
Kannattaa lukea käyttöohjeet ja toimia niiden mukaan. Eikä uskoa kaikenmailman omastapäästä keksittyjä ohjeita. Säästää rahaa ja kameran.
02-26-2011, 10:26 AM   #8
Senior Member




Join Date: Jan 2010
Location: Oregon
Photos: Gallery | Albums
Posts: 131
Original Poster
If I put my ear to the back of the K-5, can definitely hear the dust removal, very high frequency. In live view there is a noticeable difference between SR and no SR, so it's working - just needed to look at it more carefully.

In live view, if I put my ear up to the K-5, I hear a slight whirring, and it's the same whether SR is on or not. K-x does the same thing, just a little louder.

Thanks for the tips.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, dust, k-5, k-5 ii, k-5 iis, k5, menu, pentax k-5, removal, sr
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax K-7 Dust Alert and Dust Removal Functions brosen Pentax DSLR Discussion 9 02-09-2016 04:43 AM
K-5 Dust Removal G-Diesel Pentax K-5 8 01-23-2011 05:34 PM
K-5 Dust Removal Mechanism zuiko Pentax K-5 5 11-24-2010 08:01 PM
K-7 Dust Removal ?? Sew-Classic Pentax DSLR Discussion 8 12-08-2009 11:16 AM
Dust Removal Process alderfall Pentax DSLR Discussion 8 02-02-2009 07:38 PM



All times are GMT -7. The time now is 10:35 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top