Forgot Password
Pentax Camera Forums Home
 

Closed Thread
Show Printable Version Search this Thread
03-09-2011, 07:01 PM   #16
Veteran Member
dgaies's Avatar

Join Date: Oct 2009
Location: Maryland / Washington DC
Posts: 3,917
QuoteOriginally posted by nixifo Quote
I was going to return it in a few hours. I was very disappointed. I couldn't believe that they will provide a perfect fix like this. Well done.
Well at the risk of tempering the excitement, it might be a little while before everyone is ready to declare it a "perfect" fix.... but my initial impression is that things look good.

03-09-2011, 07:02 PM - 1 Like   #17
Loyal Site Supporter
SteveM's Avatar

Join Date: Jan 2009
Location: Vancouver Island, BC, Canada
Photos: Gallery
Posts: 3,295
Thank god. Not that I saw a major issue before.

I'd like to be the first to complain that there isn't enough now to complain about.
03-09-2011, 07:03 PM   #18
Veteran Member




Join Date: Sep 2007
Location: Pittsburgh, Pa, USA
Photos: Gallery
Posts: 529
QuoteOriginally posted by nixifo Quote
I was going to return it in a few hours. I was very disappointed. I couldn't believe that they will provide a perfect fix like this. Well done.
Now I'm kicking myself. I bought the K-5 for a wedding I'm shooting on Sunday. After 3 copies with FF issues I returned it for a full refund. Now it turns out that if I kept it I'd have it for the wedding.

In any case, a few more good reports and I'll place an order for a K-5. It might be too late for Sunday, but I still want one.
03-09-2011, 07:05 PM   #19
Veteran Member




Join Date: Mar 2010
Posts: 527
My tests are made with DA*300 and DA* 50-135 at open aperture and since one day no problem
Perfect till today

03-09-2011, 07:11 PM   #20
Veteran Member
Smeggypants's Avatar

Join Date: Sep 2010
Posts: 1,536
Well I've rattled off several initial test shots with 1.03 and so far I'm highly impressed. - There seems to be a little more hunting at EVs lower than EV2 than tehre were before and also results are a little intermittent, Occasionally it still front focusses, but the majority of the time it nails it around EV2

It's too early tell if it's a perfect fix, but I'm certainly a lot happier.

Right back to testing.
03-09-2011, 07:11 PM   #21
Pentaxian




Join Date: Apr 2010
Location: Tennessee
Posts: 1,994
Did anybody else notice that this firmware loaded waaay faster than 1.02? I just did 1.02 about 48 hrs. ago when I got the camera. Perhaps not much code was required to fix this.
03-09-2011, 07:11 PM   #22
Veteran Member
Smeggypants's Avatar

Join Date: Sep 2010
Posts: 1,536
QuoteOriginally posted by dgaies Quote
Well at the risk of tempering the excitement, it might be a little while before everyone is ready to declare it a "perfect" fix.... but my initial impression is that things look good.
Indeed. Certainly looking good though.
03-09-2011, 07:12 PM   #23
Senior Member
Trig's Avatar

Join Date: Aug 2009
Location: Acushnet, MA
Photos: Gallery
Posts: 211
Awesome! Downloading and installing tonight.

03-09-2011, 07:20 PM   #24
Pentaxian




Join Date: Apr 2010
Location: Tennessee
Posts: 1,994
Unfortunately still no auto image rotation. That's what I was really wanting.
03-09-2011, 07:22 PM   #25
Veteran Member




Join Date: Mar 2010
Posts: 527
03-09-2011, 07:25 PM   #26
Veteran Member
dgaies's Avatar

Join Date: Oct 2009
Location: Maryland / Washington DC
Posts: 3,917
QuoteOriginally posted by DogLover Quote
Unfortunately still no auto image rotation. That's what I was really wanting.
I was also hoping for that (seriously), but to be honest I had no expectations given the more important things that needed to be attended to
03-09-2011, 07:30 PM   #27
Pentaxian




Join Date: Apr 2010
Location: Tennessee
Posts: 1,994
QuoteOriginally posted by dgaies Quote
I was also hoping for that (seriously), but to be honest I had no expectations given the more important things that needed to be attended to
Yeah, I know, and I really am happy for all the folks that had the FF problem.
03-09-2011, 07:35 PM   #28
Site Supporter




Join Date: Sep 2006
Location: Pennsylvania
Photos: Gallery | Albums
Posts: 1,294
QuoteOriginally posted by nixifo Quote
It worked for me, almost perfect

I had terrible FF. It was useless indoors.
Just a kind word for you for coming forth a few days back on the other forum and taking some lumps and still keeping a positive attitude.

While Pentax has been ultra tight lipped in recent years it's good to see that someone in Greece broke the "silence".

I know that it was posted here by Adam a week back but you boldly stood by your comments. Congrats.

Stephen
03-09-2011, 07:43 PM   #29
Senior Member




Join Date: Nov 2008
Location: BC
Posts: 219
Ok, a quick test with the batteries.... In normal tungsten light, the FF issue has resolved for me (the first few pics)...in really low tungsten light (the last couple of photo's)- dimmer was turned down really low...not so great improvement....But all in all, pretty good fix! Will test more again tomorrow.
Just realized my camera WB was set to custom for an arena I was shooting...oops.
Attached Images
View Picture EXIF
PENTAX K-5  Photo 
View Picture EXIF
PENTAX K-5  Photo 
View Picture EXIF
PENTAX K-5  Photo 
View Picture EXIF
PENTAX K-5  Photo 
View Picture EXIF
PENTAX K-5  Photo 

Last edited by mokey; 03-09-2011 at 07:53 PM.
03-09-2011, 07:45 PM   #30
Veteran Member




Join Date: Jun 2009
Location: Bridgetown West Australia
Photos: Gallery | Albums
Posts: 850
Good news for those of you who have had this problem! Sales of the K5 should sky rocket now with all the issues put to bed.
Closed Thread

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-5, k-5 ii, k-5 iis, k5, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Firmware Hack site tr13 Pentax DSLR Discussion 433 09-30-2014 08:59 AM
Firmware differences between US and Japan? bwDraco Troubleshooting and Beginner Help 1 11-18-2010 08:08 PM
K20D Firmware Ver - Pentax Web Site Ver? ChipB Pentax DSLR Discussion 2 02-23-2010 04:14 PM
Photo samples from K-7 Official Site Japan vizjerei Pentax DSLR Discussion 6 06-06-2009 09:26 PM



All times are GMT -7. The time now is 11:03 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top