Forgot Password
Pentax Camera Forums Home
 

Closed Thread
Show Printable Version Search this Thread
03-10-2011, 06:56 AM   #91
Pentaxian




Join Date: Apr 2007
Location: Sweden
Posts: 1,884
QuoteOriginally posted by Smeggypants Quote
Yes just confirmed that above. Hmmmm
But that is not a new behavior, I've noticed it before. Live view turns on the assist lamp long before the PF does even with 1.02.

03-10-2011, 07:02 AM   #92
Senior Member
geezer52's Avatar

Join Date: Jul 2009
Location: High Desert, California
Photos: Gallery
Posts: 231
QuoteOriginally posted by Serpiente Quote
Originally posted by Erik
Judging from some posts in this thread, I think it is probably a good idea to reset the camera to factory settings after installing 1.03.
This!

If you had adjusted the AF, the firmware might alter the AF settings in general. You probably need to reset all the settings and adjust it again. Makes sense to me.
Since a reset seems necessary it's probably smarter to do the reset before installing the FW update
03-10-2011, 07:04 AM   #93
Veteran Member




Join Date: Nov 2008
Location: Umeň, Sweden
Posts: 755
QuoteOriginally posted by geezer52 Quote
Since a reset seems necessary it's probably smarter to do the reset before installing the FW update
Ideally it shouldn't matter, but consider that the "reset" routine itself may have changed between 1.02 and 1.03, so that what was once a default value is no longer so. Therefore, I think it makes more sense to reset after updating.
03-10-2011, 07:05 AM   #94
Veteran Member
dgaies's Avatar

Join Date: Oct 2009
Location: Maryland / Washington DC
Posts: 3,917
QuoteOriginally posted by geezer52 Quote
Since a reset seems necessary it's probably smarter to do the reset before installing the FW update
As far as I can tell, there is no reason to do a reset before or after the firmware update unless you want to go back and re-enter all your custom function settings. If resetting the camera were an important part of the firmware updating process, it would either take place automatically as part of the update or be explicitly included in the instructions. I realize I will likely get blasted for making such a bold assumption, but that's the way I see it.

03-10-2011, 07:13 AM   #95
Senior Moderator
Loyal Site Supporter
Parallax's Avatar

Join Date: Apr 2008
Location: South Dakota
Photos: Gallery
Posts: 15,107
QuoteOriginally posted by Christine Tham Quote
I hate to be the bearer of bad news, but I also discovered the fix is not perfect, and there is still FF in some situations.

I have just taken a number of shots, all on the FA43, f1.9, ISO100

Low level daylight, t=5s (EV -0.47): fine
Dimmed halogen light, t=10s (EV -1.47): fine
Dimmed halogen light, t=4s (EV -0.15): slight FF
Dimmed halogen light, t=1.3s (EV 1.47): slight FF
Dimmed halogen light, t=0.6s (EV2.59): fine
Halogen light (max brightness), t=1/4s (EV 3.85): fine

The degree of FF is less than before, but the camera is still not perfectly focused.

I'm happy to post some photos if there is interest, but I'm lazy and I'm hoping you will just take my word on it.

Bottom line: it's an improvement, but not perfect. Since I was pretty happy with the camera before, I'm obviously still happy with it, but ever so slightly disappointed that the firmware fix was not perfect.
I've stayed out of this issue so far, as I don't have a K5; but now I am really confused.
Haven't you maintained all along that your camera had no FF issue? It worked just fine, right? But the new firmware didn't fix the non existent problem completely, it only partially fixed the non existent problem.
What am I missing? :confused2:
03-10-2011, 07:16 AM   #96
Veteran Member




Join Date: Sep 2007
Location: Pittsburgh, Pa, USA
Photos: Gallery
Posts: 529
QuoteOriginally posted by Parallax Quote
I've stayed out of this issue so far, as I don't have a K5; but now I am really confused.
Haven't you maintained all along that your camera had no FF issue? It worked just fine, right? But the new firmware didn't fix the non existent problem completely, it only partially fixed the non existent problem.
What am I missing? :confused2:
I'm glad YOU said this. I was thinking it, but I kept quiet. Christine has already accused me of being a troll
03-10-2011, 07:25 AM   #97
Loyal Site Supporter




Join Date: Sep 2006
Location: Texas
Photos: Gallery | Albums
Posts: 23,757
QuoteOriginally posted by Parallax Quote
I've stayed out of this issue so far, as I don't have a K5; but now I am really confused.
Haven't you maintained all along that your camera had no FF issue? It worked just fine, right? But the new firmware didn't fix the non existent problem completely, it only partially fixed the non existent problem.
What am I missing? :confused2:
I guess we think alike Jim......well, sorta.....I was wondering the same thing. I am also wondering how many with "perfect focus" have or will be downloading the new firmware at their soonest convenience?

Hey, that's OK, all is forgiven here, the goal all along has been to get a fix that will make everyone happy and allow doubters to go ahead and purchase the K5. Mine was ordered last night, by Otis.

Personally, I hope we can all move on and get along. I have no regrets for my part in "whining" and thank those that also were loud squeaking wheels, the grease does not come without a lot of noise. Those that think Pentax doesn't read these Forums is not living in the real world. They heard us and responded.
Now, can we all get to shooting and posting our shots in the thread here with all those other great K5 shots? I'll be a little late, but Monday is just around the corner.

Best Regards!
03-10-2011, 07:47 AM   #98
Veteran Member
creampuff's Avatar

Join Date: May 2007
Location: Singapore
Photos: Gallery
Posts: 3,955
Hopefully harmony will reign once again in Pentaxland with this new firmware. Instead of in-fighting we should actively use our K-5s to post more pictures (good ones of course) and win over the Canikon crowd who are paying a lot more money for their gear but missing the Pentax party. We need to be Pentax evangelists because with more users on board, eventually we'll get to see more exotic lens offerings in the line-up.

03-10-2011, 07:50 AM   #99
Pentaxian




Join Date: Mar 2009
Location: Perth Australia
Photos: Albums
Posts: 1,511
resetting is probably important IF you have messed with global or lens AF adjustments at all before 1.03
03-10-2011, 07:52 AM   #100
Veteran Member




Join Date: Jan 2007
Location: Northern California
Posts: 475
Good News

QuoteOriginally posted by nixifo Quote
I want to be the first to take credit for this firmware update appearing when it did:

The K7 I bought arrives today....

Ray
03-10-2011, 07:55 AM   #101
Pentaxian




Join Date: Mar 2009
Location: Perth Australia
Photos: Albums
Posts: 1,511
QuoteOriginally posted by JayBee Quote
Actually, very little improvement, if any.
Thoughts?
Just did a test with my DA40 and its perfect focus, LV or Phase mode. I suspect your lens needs adjustment? Is it a consistent with different light levels?

Did you already have lens adjustments in place before the firmware update you've not reset?
03-10-2011, 08:01 AM   #102
Veteran Member
Smeggypants's Avatar

Join Date: Sep 2010
Posts: 1,536
QuoteOriginally posted by Parallax Quote
I've stayed out of this issue so far, as I don't have a K5; but now I am really confused.
Haven't you maintained all along that your camera had no FF issue? It worked just fine, right? But the new firmware didn't fix the non existent problem completely, it only partially fixed the non existent problem.
What am I missing? :confused2:
I'm also glad you said this. This thread https://www.pentaxforums.com/forums/pentax-k-5-forum/136142-wow-k-5-has-amazi...ish-light.html seems awfully contrary to the post 1.03 report from same forum member.
03-10-2011, 08:05 AM   #103
Pentaxian
RonHendriks1966's Avatar

Join Date: Jan 2009
Photos: Gallery
Posts: 8,556
Great thing this.

Now we can also use the internal flash with SDM-lenses and liveview. Going to make more pics now.
03-10-2011, 08:09 AM   #104
Veteran Member
Smeggypants's Avatar

Join Date: Sep 2010
Posts: 1,536
QuoteOriginally posted by WerTicus Quote
Just did a test with my DA40 and its perfect focus, LV or Phase mode. I suspect your lens needs adjustment? Is it a consistent with different light levels?

Did you already have lens adjustments in place before the firmware update you've not reset?
This is a pertinent point. I've had to recalibrate my Sigma 30/1.4 following the update. I suggest everyone checks the calibration of their lenses in daylight before making any in depth tests.
03-10-2011, 08:12 AM   #105
gtl
Veteran Member




Join Date: Feb 2010
Posts: 349
The question is, does your sigma now focus similarly in bright light and low light? Thanks!

QuoteOriginally posted by Smeggypants Quote
This is a pertinent point. I've had to recalibrate my Sigma 30/1.4 following the update. I suggest everyone checks the calibration of their lenses in daylight before making any in depth tests.
Closed Thread

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, k-5, k-5 ii, k-5 iis, k5, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Firmware Hack site tr13 Pentax DSLR Discussion 433 09-30-2014 08:59 AM
Firmware differences between US and Japan? bwDraco Troubleshooting and Beginner Help 1 11-18-2010 08:08 PM
K20D Firmware Ver - Pentax Web Site Ver? ChipB Pentax DSLR Discussion 2 02-23-2010 04:14 PM
Photo samples from K-7 Official Site Japan vizjerei Pentax DSLR Discussion 6 06-06-2009 09:26 PM



All times are GMT -7. The time now is 04:47 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top