Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-28-2011, 05:10 PM   #16
Veteran Member
Smeggypants's Avatar

Join Date: Sep 2010
Posts: 1,536
QuoteOriginally posted by imtheguy Quote
You must be a mind reader. Yes, only the mount ring for the body is anodized black (except for the contacts of course) and the rest or the mount rings are chromed, I guess, shiney anyway.
Yup, get some emery cloth and rub off some of the anodising. I sanded down the anodising under the lugs as that's where a spring contact is I think.

The mount ring/body is the return feed of the circuit and must be electrically conductive. Hope it sorts it

08-15-2011, 07:28 PM   #17
Site Supporter
enoeske's Avatar

Join Date: Jul 2009
Location: Surprise, Az
Photos: Gallery
Posts: 1,888
Did this ever get solved?

I have gotten a K-5 since this started and have found that it doesn't stop down my K 50mm when its on my Vivitar AT-22 extension tubes. The K20D works just find with them.

Same symptoms as OP.

*Non-electrical extension tubes (no contacts)
*K-5
*Lens (or tubes) does not get stopped down for the exposure -- nor with a push of the green button while in manual mode
*After removing the extension tubes, the lens alone will stop down
08-16-2011, 08:58 AM   #18
Pentaxian
fs999's Avatar

Join Date: Jul 2008
Location: Luxembourg
Photos: Gallery
Posts: 3,456
Since the K-7 the mechanical aperture lever is only working in Manual mode.

I have the same problem with my Novoflex auto-bellows. It works well with my K20D...
08-16-2011, 09:04 AM   #19
Site Supporter
enoeske's Avatar

Join Date: Jul 2009
Location: Surprise, Az
Photos: Gallery
Posts: 1,888
QuoteOriginally posted by fs999 Quote
Since the K-7 the mechanical aperture lever is only working in Manual mode.

I have the same problem with my Novoflex auto-bellows. It works well with my K20D...
I'm in manual mode -- still no aperture movement on the extension tubes, through bare K series lens works fine.

09-01-2011, 04:40 AM   #20
Inactive Account




Join Date: Aug 2011
Posts: 2
Is Anodized removal did solve the problem

I've exactly the same symptom. K5 + Automatic extension tube dosn't stop down .
Does any how solves the trouble? Is removal of the peint helpful ?
09-03-2011, 10:39 AM   #21
Site Supporter
enoeske's Avatar

Join Date: Jul 2009
Location: Surprise, Az
Photos: Gallery
Posts: 1,888
bump for a solution...
09-03-2011, 11:24 AM   #22
Inactive Account




Join Date: Aug 2011
Posts: 2
aluminium foil

I just put a piece of aluminium foil between the K5 connector and the extension tube. It closes the electrical circuit and the green buton is now working perfectly. Stop down is ok. Hope this help
10-31-2011, 10:00 AM   #23
New Member




Join Date: Oct 2011
Posts: 1
I have a Novoflex Auto-Bellows which shows the some bug with my K5. Remove the black anodized solved the problem.

02-03-2014, 02:05 PM   #24
New Member




Join Date: Feb 2014
Posts: 1
Extension tubes

Hi. Just a thanks for the info on how to get my non-electric contact ( and non-Pentax) extension tubes working correctly on my K-7. They are anodised on the camera face of the mounts, and removal of a small section of the anodising has enabled the end pin to make earth contact, and activate the diaphragm lever on the camera. A simple solution to an annoying problem.
Mike
02-03-2014, 06:50 PM   #25
Site Supporter
enoeske's Avatar

Join Date: Jul 2009
Location: Surprise, Az
Photos: Gallery
Posts: 1,888
FYI in case anyone is still following this thread...Same issue with the K-3. You need to short the contacts. Aperture won't stop down otherwise.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto, camera, dslr, extension, k-5, k-5 ii, k-5 iis, k200, k5, lens, pentax k-5, tubes
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wanted - Acquired: Auto extension tubes with electrical contacts (ex: Vivitar AT-23) RXrenesis8 Sold Items 5 06-13-2011 06:50 AM
PKA AUTO FOCUS extension tubes ? netuser Pentax SLR Lens Discussion 16 07-14-2009 06:41 AM



All times are GMT -7. The time now is 08:21 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top