Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-29-2011, 07:24 PM   #1
Inactive Account




Join Date: Mar 2011
Location: Tijuana
Posts: 1
Hot shoe Fail after First Shot

Hello
I received my new Pentax K-5 to B & H a week ago

today i test the camera with a Pentax hotshoe Sync Cord and Wescott Strobelite.

the problem is that only flash 1 time and then the flash dont fire anymore

disconnect the sync cord from the hot shoe and reconnect and turn the flash 1 again and stop flashing.

y try with another hotshoe and 3 diferent sync cords and the same problem

also conect direct in the x-sync on the camra and the same proble just fire the flash once.

pd. the internal flash work perfect. but .........

this is a configuration problem or should I send my camera to refund?
Urgent I have only 3 days more to return it to B & H

Thanks

03-29-2011, 08:48 PM   #2
Banned




Join Date: Nov 2010
Location: Williston, VT
Posts: 268
usually when the camera locks up after one shot, it's because the flash hot shoe (or socket) is getting too much voltage from the trigger. Pentax cameras have a very high threshold for voltage, but going far beyond the spec will cause them to seize up, which is better than frying your hot shoe. I've had the same result from really old flashes.
03-29-2011, 10:20 PM   #3
Pentaxian
Wheatfield's Avatar

Join Date: Apr 2008
Location: The wheatfields of Canada
Posts: 10,043
This happens because Pentax is reverse polarized.
Really.
You need to reverse the wire going into the sync connection.
The easiest way to do this is to cut the wire and put a lamp socket and plug onto the cut ends. Then you can reverse the polarity of the wires.

I had the same problem at the studio before we went wireless (which is the best solution, BTW). I had to change the cords so that the Pentaxes would work.
04-04-2011, 04:00 AM   #4
Inactive Account




Join Date: Mar 2011
Posts: 2
Hello!
I really don't understand: the pentax hot-shoe (where you attach the flash unit) have + or - polarity??

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, cord, dslr, fire, flash, hotshoe, k-5, k-5 ii, k-5 iis, k5, pentax, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wanted - Acquired: Wein Hot Shoe to Hot Shoe Safe Sync HSHSB 990-560 excanonfd Sold Items 0 08-26-2010 10:56 AM
Hot shoe question Rondec Pentax DSLR Discussion 9 11-03-2009 10:21 PM
Right side hot-shoe - why is it gone? Prognathous Pentax Film SLR Discussion 9 06-22-2009 08:14 AM
Help with hot shoe adapters please! NYpHoToGraphEr Pentax Camera and Field Accessories 22 06-02-2009 12:10 PM



All times are GMT -7. The time now is 11:21 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top