Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-04-2011, 01:20 AM   #1
Pentaxian
Clavius's Avatar

Join Date: Feb 2011
Location: De Klundert
Photos: Gallery
Posts: 4,122
K5 top display problem?

Hi everyone, just got my K5 this saturday. It is an awesome machine! I love it.

Emmediately, I updated it to the latest firmware. (1.03)

But I am noticing something different on the top display. I used to have a K20D that showed the same light metering on top. The difference is, on the K5 the metering sometimes disappears, only to leave 3 blinking dots. Only when I press the +/- button, with which I adjust the exposure, the graph returns to its normal state.

Is this normal?
Is this a problem?
Or is this a fault in my settings?
Anybody seen this before?

Thanks for any help!

04-04-2011, 01:27 AM   #2
Pentaxian
JohnBee's Avatar

Join Date: Sep 2008
Location: front of computer
Posts: 4,620
Same here.
I believe the three dots are some sort of warning with respect to metering.
Never actually looked into it though.

PS, On the K20D, this usually relates to the bracketing settings. However a quick check confirmed this is not how the K-5 display's that setting. I'm confident this is covered somewhere in the book however. I just couldn't be bothered with looking
04-04-2011, 01:46 AM   #3
Pentaxian
Clavius's Avatar

Join Date: Feb 2011
Location: De Klundert
Photos: Gallery
Posts: 4,122
Original Poster
Yes, I noticed that too, as I like to use exposure bracketing for making HDR images. K5 excels in that too. So easy to make handheld HDR's now.

Exposure bracketing is under the up-menu-button. Where you also switch between single shot, HI, remote, etc.

So it seems normal then. But what does it mean?
04-04-2011, 03:08 AM   #4
Site Supporter
i83N's Avatar

Join Date: Mar 2009
Location: Lithuania
Photos: Gallery
Posts: 1,154
try to turning off electronic level

04-04-2011, 03:16 AM   #5
Veteran Member
creampuff's Avatar

Join Date: May 2007
Location: Singapore
Photos: Gallery
Posts: 3,955
QuoteOriginally posted by i83N Quote
try to turning off electronic level
+1 Bingo. Nothing wrong with your camera.
The problem is you need to go through the K-5 Operating Manual. It is under the Rec Mode Menu (4).
04-04-2011, 03:23 AM   #6
Pentaxian
Clavius's Avatar

Join Date: Feb 2011
Location: De Klundert
Photos: Gallery
Posts: 4,122
Original Poster
It IS the electronic level. The display returned to normal when I switched it off.

I do think it's quite a handy feature though.

Thanks guys!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, display, dslr, k-5, k-5 ii, k-5 iis, k5, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-X LCD Problem - Will not display auburntigrs_1 Troubleshooting and Beginner Help 10 08-04-2011 07:29 AM
top screen display purri Troubleshooting and Beginner Help 4 08-08-2010 10:39 PM
Display problem in gallery Iam1of2 General Talk 3 04-17-2010 03:08 PM
Failure to fire/display problem smf Pentax DSLR Discussion 2 11-09-2009 10:51 AM
Image display problem Magpie Pentax Compact Cameras 4 04-05-2009 06:37 PM



All times are GMT -7. The time now is 06:33 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top