Forgot Password
Pentax Camera Forums Home
 

View Poll Results: How many times has your K-5 frozen since installing firmware 1.03?
0 15873.15%
1-5 4822.22%
6-20 52.31%
20+ (i've lost count) 52.31%
Voters: 216. You may not vote on this poll

Reply
Show Printable Version Search this Thread
08-13-2011, 03:16 PM   #46
Senior Member




Join Date: Nov 2008
Location: BC
Posts: 219
FYI I did have another freeze since 1.11. Only once though. Battery had been used but not close to depleted. oh well

08-13-2011, 03:21 PM   #47
Site Supporter
Mallee Boy's Avatar

Join Date: Sep 2006
Location: Hindmarsh Isl. Sth Australia
Photos: Gallery | Albums
Posts: 3,485
I'm a zero.
08-14-2011, 06:27 PM   #48
Inactive Account




Join Date: Feb 2010
Photos: Gallery
Posts: 488
Great news Lee. I am feeling better all the time. I am fixing to give my k-5 a real workout starting in two weeks. Wonderful.
08-15-2011, 10:23 PM   #49
Junior Member




Join Date: Feb 2011
Location: California
Photos: Gallery | Albums
Posts: 30
I went from 1.01 to 1.10. After update it froze up 3 times.

08-15-2011, 11:11 PM   #50
Loyal Site Supporter
imtheguy's Avatar

Join Date: Mar 2009
Location: Virginia Beach
Photos: Gallery | Albums
Posts: 2,950
QuoteOriginally posted by garyk Quote
Great news Lee. I am feeling better all the time. I am fixing to give my k-5 a real workout starting in two weeks. Wonderful.
One more, and my last, update for you should help also. The k-5 has been loaded with 2 clone batteries and properly made the switch on depleted grip battery to the body battery twice recently. So I am pronouncing my gear cured. So its not completely systemic but I will never know if it was the 3rd body or firmware 1.11 that made my day. Now back to life's real problems.
08-18-2011, 04:26 AM   #51
Loyal Site Supporter




Join Date: Mar 2009
Location: Southern Indiana
Photos: Gallery
Posts: 14,962
I have had one freeze when battery was almost at the point of depletion.
05-08-2012, 08:21 PM   #52
Site Supporter
Sandy Hancock's Avatar

Join Date: Feb 2012
Location: Adelaide Hills, South Australia
Photos: Gallery | Albums
Posts: 5,252
I have had my K-5 for about two years, and it happened last night for the first time. It was exceptionally frustrating during a high-pressure concert shoot. Luckily I had my old K10D *and* my K-01 at hand so the night was not lost.
It wouldn't even turn off properly - the top LCD screen would not blank out fully. Basically nothing I could think of on the fly and in the dark would fix it until I took off the battery grip in beter light after the shoot, removed the primary battery and lens, and rebooted from scratch. It seems fine now....
The only untoward finding I could make was the Sigma EX 17-50 I had on it at the time was inadvertently switched to OS "on" at the same time as the in-body SR. Does anyone think that contributed to the problem?
07-17-2012, 09:43 PM   #53
Pentaxian
bossa's Avatar

Join Date: Jul 2011
Location: Adelaide
Posts: 4,538
Is there a chance that the Release Mode is causing these issues? Focus priority for example.
I had two K-5's for almost a year and the lock-up issue seemed cured early on with firmware updates. I have no idea why my new K-5 is doing this BS every day.. and it is when the battery is low. Perhaps the supplied batteries are substandard these days.

07-17-2012, 09:59 PM   #54
Loyal Site Supporter
imtheguy's Avatar

Join Date: Mar 2009
Location: Virginia Beach
Photos: Gallery | Albums
Posts: 2,950
QuoteOriginally posted by bossa Quote
Is there a chance that the Release Mode is causing these issues? Focus priority for example.
I had two K-5's for almost a year and the lock-up issue seemed cured early on with firmware updates. I have no idea why my new K-5 is doing this BS every day.. and it is when the battery is low. Perhaps the supplied batteries are substandard these days.
I'm certainly not in a position to rule anything out but knowing that as long as I swap batteries when they are down to 1/3 or so prevents freezing, its a non issue anymore. However, in honor of your idea, I will change from focus to shutter (?) priority and run all batteries to the end as a fun test. Will report back.
07-17-2012, 10:53 PM   #55
Pentaxian
bossa's Avatar

Join Date: Jul 2011
Location: Adelaide
Posts: 4,538
QuoteOriginally posted by imtheguy Quote
I'm certainly not in a position to rule anything out but knowing that as long as I swap batteries when they are down to 1/3 or so prevents freezing, its a non issue anymore. However, in honor of your idea, I will change from focus to shutter (?) priority and run all batteries to the end as a fun test. Will report back.
Thanks Lee.
07-17-2012, 10:55 PM   #56
Pentaxian
bossa's Avatar

Join Date: Jul 2011
Location: Adelaide
Posts: 4,538
One more idea...

Try different combos of:
Body 1st
Grip 1st
Auto.

I'll do the same but obviously that will take a few days to get through if you aren't shooting all day.
07-22-2012, 05:22 PM   #57
Loyal Site Supporter
imtheguy's Avatar

Join Date: Mar 2009
Location: Virginia Beach
Photos: Gallery | Albums
Posts: 2,950
QuoteOriginally posted by bossa Quote
Thanks Lee.
Fail. I changed the setting, used grip and two Pentax batteries, shot a dozen as both batteries were about depleted then on the 13th shot it locked as usual until both batteries were dropped. It was a good theory to test but...bleh!
07-22-2012, 08:13 PM   #58
Site Supporter




Join Date: Jan 2008
Location: Fly-over, USA
Photos: Gallery
Posts: 1,173
After about 18 months of steady daily use, recently, I sent my K-5 to CRIS for repair on the Pentax extended warranty (B&H $20). I was originally quoted a turn-around time of 3 weeks. The actual turn-around time for the new shutter motor & CLA was about 3 business days. I paid for shipping to their AZ facility. The extended warranty covered the fix and tune-up, plus return shipping to me. Now, the camera works like new. .

So.... If you've got a problem, sent it in for repair. I'm very pleased... Cheers... M
07-23-2012, 12:30 AM   #59
Veteran Member
sb in ak's Avatar

Join Date: Jun 2012
Location: Homer, AK
Photos: Gallery | Albums
Posts: 571
QuoteOriginally posted by Michaelina2 Quote
After about 18 months of steady daily use, recently, I sent my K-5 to CRIS for repair on the Pentax extended warranty (B&H $20). I was originally quoted a turn-around time of 3 weeks. The actual turn-around time for the new shutter motor & CLA was about 3 business days. I paid for shipping to their AZ facility. The extended warranty covered the fix and tune-up, plus return shipping to me. Now, the camera works like new. .

So.... If you've got a problem, sent it in for repair. I'm very pleased... Cheers... M
Holy cow, that's a fast turnaround. I've heard a lot of horror stories about Pentax turnaround times so this is great to hear.

I upgraded to 1.03 when I got the camera a month ago. Initial hiccup that I linked to a bad SD card. Flawless ever since.
07-23-2012, 05:20 AM   #60
Loyal Site Supporter
Tom S.'s Avatar

Join Date: May 2008
Location: S.E. Michigan
Photos: Albums
Posts: 4,238
QuoteOriginally posted by sb in ak Quote
Holy cow, that's a fast turnaround. I've heard a lot of horror stories about Pentax turnaround times so this is great to hear.

I upgraded to 1.03 when I got the camera a month ago. Initial hiccup that I linked to a bad SD card. Flawless ever since.
I think most of the turn around time horror stories originated when so many were sending K-5s back for stain issues, which may have created a log jam. Of course the time is also controlled by parts availability.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, firmware, k-5, k-5 ii, k-5 iis, k5, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-x freezes lescatalpas Pentax DSLR Discussion 8 06-18-2010 07:33 PM
AF-360FGZ Flash Problem (Freezes) yusuf Flashes, Lighting, and Studio 4 04-10-2010 09:06 AM
K200d freezes up while using DaveInGR Pentax DSLR Discussion 5 06-29-2009 02:22 AM
k20d freezes.... ?!?!?! Lanfriendly Pentax DSLR Discussion 35 01-26-2009 03:50 PM
Firmware update and file number luxart Pentax DSLR Discussion 7 01-26-2007 07:13 PM



All times are GMT -7. The time now is 08:55 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top