Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-10-2011, 08:13 PM   #1
Forum Member
Tomzee93's Avatar

Join Date: Dec 2009
Location: Knoxville
Photos: Gallery | Albums
Posts: 71
Viewfinder doesn't match final image

While shooting around with my new K-5 this week, on many occasions I would notice an image I snapped had a crooked crop compared to what I composed in the viewfinder. It seems it will only happen randomly, while working fine part of the time. It also seems to malfunction regardless of whether or not Horizon Correction is enabled. Below, I've attached a quick snap displaying the problem. I saw all of the left corner of the station with a little room to spare in the viewfinder, and the horizon was completely horizontal. This was a handheld shot with Horizon Correction off, but I know for sure my composition wasn't that off as you see below.

Also, with this photo and many others, I've noticed much more image blur than with my K-x. With the K-x I could shoot 1/20 handheld and get a decent shot, but with the K-5 with SR enabled, I'm still finding noticeable motion blur at 1/50 and 1/60.


Will I just have to return it for a new one?

Thanks,

Kevin



06-10-2011, 09:51 PM   #2
Site Supporter
Site Supporter




Join Date: Nov 2010
Location: Long Island, NY
Photos: Gallery
Posts: 593
This is completely a shot in the dark, but is it possible you have lens correction on? I wouldn't imagine it would be that far off, but it might seem to "magnify" a slight error...

Really... completely just a guess...
06-10-2011, 10:05 PM   #3
Site Supporter
Site Supporter




Join Date: Oct 2010
Location: Melbourne
Photos: Gallery
Posts: 2,913
Put the cam on a tripod and do several repeatable tests. Note down on a piece of paper precisely what you see in the viewfinder and camera settings for each shot. Take different lenses and repeat the procedure and take it from there.

Greetings
06-10-2011, 10:11 PM   #4
Veteran Member




Join Date: Jan 2009
Location: Frozen white North
Photos: Albums
Posts: 845
My K10D took shots tilted in the other direction. One member said I was turning the camera while pressing the shutter button, but that wasn't it.

My K-5 has a minor left rotation sometimes. I guess it could be pressing the button but I think because of the SR the sensor has a tendancy to twist.

06-11-2011, 12:15 AM   #5
Inactive Account




Join Date: Jun 2008
Location: Finland
Photos: Albums
Posts: 20
I had my K-5 serviced for exactly the same problem. You can see the sample photos in my profile album. The tilt always occurred only in horizontal position, never in in portrait or upside-down position. The subject was always level with view finder guides and edges. I was not using the horizon correction or sensor position adjustments. After being serviced this particular problem has not returned. Service report said the sensor was adjusted.

But now I have had occasional double images at 1/100s shutter speed, like a real bad shake in vertical direction (repeatable until powering down the camera, while no doubling was visible at 1/40s or 1/160s). This happened even with SR off.

Also sometimes SR seems to totally fail, giving an extremely blurred picture with Stabilized value "5" in Photome EXIF, instead of the usual "Ready" or "Not ready". EDIT: the SR was ready in those cases, with stabilizing times in 2-4 sec range.

My K5 (second body, replaced for stains and then serviced) is also subjectively giving worse, softer IQ than my old K200D, both in jpg and raw, even when using Limited lenses. I've shot hundreds of test pictures while trying to nail down the various problems with the camera. Yesterday I was trying to find AF correction for kit lens shooting a flat target and found out the critical focus is at +10 when shooting @18mm close distance but goes to zero correction when approaching infinity.

I've been trying to like the K5, but feel like I'm wasting time using it when the old K200D is a lot more consistent performer. I seriously suspect my current K5 is a lemon with faulty sensor mechanics but I feel I need to find a concrete, repeatable fault to get it serviced (or preferably replaced) under guarantee again.

Sorry for the rant, but K5 has taken the fun out of photography for me.

Sami

Last edited by lockheed; 06-11-2011 at 12:35 AM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
blur, camera, correction, dslr, horizon, k-5, k-5 ii, k-5 iis, k-x, k5, pentax k-5, viewfinder
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Final Saved Image eco1 Digital Processing, Software, and Printing 11 01-17-2010 12:38 AM
viewfinder doesn't match image - confused MollyM Pentax DSLR Discussion 14 10-12-2009 07:30 AM
final firmware and high-iso image quality mattdm Pentax News and Rumors 28 06-16-2009 12:12 PM
SMC-M 50/1.4: focus in viewfinder and focus on frame don't match kerey Pentax SLR Lens Discussion 7 11-15-2007 09:07 PM
Frustrated with the Final Outcome of the Image? My Suggestion benjikan Photographic Technique 2 05-11-2007 10:47 AM



All times are GMT -7. The time now is 12:48 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top