Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-10-2011, 12:45 PM   #1
Senior Member
melvis2's Avatar

Join Date: Mar 2011
Location: Knoxville TN
Photos: Albums
Posts: 179
K-5 locking up yesterday, now...

My K-5 (less than 6 months old) started locking up the other day and yesterday while at the park shooting it locked up three times. Turned it on today and the mirror is flipping up (multiple times) when I turn it on and no matter what button I press it actuates the mirror untill I pull the battery out and turn it back on. Is it time to send it back to Pentax for repairs? Any advice would be appreciated about these issues! I know that there are several threads on here dealing with the locking up issue but the mirror issue is a new one to me.

07-10-2011, 12:59 PM   #2
Pentaxian
JohnBee's Avatar

Join Date: Sep 2008
Location: front of computer
Posts: 4,620
Can you confirm if this happen with different cards?
07-10-2011, 01:06 PM   #3
Senior Member
melvis2's Avatar

Join Date: Mar 2011
Location: Knoxville TN
Photos: Albums
Posts: 179
Original Poster
Hadn't tried it but I will as soon as I can.
07-10-2011, 01:57 PM   #4
Site Supporter
foxhead's Avatar

Join Date: Oct 2009
Location: Wisconsin
Posts: 55
Does your battery indicator show that your battery is low?
What version firmware do you have installed?

07-10-2011, 02:10 PM   #5
Senior Member
melvis2's Avatar

Join Date: Mar 2011
Location: Knoxville TN
Photos: Albums
Posts: 179
Original Poster
Fresh charge on the battery last night and the firmware version is the latest one they have out whichever that is. I think it is V1.03 ??
07-10-2011, 02:27 PM   #6
Junior Member




Join Date: Jan 2011
Location: Essen, NRW
Photos: Gallery
Posts: 47
I feel your pain... I've only had a lockup once or twice in the 6 months I've had my K-5, but had sporadic and repeating 'mirror flapping' episodes on and off since the ealiest days with the camera. You could try a reset, which did help me - for a while. The symptoms were unpredictable and changing lenses or batteries or cards made no particular difference in my case. Ultimately the body was replaced.
07-10-2011, 02:30 PM   #7
Site Supporter
SpecialK's Avatar

Join Date: Dec 2006
Location: So California
Photos: Gallery
Posts: 14,901
This is a bug.

5 times so far, 3 in the last 2 weeks. Must remove and re-insert battery.
07-11-2011, 08:00 AM   #8
New Member




Join Date: Jun 2011
Location: New England
Posts: 20
Check this thread.......



07-11-2011, 10:39 AM   #9
Site Supporter
Biro's Avatar

Join Date: Jan 2009
Posts: 1,182
You know, I keep going back and forth on buying a K-5. I even had one in my B&H shopping cart and was about to pull the trigger... and backed off. It's not the price, although for a while I was waiting for the body-only to drop to $1000. The K-5 is just too buggy a camera for me. Don't get me wrong: No camera is perfect and competitors like the Nikon D7000 have their share of problems. And I also fully acknowledge that we hear a lot more from people with complaints (on the Internet and everywhere else) than from satisfied customers. And I am not running away from Pentax to another brand. But there's simply too much unfinished busness with the K-5. My heart goes out to the OP and I hope the problem has an easy remedy. Perhaps the K-3 will be the answer. In the meantime, maybe I'll pick up a few more lenses... or update my micro four-thirds kit. A pity... becase I want to want a K-5.
07-11-2011, 12:15 PM   #10
New Member




Join Date: Jun 2011
Location: New England
Posts: 20
wishing i had waited longer

I didn't run out and buy a k7 ( I would have if I had the $$). When the K5 was introduced I thought it was the camera I had waited for. I thought I had waited until all the bugs were discovered and fixed.
Now I'm thinking I should have waited for the next model or just jumped ship.
I've worked with Pentax since the 80's. Very excited when they finally went digital. I loved the k10 and I still have my k20 (works like a champ).
But my K5 is really disappointing me.
07-11-2011, 03:45 PM   #11
Senior Member
melvis2's Avatar

Join Date: Mar 2011
Location: Knoxville TN
Photos: Albums
Posts: 179
Original Poster
I'm not hardly ready to jump ship just yet I just hope that Pentax customer service is decent. I'm going to use my pentax warranty and return this K-5 this time and I've still got my 3 year square trade warranty if this doesn't do the trick. Anyone got any experience with returns and Pentax customer service?
07-12-2011, 11:54 AM   #12
Senior Member
Jim Radcliffe's Avatar

Join Date: Jul 2011
Location: Dallas, Texas
Photos: Gallery
Posts: 163
Mine did exactly the same thing this morning.. mounted a lens and the mirror flopped a couple of times... took a shot and the camera locked up. Pressing the shutter half way did nothing.. it would not focus. Turned the camera off and back on.. still nothing.. took the battery out for about 30 seconds, put it back in and turned the camera on.. worked fine.

There is obviously a real problem here. I wish Pentax would address it in some fashion.. just knowing they are aware of the issue and working on it would be good to hear.
07-12-2011, 06:19 PM   #13
Loyal Site Supporter
TER-OR's Avatar

Join Date: Apr 2009
Location: Dundee, IL
Photos: Gallery | Albums
Posts: 5,831
Mine started freezing this morning, and did it again this afternoon. The only thing which worked was popping the battery out and back in. The camera stuck in "on" and unable to turn off or take photos.
07-12-2011, 07:13 PM   #14
Veteran Member




Join Date: Jul 2010
Photos: Gallery | Albums
Posts: 573
One thing you mentioned Jim was the all over the board need for micro adjustments on some of your lenses. I think I've read a lot more inconsistency reports with micro adjust and lenses with the K5 on this and other Pentax forums. With the K20 or K7 some lenses were +/- 1-3 and with the K5 the same lenses could be +/- 10 and not always in the same direction.

So I'm left wondering if it's more the K5 than the lenses and if it is the body, is it hardware or software?

UPDATE: Sorry for those of you that are confused about my reply to something Jim had stated. I meant to reply to this thread https://www.pentaxforums.com/forums/pentax-k-5-forum/143755-boxedlight-jim-ra...er-review.html instead.

Last edited by RyanW; 07-12-2011 at 09:55 PM. Reason: Trying to add a little clarity to my post
07-14-2011, 01:51 AM   #15
Pentaxian
JohnBee's Avatar

Join Date: Sep 2008
Location: front of computer
Posts: 4,620
QuoteOriginally posted by melvis2 Quote
Hadn't tried it but I will as soon as I can.
Any updates on changing cards?

The reason I ask is because I too went through this with a K20D about a year ago and I learned that SD cards can/and do cause lockups and intermittent problems very similar to what you're written.

And the cause.... (are you ready for this?) was my PC!
Yes.... amazingly enough, my PC was corrupting the cards whenever I would read data off of them. Which had me was convinced that camera was at fault.

Having said that, this doesn't mean that you NEED a card reader in order to encounter similar problems. And so this is why I think it would be worth testing different cards out with your own unit.

The first thing you'd need to do, is establish what actions cause the freeze-up(yes it can be done). In my case, it was turning off the camera, taking out the card, inserting the card, taking a shot, browsing the images afterward and taking another shot! <- took me three days to figure that out.

Anyways, once you've figured out how to make it freeze at will, you can then start troubleshooting by testing the procedure under difference circumstances.
And in my case, I avoided the issue by formatting the card in the camera first.

Anyways, what's more interesting is that my Pentax Canada contact told me that they received many such complains from people with freezing camera's who fell under the unable to replicate clause. Which would result with a part swap for good measure and return. Though likely completely unnecessary in he end.

Anyways, let me know if you uncover any change in your own investigation.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, issue, k-5, k-5 ii, k-5 iis, k5, mirror, pentax k-5, times, yesterday
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
locking the mode dial any tips? adwb Pentax K-r 5 07-01-2011 01:14 AM
K10D AF not locking Geekybiker Troubleshooting and Beginner Help 3 06-02-2011 01:57 PM
Canon offers locking mode dial for 7D and 5DMkII... for $100 deadwolfbones Non-Pentax Cameras: Canon, Nikon, etc. 2 12-02-2010 11:46 PM
'a' lens(es) .. locking focus.. help.. dcmsox2004 Pentax SLR Lens Discussion 4 02-10-2010 01:52 PM
Locking/Latching Shutter Release Cable dosdan Pentax Camera and Field Accessories 4 12-28-2009 10:06 PM



All times are GMT -7. The time now is 01:47 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top