Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-06-2011, 06:49 AM   #1
Forum Member




Join Date: May 2009
Location: Toronto
Posts: 53
What's going on? K5, Av and auto-iso

Hi all,

Just got a K5. Quick question, in aperture-priority, the auto-iso is not engaged, though I have engaged it in the menus. Is this correct? Auto-iso only seems to be working for me in TAv. As I generally only shoot in Av, this is a nuisance.

How would I correct it so that auto-iso is engaged in Av? Auto-Iso worked, kinda, in my K100D Super, and certainly in my Kx.

Thanks,
André

09-06-2011, 06:52 AM   #2
Senior Member




Join Date: Mar 2011
Posts: 140
Set the camera to Av Mode, and while in Av mode, press the iso button followed by the green button. That activates auto iso.
09-06-2011, 06:54 AM   #3
Senior Member
Ivor K Ecks's Avatar

Join Date: Mar 2010
Location: Sydney
Photos: Albums
Posts: 288
Whilst in av mode press the iso button then the green button.

Peter
09-06-2011, 06:54 AM   #4
Senior Member




Join Date: Mar 2011
Posts: 140
Any time you are in auto iso, you can override that feature by pressing the iso button and using the rear wheel to set the iso to whatever you want it to be. The iso button followed by the green button get you back to auto iso.

09-06-2011, 06:58 AM   #5
Senior Member




Join Date: May 2010
Location: Hilversum
Photos: Gallery
Posts: 215
... and I just learned something new! I always wondered why it never changed from the last setting I set it to...
09-06-2011, 07:32 AM   #6
Veteran Member
RioRico's Avatar

Join Date: Jun 2008
Location: Limbo, California
Posts: 11,264
For the same adjustments on the K20D (and probably K10D too): hold down the OK button; then press the Green button to transition to/from auto-ISO, or spin the rear e-dial to adjust ISO level.
09-06-2011, 07:57 AM   #7
Loyal Site Supporter
Rupert's Avatar

Join Date: Sep 2006
Location: Texas
Photos: Gallery | Albums
Posts: 25,005
I didn't know that! Thanks!
Tav is my most used mode.......just a great way to quickly control both speed and aperture. Love it!
Regards!
09-06-2011, 09:38 AM   #8
Forum Member




Join Date: May 2009
Location: Toronto
Posts: 53
Original Poster
Thanks all!

06-18-2012, 07:59 AM   #9
Forum Member
pentax user's Avatar

Join Date: Oct 2010
Posts: 85
does the program line determine what auto iso the camera choose?
or the iso parameter
06-18-2012, 08:43 AM   #10
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,002
QuoteOriginally posted by pentax user Quote
does the program line determine what auto iso the camera choose?
or the iso parameter
There is an "iso-line" also -- go to the status screen (where you can adjust iso range with the dials) and click OK on that and it will go to an separate screen showing just the auto-iso range plus a preference choice for slow-normal-fast auto-iso...
06-18-2012, 08:49 AM   #11
Loyal Site Supporter
i_trax's Avatar

Join Date: Jan 2011
Location: Perth Western Australia
Photos: Gallery | Albums
Posts: 1,119
Auto ISO

QuoteOriginally posted by pentax user Quote
does the program line determine what auto iso the camera choose?
or the iso parameter
very good question.
+ is there anyway to have auto ISO available while using manual KM lenses in M mode?
06-18-2012, 08:52 AM   #12
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,002
QuoteOriginally posted by i_trax Quote
very good question.
+ is there anyway to have auto ISO available while using manual KM lenses in M mode?
Not in M mode. This is where m42s have an advantage since they work in Av mode. (Or Ms if you only shoot wide-open.)
06-18-2012, 09:19 AM   #13
Loyal Site Supporter
i_trax's Avatar

Join Date: Jan 2011
Location: Perth Western Australia
Photos: Gallery | Albums
Posts: 1,119
so there is really NO way to have auto ISO in M mode???
well, I did look everywhere and expected it but still, disappointed!
I do have a lot of M42 lenses ( can use in Av) but still have some old fast zooms in K , bugger!
06-18-2012, 10:07 AM   #14
Pentaxian




Join Date: Oct 2011
Location: Savannah, GA
Posts: 5,002
QuoteOriginally posted by i_trax Quote
so there is really NO way to have auto ISO in M mode???
well, I did look everywhere and expected it but still, disappointed!
I do have a lot of M42 lenses ( can use in Av) but still have some old fast zooms in K , bugger!
M means manual, no auto anything. This is a result of the crippled K-mount the bodies now have -- even though the K1000 could do it, the body no longer knows what the aperture is set at with K & M lenses so auto is not possible. You can use the hack to fool it into thinking it is a 'A' lens, but as noted the linkage of A & M lenses is not the same so it still will not set aperture properly, and you have to fool it some more with EV comp, and it sounds like it is not a linear adjustment?

So we are left with green button metering, and you can do some quick calculations to adjust ISO to get shutter speed you desire.
06-18-2012, 10:09 AM   #15
Veteran Member
FrancisK7's Avatar

Join Date: Sep 2007
Location: Montreal
Photos: Gallery
Posts: 474
QuoteOriginally posted by drec Quote
Hi all,

Just got a K5. Quick question, in aperture-priority, the auto-iso is not engaged, though I have engaged it in the menus. Is this correct? Auto-iso only seems to be working for me in TAv. As I generally only shoot in Av, this is a nuisance.

How would I correct it so that auto-iso is engaged in Av? Auto-Iso worked, kinda, in my K100D Super, and certainly in my Kx.

Thanks,
André
Salut André,

I shot in Av for years but I find TAv to be very cool as well. Do a few shoots in the mode and see how things go. I like it better nowadays!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
auto-iso, av, camera, dslr, k-5, k-5 ii, k-5 iis, k5, pentax k-5
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Auto-ISO] so, is the K5 and Kr brave enough to use max iso? Reportage Pentax K-5 13 10-24-2010 03:30 PM
Auto ISO...do you use it? Reportage Pentax DSLR Discussion 76 09-30-2010 05:27 PM
I love the auto ISO on my K-x jct us101 Pentax DSLR Discussion 32 05-20-2010 05:15 AM
Auto iso - k10d stevewig Pentax DSLR Discussion 10 03-25-2010 05:32 PM
Auto-iso on Pentax K-7 consiglieri Troubleshooting and Beginner Help 5 11-27-2009 12:35 PM



All times are GMT -7. The time now is 01:28 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top