Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-12-2011, 11:25 AM   #31
Site Supporter
aliasant's Avatar

Join Date: Feb 2010
Location: Stockholm
Photos: Gallery | Albums
Posts: 634
Original Poster
Ouch.

I will send it to the same guys in Sweden that replaced my first spotted K5 and they were very nice and understanding. I hope they are quicker then CRIS.
There might be so that many users are getting the same problems and spareparts might not be that easy to get.. I sure hope its not though.
I really hated the 4 weeks waiting for the new K5 last time.

Its nice to know Im not alone but then again... if I had been alone spare parts should have been easy to get..
But maybe they are... We will see soon..

09-20-2011, 01:02 PM   #32
Site Supporter
psychdoc's Avatar

Join Date: Jul 2010
Location: Bham
Photos: Gallery | Albums
Posts: 943
QuoteOriginally posted by aliasant Quote
I hope they are quicker then CRIS.
They better be. Going to be 4 weeks soon now since I send my K5 in. CRIS gave me an update of sorts. They said they needed to replace parts but did not have it in stock. They did not have ETA for when they would get the parts...They didnt tell me what parts needed replacing either. If you get yours back, please update this thread as it will be interesting to know what they found wrong with yours in the similar situation.
09-20-2011, 01:27 PM   #33
Site Supporter
aliasant's Avatar

Join Date: Feb 2010
Location: Stockholm
Photos: Gallery | Albums
Posts: 634
Original Poster
The Pentax Tech guys here in Sweden called me last Friday and told me that they will fix all problems I reported, meaning they will change the electronics and the sensor. Unfortunatly they didnt have the sensor home so they said that they should be able to send it back to me late next week. ( read this week) Good enough for me. Great of them to call with update info. Sure I asked them to call me if there was any update on how long it would take but Im not used to actually receive such a call.
They change the sensor because I have a "huge" dot in it but only when I shot video. I wasnt sure they would exchange it for that but Im really glad they did. Video is pretty useless with a huge dot in it.
They change the electronics because of the shutdown problems even though they couldnt repeat it. Changing the electronics should also fix the mirror flopping issues so Im fairly confident I will get an almost new K-5.

Im thinking about trying to get an extended warranty though. Honestly. Pentax should by me a 2 years warranty extension after all the problems I have had with the K-5. Just to show me that at least they are confident my K-5 wont break down anytime soon.

09-25-2011, 12:07 PM   #34
Site Supporter
psychdoc's Avatar

Join Date: Jul 2010
Location: Bham
Photos: Gallery | Albums
Posts: 943
I got an update from CRIS repairs:

"REPLACED MAIN PCB/FPC"

They have mailed it back out. I should get it back this week. Whew! Hope this fixes the problem. Have been without the camera for a month.

09-27-2011, 01:00 AM   #35
Site Supporter
aliasant's Avatar

Join Date: Feb 2010
Location: Stockholm
Photos: Gallery | Albums
Posts: 634
Original Poster
QuoteOriginally posted by psychdoc Quote
I got an update from CRIS repairs:

"REPLACED MAIN PCB/FPC"

They have mailed it back out. I should get it back this week. Whew! Hope this fixes the problem. Have been without the camera for a month.
Good for you!

Im not being as lucky as I thought.
Called the repair shop yesterday and they are still waiting for the new sensor
Late next week Im off to shoot birds over the weekend.
I will probably end up, not showing of my K5 to a bunch of Canon boys but borrowing a Canon 7d...from one of those guys. Not exactly great from a Pentax Marketing view
09-28-2011, 01:14 AM   #36
Veteran Member
xjjohnno's Avatar

Join Date: Jan 2009
Location: Melbourne Australia
Photos: Gallery
Posts: 2,115
When my K5 failed, the mirror lock up issue, they replaced the CPU. It didn't take long for it to fail again, this time a replacement camera.
Rather then go to the shop I bought the camera from I prefer going directly to the importer/service people seeing as they will be making the final decision.
I hope your K5 works fine on return. Now my old K20D is one super reliable camera, it's getting close to 5 times around with actuations and going strong. My K5 was one of the first in the country so I suspect its problems were due to a rush to provide cameras for the release dates and therefore quality controls cmae second to supplying stock.
09-28-2011, 12:57 PM   #37
nah
Senior Member




Join Date: May 2008
Location: New Westminster, Canada
Photos: Gallery
Posts: 280
QuoteOriginally posted by StepOne Quote
Make a short video, show your serial, camera, explain and show your problems there. Send a CD/DVD with camera also to Pentax Service. Don't "try" to make it work, if it failed, will fail again. Get it fixed or one that work for the price you paid for.
That is a brilliant idea. Sometimes it so hard to explain the problem and not knowing if the person on the other fully understands what you're getting at.
10-03-2011, 11:35 AM   #38
Site Supporter
aliasant's Avatar

Join Date: Feb 2010
Location: Stockholm
Photos: Gallery | Albums
Posts: 634
Original Poster
Today I got the camera back.
Finally.
They swapped the Sensor, Electronics and the Mirror "mechanics"

Now it works great, sometimes.

Seems to have serious strange focusing issues using fast manual lenses indoors under tungsten.
I thought that was fixed?
Its also not very consistent.

Using a slower Bigma AF lens gives perfect results but using my manual 50/1.4 85/1.8 or even a 35/2.8 front focuses like crazy but my Kiron 105/2.8 Macro is spot on.
Shooting my 350/4,5 and focus ends up 5-10 meters behind.

Going to call the rep shop tomorrow and ask what the heck they did to it.

10-03-2011, 11:40 AM   #39
Veteran Member
crewl1's Avatar

Join Date: Jul 2010
Location: Los Angeles, CA
Photos: Gallery | Albums
Posts: 9,796
Did you verify the firmware version?
10-03-2011, 11:41 AM   #40
Site Supporter
aliasant's Avatar

Join Date: Feb 2010
Location: Stockholm
Photos: Gallery | Albums
Posts: 634
Original Poster
QuoteOriginally posted by crewl1 Quote
Did you verify the firmware version?
First thing I checked.
Firmware 1.11
10-04-2011, 02:42 AM   #41
Site Supporter
aliasant's Avatar

Join Date: Feb 2010
Location: Stockholm
Photos: Gallery | Albums
Posts: 634
Original Poster
This is turning out to be a real nightmare.

Last night I was testing the camera and it just behaved stranger and stranger.
The 100% crop below shows some kind of double exposure thing.
Few occations I got sharp shots but never using slower times then perhaps 1/500
using wide lenses like a 35/2.8 front focuses alot. Manual shot from stand and distance about 40cm.
The camera gives the red focus indicator + the green steady light. I take the shot and focus is between 2 and 10cm infront.
I use a longer 350/4.5 and focus ends up way behind.

This morning while having the service guy on the phone i switched on LW and the whole camera was ticking like a bomb and the liveview image was jumping up and down.
That would explain the weird double exposures.
Sending it back of course.

Another 3 weeks waiting and this will be the 3rd time I send the camera back since I bought it late december last year.

Im so thinking about getting a Canon but what am i going to do with all my Pentax lenses? I would have to sell everything except the Adaptalls and m42s
Attached Images
   
10-04-2011, 04:16 AM   #42
Site Supporter
psychdoc's Avatar

Join Date: Jul 2010
Location: Bham
Photos: Gallery | Albums
Posts: 943
QuoteOriginally posted by aliasant Quote
Going to call the rep shop tomorrow and ask what the heck they did to it.
QuoteOriginally posted by aliasant Quote
Another 3 weeks waiting and this will be the 3rd time I send the camera back since I bought it late december last year.

Im so thinking about getting a Canon but what am i going to do with all my Pentax lenses? I would have to sell everything except the Adaptalls and m42s
Sorry!
I am having recurrent problems with mine upon return from so called 'repair'. I am thinking along the same lines regarding my 'system'. See my thread below:

https://www.pentaxforums.com/forums/pentax-k-5-forum/161159-help-help-k5-not-...back-cris.html

Do you think Hoya got out because they 'bombed' with the K5 and it was the last straw?
10-04-2011, 04:34 AM   #43
Site Supporter
aliasant's Avatar

Join Date: Feb 2010
Location: Stockholm
Photos: Gallery | Albums
Posts: 634
Original Poster
QuoteOriginally posted by psychdoc Quote
Sorry!
I am having recurrent problems with mine upon return from so called 'repair'. I am thinking along the same lines regarding my 'system'. See my thread below:

https://www.pentaxforums.com/forums/pentax-k-5-forum/161159-help-help-k5-not-...back-cris.html

Do you think Hoya got out because they 'bombed' with the K5 and it was the last straw?
I think Hoya knew what laid ahead for sure.
Sorry to hear im not alone.
10-11-2011, 08:43 AM   #44
Site Supporter
aliasant's Avatar

Join Date: Feb 2010
Location: Stockholm
Photos: Gallery | Albums
Posts: 634
Original Poster
Today I got the K5 back and this time they calibrated it using one of my old manual lenses.
They also tightened the focus screen springs and placed shims in there.
The Liew View "jumping around" problems seems gone now. They say they adjusted the cabel from the electronics... what ever that means.

Anyways.

Finally I have the camera I thought I bought back in december.
So far, testing perhaps 100 shots they all have been spot on. Truly excellent!
After a disasterous weekend using a friends Canon 7D, a Canon 550 and even a Canon 5D MkII Im so glad Im back with my Pentax!
The Canons are probably great in someone elses hands but not in mine. At least using manual focusing.
But I have to say, using that 5DmkII was pretty sweet. The resolution is fantastic and now they are about to release what I guess will be 5DmkIV ?
I am tempted..... Just to get that resolution.
One of the guys I went shooting with used it with a 500m f4,5 Canon lens and he got some incredible shots.
My shots using old manual lenses on an unknown camera didnt stand a chance. I was in another ball game sitting on the bench...

Now that I got my K5 back Im hungry for revenge
10-11-2011, 10:44 PM   #45
Junior Member




Join Date: Oct 2009
Location: marion va
Photos: Gallery
Posts: 28
sounds like I wrote your post.........ugh! mine was shipped to pentax repair center in AZ October 21......was given a return date of November.UGH! wish I had bought a canon!

good luck!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, dslr, k-5, k-5 ii, k-5 iis, k5, lens, mirror, pentax k-5, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutter Life v.s. Half-Press AF Life? shang Pentax K-5 16 02-06-2011 12:41 AM
Shutter release half-press issue? dcshooter Pentax K-5 15 01-19-2011 03:33 PM
ZX-5 display going haywire with shutter button half press Nick Siebers Pentax Film SLR Discussion 6 07-26-2010 08:28 PM
Hair-trigger half-press on k-7 shutter release... weak spring? Timichango Pentax DSLR Discussion 5 02-24-2010 03:09 PM
Time from button press to shutter open - building a light trigger amoringello Pentax DSLR Discussion 6 06-14-2008 07:02 PM



All times are GMT -7. The time now is 10:26 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top